Bug 77 - Change request: add limited permissions to change bugs reported by others
Change request: add limited permissions to change bugs reported by others
Status: CLOSED CURRENTRELEASE
Product: Bugzilla
Classification: Community
Component: Bugzilla General (Show other bugs)
2.1r
All Linux
medium Severity medium (vote)
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1998-11-15 09:24 EST by Aleksey Nogin
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-22 09:19:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Aleksey Nogin 1998-11-15 09:24:39 EST
As far as I understand, current Bugzilla allows people to
change only their bug reports and only while it is "NEW". I
think the following capabilities are also necessary (most
important first):

1) Be able to add/remove my address to/from the CC list of
any bug. This would help people who experience the same
problem or just curious.

2) Be able to add additional information to bug reports.
That will allow people to give you some more specific
information so that you can find and fix the bug faster.
That would also allow expert users to explain why the
problem reported by a novice user is not a bug (so that you
do not have to spend your time doing that).

3) Be able to mark my bug report as "FIXED". That would
allow a user who have realized that his/her problem happened
because he/she was doing something wrong to close the bug.
Comment 1 Need Real Name 1998-11-19 12:29:59 EST
#2 is in place, the others are on the "TODO" list
Comment 2 Aleksey Nogin 1998-12-09 04:05:59 EST
#1 and #3 are still not implemented in Bugzilla 2.1rC

Another missing functionality  is the ability to reopen the bug (many
bug reports have comments from RedHat developers saying "try this fix
and if it does not work, reopen the bug report", but Bugzilla does not
allow to reopen a bug report)

Also, it would be nice to be able to change the "Version" field (when
someone upgrades and them verifies that the bug is still there). Well,
actually, it would be nice to be able to change any field :-)
Comment 3 Need Real Name 1999-01-19 11:39:59 EST
users can reopen a bugs, and a generic "add/remove" is in place for
the cc list.
Comment 4 Need Real Name 1999-03-22 09:19:59 EST
I think that #3 should be handled by adding a "never mind" comment,
because a user may have stumbled across a true bug but have come up
with a work around in the mean time and lost interest in the true fix.

Besides, the incidence of "never mind" bugs has been low enough that
this is not a big issue at this time.

Note You need to log in before you can comment on or make changes to this bug.