Bug 77003 - ks hd install fails when RedHat Directory on "/"
ks hd install fails when RedHat Directory on "/"
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.3
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 90599 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-30 15:16 EST by P Jones
Modified: 2007-03-26 23:58 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-04 22:59:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description P Jones 2002-10-30 15:16:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
installer gives error "Requested Partiiton Does Not Exist", partition exists

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. partition hda1 to 5G
2. copy cd's to /rhsource
3. start install, using kicstart below
	

Additional info:

The last message on tty3 is "* hda1 is a protected partition"

Here's the kickstart file:
install
text
lang English
langsupport     English
keyboard us
mouse generic3ps/2 --device psaux --emulthree
rootpw password
firewall --medium
authconfig --enableshadow --enablemd5
bootloader
network --bootproto dhcp
part / --fstype ext2 --noformat --onpart hdc2
harddrive --partition hdc1 --dir /rhsource
%packages
@ Base


I'm using the kernel and initrd-everything.img from /images/pxeboot/
I'm passing the arguement "ks=hd:hda1/kickstart" to the installer.
It is finding the second stage.
Comment 1 P Jones 2002-10-30 22:04:50 EST
I also tried copying the .iso files to the /rhsource directory.  I did find
those files, but errored with the same message
Comment 2 P Jones 2002-10-30 22:06:18 EST
oh, and the iso mediacheck passes, and can install fine if located on a diffrent
partition. (one not marked for use in the ks file with a "part" line)
Comment 3 P Jones 2002-10-31 11:17:42 EST
Corrections: 
I tired this on hda as well as hdc; I put hda in steps to reproduce, I ment to
be consistant with the kickstart file posted. Please assume I ment hdc.

The kickstart pasted was the one that worked, to get the one that failed,
replace the part line with this:
part / --fstype ext2 --noformat --onpart hdc1
Comment 4 Michael Fulbright 2003-01-31 14:13:14 EST
This currently fails when trying to mount the harddrive images to merge the RPM
headers.

To correct this problem will require some special case code that recognizes when
the source for the harddrive install images is also a partition used for the
installed system.
Comment 5 Michael Fulbright 2003-05-06 17:02:52 EDT
This affects installs and upgrades.
Comment 6 Michael Fulbright 2003-05-12 14:44:27 EDT
*** Bug 90599 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2004-10-04 22:59:42 EDT
This should be happier in newer releases.

Note You need to log in before you can comment on or make changes to this bug.