Bug 770039 - nfs:posix-compliane fails for link tests
nfs:posix-compliane fails for link tests
Status: CLOSED DUPLICATE of bug 765518
Product: GlusterFS
Classification: Community
Component: object-storage (Show other bugs)
pre-release
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gaurav
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-23 01:26 EST by Saurabh
Modified: 2016-01-19 01:09 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-09 07:37:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Saurabh 2011-12-23 01:26:08 EST
Description of problem:

the link test from the posix-testsuite
Version-Release number of selected component (if applicable):

Test Summary Report
-------------------
/opt/qa/tools/posix-testsuite/tests/chown/00.t   (Wstat: 0 Tests: 171 Failed: 3)
  Failed tests:  77, 84, 88
/opt/qa/tools/posix-testsuite/tests/link/00.t    (Wstat: 0 Tests: 82 Failed: 2)
  Failed tests:  72, 79
Files=185, Tests=1979, 94 wallclock secs ( 0.64 usr  0.28 sys +  6.04 cusr  8.29 csys = 15.25 CPU)
Result: FAIL

real    1m33.923s
user    0m6.738s
sys     0m8.600s


How reproducible:-

every run.
Steps to Reproduce:
1.run posix-compliance test over nfs mount
2. volume should be distribute replicate,
3.
  
Actual results:
link test fails

Expected results:
link test should fail

Additional info:
[root@node130 ~]# /root/330/inst/sbin/gluster volume info dist-rep
 
Volume Name: dist-rep
Type: Distributed-Replicate
Status: Started
Number of Bricks: 2 x 2 = 4
Transport-type: tcp
Bricks:
Brick1: 10.1.11.130:/export-xfs/dr
Brick2: 10.1.11.131:/export-xfs/drr
Brick3: 10.1.11.130:/export-xfs/ddr
Brick4: 10.1.11.131:/export-xfs/ddrr
[root@node130 ~]# 

logs from nfs.log

[2011-12-23 00:56:19.116324] I [nfs.c:745:init] 0-nfs: NFS service started
[2011-12-23 00:56:19.116426] I [common-utils.c:1940:get_mem_size] 0-common-utils: Total Mem: 2104270848
[2011-12-23 00:56:19.116440] I [io-cache.c:1555:check_cache_size_ok] 0-dist-rep-quick-read: Max cache size is 2104270848
[2011-12-23 00:56:19.116477] I [common-utils.c:1940:get_mem_size] 0-common-utils: Total Mem: 2104270848
[2011-12-23 00:56:19.116505] I [io-cache.c:1555:check_cache_size_ok] 0-dist-rep-io-cache: Max cache size is 2104270848
[2011-12-23 00:56:19.126935] W [graph.c:325:_log_if_unknown_option] 0-nfs-server: option 'rpc-auth.auth-glusterfs' is not recognized
[2011-12-23 00:56:19.126980] W [graph.c:325:_log_if_unknown_option] 0-nfs-server: option 'rpc-auth-allow-insecure' is not recognized
[2011-12-23 00:56:19.126992] W [graph.c:325:_log_if_unknown_option] 0-nfs-server: option 'transport-type' is not recognized
[2011-12-23 00:56:19.127019] I [client.c:1937:notify] 0-dist-rep-client-0: parent translators are ready, attempting connect on transport
[2011-12-23 00:56:19.129776] I [client.c:1937:notify] 0-dist-rep-client-1: parent translators are ready, attempting connect on transport
:$
[2011-12-23 01:17:23.333386] W [client3_1-fops.c:554:client3_1_rmdir_cbk] 0-dist-rep-client-1: remote operation failed: Permission denied
[2011-12-23 01:17:23.333405] W [nfs3.c:3513:nfs3svc_rmdir_cbk] 0-nfs: 6e01cffa: /fstest_a59aa2d42141f8cf856b1f8517def6a6/fstest_28745ea0e825369f5042973f96b5bb12/fstest_eaf666aa188d3d9b46d0e41bfbf4e326 => -1 (Permission denied)
[2011-12-23 01:17:26.572745] W [client3_1-fops.c:177:client3_1_symlink_cbk] 0-dist-rep-client-2: remote operation failed: Permission denied. Path: /fstest_9d0be9f0bdbf1bf416a4573865011b51/fstest_12bc7b631a6f0465e3805a6167abd938/fstest_edce7087009e2118c76575ad390239f4
[2011-12-23 01:17:26.572830] W [client3_1-fops.c:177:client3_1_symlink_cbk] 0-dist-rep-client-3: remote operation failed: Permission denied. Path: /fstest_9d0be9f0bdbf1bf416a4573865011b51/fstest_12bc7b631a6f0465e3805a6167abd938/fstest_edce7087009e2118c76575ad390239f4
[2011-12-23 01:17:26.572865] W [nfs3.c:2884:nfs3svc_symlink_cbk] 0-nfs: a402cffa: /fstest_9d0be9f0bdbf1bf416a4573865011b51/fstest_12bc7b631a6f0465e3805a6167abd938/fstest_edce7087009e2118c76575ad390239f4 => -1 (Permission denied)
[2011-12-23 01:17:35.836832] W [client3_1-fops.c:509:client3_1_unlink_cbk] 0-dist-rep-client-0: remote operation failed: Permission denied
[2011-12-23 01:17:35.837028] W [client3_1-fops.c:509:client3_1_unlink_cbk] 0-dist-rep-client-1: remote operation failed: Permission denied
[2011-12-23 01:17:35.837050] W [nfs3.c:3338:nfs3svc_remove_cbk] 0-nfs: 3304cffa: /fstest_16dfecc0daa9091324082337c8b6c28e/fstest_9ef604489896d0b36720ecbfbe1b495a => -1 (Permission denied)
[2011-12-23 01:17:36.858777] W [client3_1-fops.c:509:client3_1_unlink_cbk] 0-dist-rep-client-0: remote operation failed: Permission denied
[2011-12-23 01:17:36.859000] W [client3_1-fops.c:509:client3_1_unlink_cbk] 0-dist-rep-client-1: remote operation failed: Permission denied
[2011-12-23 01:17:36.859029] W [nfs3.c:3338:nfs3svc_remove_cbk] 0-nfs: 3c04cffa: /fstest_16dfecc0daa9091324082337c8b6c28e/fstest_9ef604489896d0b36720ecbfbe1b495a => -1 (Permission denied)
[2011-12-23 01:17:42.783136] W [client3_1-fops.c:509:client3_1_unlink_cbk] 0-dist-rep-client-2: remote operation failed: Permission denied
[2011-12-23 01:17:42.783317] W [client3_1-fops.c:509:client3_1_unlink_cbk] 0-dist-rep-client-3: remote operation failed: Permission denied
[2011-12-23 01:17:42.783338] W [nfs3.c:3338:nfs3svc_remove_cbk] 0-nfs: 5205cffa: /fstest_089e24e6fa388e6208cb0c2cd629b0de/fstest_371fda1f26b21529950161b0003feaf7/fstest_0a3e9cfc4bdf0663bafab87133f71d36 => -1 (Permission denied)
Comment 1 Vijay Bellur 2011-12-26 06:46:31 EST
How is this bug different from 765518?
Comment 2 Vijaykumar Koppad 2012-01-09 06:58:05 EST
This happens in glusterfs-3.3.0qa19 also.
Comment 3 Gaurav 2012-01-09 07:37:31 EST

*** This bug has been marked as a duplicate of bug 765518 ***

Note You need to log in before you can comment on or make changes to this bug.