Bug 77005 - RFE: Alternatives system for RPM packets
RFE: Alternatives system for RPM packets
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: comps (Show other bugs)
8.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Tim Powers
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-30 15:56 EST by Petri T. Koistinen
Modified: 2007-03-26 23:58 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-08 14:47:39 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petri T. Koistinen 2002-10-30 15:56:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.6 (X11; Linux i686; U;) Gecko/20020830

Description of problem:
I want to use Postfix, I don't want to use Sendmail. Why can't I just install
Postfix and leave Sendmail uninstalled.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run RH 8.0 installation from CD.
2. Configure setup.
3. Select Postfix.

	

Actual Results:  Sendmail installed per default.

Expected Results:  No sendmail, if I only want Postfix.

Additional info:
Comment 1 Tim Powers 2002-11-08 13:14:56 EST
This is because sendmail is in the base component for the installation. You may
be able to unselect sendmail in the individual package selection screens.

Tim
Comment 2 Petri T. Koistinen 2002-11-08 13:48:03 EST
Why Sendmail is a base component?
Comment 3 Tim Powers 2002-11-08 14:03:46 EST
It's in the base component because it's generally a good idea to allow the
machine to send mail. We had to choose something as the default, and because
postfix was only recently added to Red Hat Linux we chose sendmail to be the
default.

Again, you should be able to unselect sendmail in the individual package
selection screen.

Tim
Comment 4 Petri T. Koistinen 2002-11-08 14:47:31 EST
OK. I hope Postfix will be the default someday. Personaly I don't even bother to
learn how to use Sendmail. I find Postfix much easier to use.

So you don't have option in your configuration system which says:

- System must have mail transport agent
- Postfix provides mta
- Sendmail provides mta

Choose what you want, but make sure there is mta. You know, this is kind of
Debian way of thinking, I think.
Comment 5 Tim Powers 2002-11-08 15:41:10 EST
We already do that. Both sendmail and postfix Provide: smtpdaemon.

Also, adding an option to the install to select which daemon you want for every
installation is probably not going to happen since we are actually trying to
simplify things. 

Like I said before, you can unselect sendmail in the individual package selection.

Tim
Comment 6 Petri T. Koistinen 2002-11-10 06:49:41 EST
OK, sorry. I will not reopen this bug again. Still, I feel that Postfix is
simple to use for beginners as well as professionals. I hope that Postfix and
Sendmail could switch places as Red Hat's installation defaults in future.

Yes, I know that I can unselect sendmail in individual package selection, but
how many of new users want to mess around with it. Installing Red Hat Linux is
already scary enough experience. (Well, don't worry, it's getting less scary
with each new major release, if you keep up the good work.)

You are correct, it's probably no the time yet. Thanks for being forbearing
towards me and thanks for your time.

Petri

P.S. GUI for Postfix configuration could be overkill, it's quite simple even
without it. On the other hand would it hurt anyone... I don't know.

Note You need to log in before you can comment on or make changes to this bug.