This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 770083 - NFS does not work in F16
NFS does not work in F16
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Steve Dickson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-23 05:22 EST by Adel Gadllah
Modified: 2011-12-28 15:49 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2011-12-23 06:15:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Adel Gadllah 2011-12-23 05:22:32 EST
Description of problem:

After upgrading to F16 (from F15) I can no longer export nfs shares and mount them on clients.

Version-Release number of selected component (if applicable):
nfs-utils-1.2.5-3.fc16.x86_64

How reproducible:

Always

Steps to Reproduce:
1. Export an fs
2. Start the nfs services (nfs-server.service)
3. Try to mount
4. Connection timeout
  
Actual results:

Can't mount.

Expected results:

Be able to mount the shares.

Additional info:

ystemctl status nfs-server.service 
nfs-server.service - NFS Server
	  Loaded: loaded (/lib/systemd/system/nfs-server.service; enabled)
	  Active: active (running) since Fri, 23 Dec 2011 11:18:45 +0100; 5s ago
	 Process: 4212 ExecStopPost=/usr/sbin/exportfs -f (code=exited, status=0/SUCCESS)
	 Process: 4211 ExecStop=/usr/sbin/rpc.nfsd 0 (code=exited, status=0/SUCCESS)
	 Process: 4223 ExecStartPost=/usr/lib/nfs-utils/scripts/nfs-server.postconfig (code=exited, status=0/SUCCESS)
	 Process: 4221 ExecStartPost=/usr/sbin/rpc.mountd $RPCMOUNTDOPTS (code=exited, status=0/SUCCESS)
	 Process: 4220 ExecStart=/usr/sbin/rpc.nfsd $RPCNFSDARGS ${RPCNFSDCOUNT} (code=exited, status=0/SUCCESS)
	 Process: 4219 ExecStartPre=/usr/sbin/exportfs -r (code=exited, status=0/SUCCESS)
	 Process: 4217 ExecStartPre=/usr/sbin/rpc.rquotad $RPCRQUOTADOPTS (code=exited, status=0/SUCCESS)
	 Process: 4215 ExecStartPre=/usr/lib/nfs-utils/scripts/nfs-server.preconfig (code=exited, status=0/SUCCESS)
	Main PID: 4218 (rpc.rquotad)
	  CGroup: name=systemd:/system/nfs-server.service
		  ├ 4218 /usr/sbin/rpc.rquotad
		  └ 4222 /usr/sbin/rpc.mountd


exportfs -rav
exporting *:/opt
exporting *:/home/linux/Dokumente/ICnova/project_build_arm/adb1004g45b5inch/root

Firewall is disabled for testing purposes.

mount -v just spits out tons of

mount.nfs: mount(2): Connection refused
mount.nfs: trying text-based options 'vers=4,addr=192.168.2.200,clientaddr=192.168.2.23'
Comment 1 Adel Gadllah 2011-12-23 05:28:33 EST
Hmm adding "-o mountproto=tcp"  to the mount command seems to work. The question is still ... why?
Comment 2 Adel Gadllah 2011-12-23 06:03:55 EST
After a reboot it does not work again not even when passing mountproto=tcp and the service seems to be running fine.
Comment 3 Adel Gadllah 2011-12-23 06:15:13 EST
mv /etc/sysconfig/nfs.rpmnew /etc/sysconfig/nfs fixed it ..
Comment 4 Steve Dickson 2011-12-27 17:40:28 EST
(In reply to comment #3)
> mv /etc/sysconfig/nfs.rpmnew /etc/sysconfig/nfs fixed it ..

Yes... unfortunately, the new systemd init scrips did not allow 
any backwards compatibility with the already established
init scripts... My apologies for your frustration...
Comment 5 Adel Gadllah 2011-12-28 15:49:44 EST
(In reply to comment #4)
> (In reply to comment #3)
> > mv /etc/sysconfig/nfs.rpmnew /etc/sysconfig/nfs fixed it ..
> 
> Yes... unfortunately, the new systemd init scrips did not allow 
> any backwards compatibility with the already established
> init scripts... My apologies for your frustration...

Ah OK, that explains it. That should have been documented somewhere though (Release Notes?).

But anyway it works fine now ;)

Note You need to log in before you can comment on or make changes to this bug.