Bug 770153 - vdsm-bootstrap should not set max_cstate=1 to the kernel command line
vdsm-bootstrap should not set max_cstate=1 to the kernel command line
Status: CLOSED CURRENTRELEASE
Product: oVirt
Classification: Community
Component: vdsm (Show other bugs)
unspecified
x86_64 Linux
medium Severity medium
: ---
: 3.2
Assigned To: Alon Bar-Lev
virt
: EasyFix
Depends On: 770122 770123 bootstrap-rewrite
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-23 11:49 EST by Yaniv Kaul
Modified: 2016-04-26 22:08 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 770123
Environment:
Last Closed: 2013-02-15 01:46:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yaniv Kaul 2011-12-23 11:49:32 EST
+++ This bug was initially created as a clone of Bug #770123 +++

+++ This bug was initially created as a clone of Bug #770122 +++

Description of problem:
max_cstate=1 was added to kernel defaults for oVirt Node due to a large portion of hardware having issues w/ time sync in kvm.

As long as hardware has a stable/constant tsc, it should be safe to remove this restriction.  People with older hardware can always manually add it back in.

Need to remove it from vdsm-bootstrap:

[root@rhevm-3 vdsm-bootstrap]# grep -R cstate *
vds_bootstrap.py:            args += ['processor.max_cstate=1']
Comment 1 Dan Kenigsberg 2012-06-25 03:41:16 EDT
This was requested by rhev-3.0 bug 579705, so I'd be keeping max_cstate for rhel6.

http://gerrit.ovirt.org/5658
Comment 2 Yaniv Kaul 2012-06-26 07:42:20 EDT
(In reply to comment #1)
> This was requested by rhev-3.0 bug 579705, so I'd be keeping max_cstate for
> rhel6.

I believe it's no longer needed.
Note that ovirt-node have removed it already - https://bugzilla.redhat.com/show_bug.cgi?id=770123
And the logic to set/remove it - https://bugzilla.redhat.com/show_bug.cgi?id=770123#c2


> 
> http://gerrit.ovirt.org/5658
Comment 3 Dan Kenigsberg 2012-06-26 08:54:25 EDT
I am not at all sure that ovirt-node has satisfied Andy's requirement of https://bugzilla.redhat.com/show_bug.cgi?id=770123#c1

.. we check /proc/cpuinfo flags for constant_tsc and if it's NOT present we add the max_cstate otherwise we leave it off.

This is a logic that vdsmd does not have. Sp this patch is partial.
Comment 4 Alon Bar-Lev 2012-10-23 05:16:10 EDT
I agree this should not be used. Will be removed unless someone has any new input.

Thanks!
Comment 5 Alon Bar-Lev 2012-11-28 03:46:33 EST
new bootstrap will warn if no constant_tsc.
Comment 6 Itamar Heim 2013-01-16 11:08:36 EST
3.2 beta built, moving to ON_QA status to allow testing

Note You need to log in before you can comment on or make changes to this bug.