This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 770189 - [abrt] evolution-data-server-3.2.2-1.fc16: link_before: Process /usr/libexec/e-addressbook-factory was killed by signal 11 (SIGSEGV)
[abrt] evolution-data-server-3.2.2-1.fc16: link_before: Process /usr/libexec/...
Status: CLOSED DUPLICATE of bug 755791
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:63117e72447e9c4bebf6933fb7d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-23 19:13 EST by Chandana De Silva
Modified: 2012-01-02 06:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-02 06:19:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: dso_list (6.66 KB, text/plain)
2011-12-23 19:13 EST, Chandana De Silva
no flags Details
File: maps (31.16 KB, text/plain)
2011-12-23 19:13 EST, Chandana De Silva
no flags Details
File: backtrace (46.88 KB, text/plain)
2011-12-23 19:13 EST, Chandana De Silva
no flags Details

  None (edit)
Description Chandana De Silva 2011-12-23 19:13:07 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/libexec/e-addressbook-factory
crash_function: link_before
executable:     /usr/libexec/e-addressbook-factory
kernel:         3.1.5-6.fc16.x86_64
pid:            2240
pwd:            /
reason:         Process /usr/libexec/e-addressbook-factory was killed by signal 11 (SIGSEGV)
time:           Sat 24 Dec 2011 10:51:20 AM EST
uid:            1000
username:       chandana

backtrace:      Text file, 48005 bytes
dso_list:       Text file, 6822 bytes
maps:           Text file, 31912 bytes

build_ids:
:80d1527bdbaa66a7f4467a3432a25332fb76758a
:16053224897d5961128b8819407b87a74957908a
:bfa713fda01e5880fdba7387f6053e350dcf9738
:93364c86bf2f54aa5a2f1a700ca2166aef574f1f
:3ed9e61c2b7e707ce244816335776afa2ad0307d
:aa733447f84020c94a66814e501a36e248cbb43d
:34b7964512e7197292839abae625453763c6f25b
:89017ab0b75e533e4294f74ee8f7db3daceea536
:e3c88cb9ea428bd61f4064dbd53acae2d396a1ec
:7f61fb1b16866dcb14575dfc5dda295a8c416071
:87461d97d0ba0bd94e4d74ff0879190b67b326c5
:545fac2346ca24589041213956b7f22f7e91c139
:e21d62a3622c3edb824299d83be75df8fdddbe53
:5e8c36ca13a4af14fa6b1b45a0dbfb43ed6aed6e
:0ce9819eb7014de7e72eec40979dd5e4d6566dca
:ab59942678bcdecb23756804dcd0aac63ccc1669
:7947878389f6a313c0b930260e12fd44bd6746fc
:17ef36c4f4e8918b9ab1c2e3eaca7c9b584ad5cb
:086b8d05a2fb6992634d2e22e69d7aefe16cf390
:9b36eee79f50b968c4582c73692f0c2d91385be2
:30af62b93e2ab7dbaf39c52e346cd52101b4b590
:e002e6f692473d7ae6549f1ae42926d5b5e3398e
:9d1209fc79304f03cc839de1c0036c61b48dfff8
:701c8cd759f655fae8c102c779740becb24ee061
:638db099ff5fb986d1a092629d1bb1dca5be4904
:e5429e0905bedecc534b057783916ba43e06a66e
:b520dba85e987a6e66449eaf57c7fc5b21acb333
:a2748a35d28f083d729359d9c06bc85158408ee3
:c6739204320eb15bdcdba039a2b183298170403e
:8264e35452b2a930c1b9b092b87f32d42d69d8c5
:08bf94ada10df76cac3eb5485f19d48b9730e203
:d8b26823ae85343e974130aa7fb18f8e7a8f6c3d
:7109859fdd4912a7b36eea239079fd72b5575d18
:0f0c9eed63ed279ceb0aef109eff8bcbb351e4bb
:30208e0b20e44d2ff5a27b7ce643cfd03f307b4a
:4953d1f613914126bccceb3cb96386647ffba9df
:dcef47a6e015071bb788871cb6cb197d166fc2f8
:ccadad4ec7dab3bb6abc23f9d4cdf53ff01cb235
:376567a97a463859c28334ed8bf71262183298c2
:c953cbce426d612e0a04f33a1c43aae08680c700
:e2e67b3ae2579e1667b73ad385f61552931024e9
:0406dc93e5d067b98e166932201a6df7dde67888
:6502dd4813f98137c70e6e05cc43828f5c2263c1
:162e7de5d553b39188a8e39ab7bc40cf6072a901
:b0eabf9093defbfdd0857ea3ed1a4563b743434e
:b492837dde7c9f97bee3e688aa7a2eb39ed1666a
:cfd6e064ee1dde01516f4a3bb8b2b52e155464ad
:88c273fb9c6869c8e7a2c4ef8e1a8f10b50d1b49
:be507c791e34415e8f42f0e6030c889b2895cf9a
:34968f9aed7f031bcd801c4516f4eb68127ca239
:0fccce2fdb46650674ef5b64fae5f25f14c88e08
:74ae88173658854383370d76513e8146f1b5e933
:29c869a877c1ceade9538f84f5ec70c3901b66b3
:83cb4627bed5c756d4e6f23badf8a6b4b042f4e6
:e5d7ac2dfe435e205e491f7ce827563859fca4f4
:e567a4b498aa9dfc484575e666a17925f0944318
:88d586ed67ebe5227b761b4ab2e02433f29c840f
:3e2404bd469800afd61eda83d0292a2165ef0db0
:c81f03cf64b912fe473d4f12bf5889125825dcc4
:921b64859b34786348daf376801c05efbf9bac81
:202a875ea0fbf03fbf53345f8e333d923d9b6fc9
:6c827aed0fb6c93acb6c2329a62f452ff83e9052
:37c84b700d36cedd486ab4259d4fb8cd34eb0d6b
:30d222cbaa7087ff6613d2737d967fc570ec8a72
:15c25336f081a938b4c7bdc13478f620c614242d
:de59715846d228b19cc9d61c82af83c1395acae1
:650b733aecfb9c46bdfc023661f19244a278df04
:e02146cbd7b3747790cf4808baa58dc78c2e0042
:b0a2d0b4c09d819887ec7d711c8cf3977a074c4f
:1bdafc3d69c38e71f953133d77c2e17f6c38d0cf
:daec0ba0ef53c9f6c098d2b47f5974fa82aff498
:0949b493f01e0553822be3bd14def9dbe79b804f
:38cc9759fa35484f171a9905448e4a946eaa48d9
:df8e8e6d51fc9736c06237ef2c62e4f9c0f057c6

comment:
:THis problem seems to happen only when the computer is re-started or booted up from cold. I suspec that this due to the network connections not being up at the time. I use a wireless connection.
:I lookd through systemctl, but could not find a unit for evolution-data server. How does it get started up, and how can it be delayed untill a network connection is available ?

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-vp84elRY8Q,guid=3ed13a04d8379b42c20842a50000001e
:XDG_SESSION_COOKIE=63c8e694c7d81160555d76230000000c-1324684276.205132-226248255
:XDG_RUNTIME_DIR=/run/user/chandana
:DISPLAY=:0
:DESKTOP_SESSION=gnome
:SSH_AUTH_SOCK=/tmp/keyring-gRVppj/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1910,unix/unix:/tmp/.ICE-unix/1910
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:GDMSESSION=gnome
:XDG_VTNR=1
:USERNAME=chandana
:XDG_SESSION_ID=2
:GPG_AGENT_INFO=/tmp/keyring-gRVppj/gpg:0:1
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-vp84elRY8Q,guid=3ed13a04d8379b42c20842a50000001e
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-chandana-4Z9Ykf/database
:USER=chandana
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=1906
:SHLVL=1
:GDM_LANG=en_US.utf8
:PWD=/home/chandana
:GNOME_KEYRING_CONTROL=/tmp/keyring-gRVppj
:LANG=en_US.utf8
:_=/usr/bin/dbus-launch
:LOGNAME=chandana
:HOME=/home/chandana

event_log:
:2011-12-24-11:12:15> Analyzing coredump 'coredump'
:2011-12-24-11:12:15  All 74 debuginfo files are available
:2011-12-24-11:12:15  Generating backtrace
:2011-12-24-11:12:16  Backtrace is generated and saved, 48005 bytes
:2011-12-24-11:12:26> GConf directory /apps/e-addressbook-factory does not exist
:2011-12-24-11:12:26* (exited with 1)
:2011-12-24-11:12:27> Smolt profile successfully saved

smolt_data:
:
:
:General
:=================================
:UUID: d5a67d92-3763-4f49-91f5-05f19134d29d
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 4389.72
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM) i7-2720QM CPU @ 2.20GHz
:CPU Stepping: 7
:CPU Family: 6
:CPU Model Num: 42
:Number of CPUs: 8
:CPU Speed: 2201
:System Memory: 7867
:System Swap: 9983
:Vendor: Dell Inc.
:System: Latitude E6520 01
:Form factor: Laptop
:Kernel: 3.1.5-6.fc16.x86_64
:SELinux Enabled: 0
:SELinux Policy: targeted
:SELinux Enforce: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:260:4136:1172) pci, agpgart-intel, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:257:4136:1172) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:(4631:5111:4136:1172) pci, firewire_ohci, FIREWIRE, N/A
:(4631:33569:4136:1172) pci, sdhci-pci, BASE, N/A
:(4631:33585:4136:1172) pci, None, STORAGE, N/A
:(32902:7202:4136:1172) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:10282:4136:1172) pci, ahci, RAID, Mobile 82801 SATA RAID Controller
:(32902:7247:4136:1172) pci, None, PCI/ISA, QM67 Express Chipset Family LPC Controller
:(32902:5378:4136:1172) pci, e1000e, ETHERNET, 82579LM Gigabit Network Connection
:(32902:7188:4136:1172) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 3
:(32902:7213:4136:1172) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:4136:1172) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:7226:4136:1172) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(32902:130:32902:4897) pci, iwlagn, NETWORK, Centrino Advanced-N 6205 AGN
:(32902:294:4136:1172) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:4136:1172) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:4136:1172) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7186:4136:1172) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 2
:(32902:7200:4136:1172) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(4318:3592:4136:5268) pci, snd_hda_intel, MULTIMEDIA, HDMI Audio stub
:(4318:4182:4136:5268) pci, nouveau, VIDEO, GF108 [Quadro NVS 4200M]
:(32902:7194:4136:1172) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 6
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 12901535 11309808 11178786 3276800 3077543 3077543
:/dev/sda5 /home ext4 4096 4096 15223351 12712894 11939544 3874176 3719435 3719435
:/dev/sda2 /boot ext4 1024 1024 495844 409402 383802 128016 127741 127741
:

var_log_messages:
:Dec 21 08:58:50 localhost abrt[2372]: Saved core dump of pid 2335 (/usr/libexec/e-addressbook-factory) to /var/spool/abrt/ccpp-2011-12-21-08:58:50-2335 (63811584 bytes)
:Dec 21 09:21:00 localhost abrt[3177]: Saved core dump of pid 2381 (/usr/libexec/e-addressbook-factory) to /var/spool/abrt/ccpp-2011-12-21-09:21:00-2381 (41861120 bytes)
:Dec 21 09:31:18 localhost abrt[3923]: Saved core dump of pid 3885 (/usr/libexec/e-addressbook-factory) to /var/spool/abrt/ccpp-2011-12-21-09:31:18-3885 (54878208 bytes)
:Dec 21 11:18:32 localhost abrt[6099]: Saved core dump of pid 4696 (/usr/libexec/e-addressbook-factory) to /var/spool/abrt/ccpp-2011-12-21-11:18:32-4696 (46903296 bytes)
:Dec 21 15:04:19 localhost abrt[9905]: Saved core dump of pid 6718 (/usr/libexec/e-addressbook-factory) to /var/spool/abrt/ccpp-2011-12-21-15:04:19-6718 (37441536 bytes)
:Dec 21 15:04:46 localhost abrt[9944]: Saved core dump of pid 9918 (/usr/libexec/e-addressbook-factory) to /var/spool/abrt/ccpp-2011-12-21-15:04:46-9918 (37441536 bytes)
:Dec 21 18:11:51 localhost abrt[13306]: Saved core dump of pid 9957 (/usr/libexec/e-addressbook-factory) to /var/spool/abrt/ccpp-2011-12-21-18:11:51-9957 (46845952 bytes)
:Dec 21 18:18:45 localhost abrt[13430]: Saved core dump of pid 13423 (/usr/libexec/e-addressbook-factory) to /var/spool/abrt/ccpp-2011-12-21-18:18:45-13423 (55382016 bytes)
:Dec 21 18:18:57 localhost abrt[13467]: Not dumping repeating crash in '/usr/libexec/e-addressbook-factory'
:Dec 21 23:07:35 localhost abrt[16867]: Saved core dump of pid 15973 (/usr/libexec/e-addressbook-factory) to /var/spool/abrt/ccpp-2011-12-21-23:07:35-15973 (55439360 bytes)
:Dec 21 23:25:13 localhost abrt[17439]: Saved core dump of pid 16962 (/usr/libexec/e-addressbook-factory) to /var/spool/abrt/ccpp-2011-12-21-23:25:13-16962 (55439360 bytes)
:Dec 22 06:40:49 localhost abrt[18453]: Saved core dump of pid 17590 (/usr/libexec/e-addressbook-factory) to /var/spool/abrt/ccpp-2011-12-22-06:40:49-17590 (46850048 bytes)
:Dec 22 13:58:02 localhost abrt[25905]: Saved core dump of pid 25898 (/usr/libexec/e-addressbook-factory) to /var/spool/abrt/ccpp-2011-12-22-13:58:02-25898 (55406592 bytes)
:Dec 22 15:14:32 localhost abrt[27111]: Saved core dump of pid 27103 (/usr/libexec/e-addressbook-factory) to /var/spool/abrt/ccpp-2011-12-22-15:14:32-27103 (63942656 bytes)
:Dec 24 10:51:20 localhost abrt[2281]: Saved core dump of pid 2240 (/usr/libexec/e-addressbook-factory) to /var/spool/abrt/ccpp-2011-12-24-10:51:20-2240 (62513152 bytes)
Comment 1 Chandana De Silva 2011-12-23 19:13:11 EST
Created attachment 549398 [details]
File: dso_list
Comment 2 Chandana De Silva 2011-12-23 19:13:13 EST
Created attachment 549399 [details]
File: maps
Comment 3 Chandana De Silva 2011-12-23 19:13:16 EST
Created attachment 549400 [details]
File: backtrace
Comment 4 Milan Crha 2012-01-02 06:19:13 EST
Thanks for a bug report. There had been reported a similar bug report already, thus I'm marking it as a duplicate.

*** This bug has been marked as a duplicate of bug 755791 ***

Note You need to log in before you can comment on or make changes to this bug.