Bug 770210 - [abrt] kernel: irq 18: nobody cared (try booting with the "irqpoll" option) ASM108x
[abrt] kernel: irq 18: nobody cared (try booting with the "irqpoll" option) A...
Status: CLOSED DUPLICATE of bug 755956
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:ba6daa46d5ffe19f77778bc2291...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-24 05:42 EST by Paul Ecoffet
Modified: 2012-03-05 16:58 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-05 16:58:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Ecoffet 2011-12-24 05:42:55 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.5-6.fc16.x86_64 root=/dev/mapper/vg_paul-lv_root ro rd.lvm.lv=vg_paul/lv_swap rd.md=0 rd.dm=0 quiet LANG=fr_FR.UTF-8 SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 rd.lvm.lv=vg_paul/lv_root KEYTABLE=fr-latin1
event_log:      2011-12-24-11:40:01> Smolt profile successfully saved
kernel:         3.1.5-6.fc16.x86_64
reason:         irq 18: nobody cared (try booting with the "irqpoll" option)
time:           ven. 23 déc. 2011 15:13:06 CET

backtrace:
:irq 18: nobody cared (try booting with the "irqpoll" option)
:Pid: 0, comm: kworker/0:0 Not tainted 3.1.5-6.fc16.x86_64 #1
:Call Trace:
: <IRQ>  [<ffffffff810dc87d>] __report_bad_irq+0x3d/0xe0
: [<ffffffff810dcb3d>] note_interrupt+0x16d/0x220
: [<ffffffff810da8f9>] handle_irq_event_percpu+0xa9/0x220
: [<ffffffff810daab4>] handle_irq_event+0x44/0x70
: [<ffffffff810dd49f>] handle_fasteoi_irq+0x5f/0xf0
: [<ffffffff810151e9>] handle_irq+0x49/0xa0
: [<ffffffff815df2da>] do_IRQ+0x5a/0xe0
: [<ffffffff815d4d6e>] common_interrupt+0x6e/0x6e
: <EOI>  [<ffffffff8130539b>] ? intel_idle+0xcb/0x120
: [<ffffffff8130537d>] ? intel_idle+0xad/0x120
: [<ffffffff81483fc6>] cpuidle_idle_call+0xc6/0x280
: [<ffffffff81012225>] cpu_idle+0xc5/0x120
: [<ffffffff815c1003>] start_secondary+0x260/0x262

smolt_data:
:
:
:Général
:=================================
:UUID: 8ad6e368-c867-486c-bfcf-79ccc1a55430
:SE: Fedora release 16 (Verne)
:Niveau d'exécution par défaut: Unknown
:Langue: fr_FR.utf8
:Plateforme: x86_64
:BogoMIPS: 6585.76
:Fabricant du processeurs: GenuineIntel
:Modèle de processeur: Intel(R) Core(TM) i5-2500 CPU @ 3.30GHz
:Stepping du processeur: 7
:Famille de processeur: 6
:Modèle du processeur: 42
:Nombre de processeurs: 4
:Vitesse du processeur: 3301
:Mémoire du système: 3938
:Swap du système: 5983
:Fabricant: MSI
:Système: MS-7681 2.0
:Type d'ordinateur: Desktop
:Noyau: 3.1.5-6.fc16.x86_64
:SELinux activé: 1
:Stratégie SELinux: targeted
:SELinux strict: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(4332:33128:5218:30337) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(32902:256:5218:30337) pci, None, HOST/PCI, 2nd Generation Core Processor Family DRAM Controller
:(32902:257:5218:30337) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:(4147:404:5218:30337) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(32902:7202:5218:30337) pci, i801_smbus, SERIAL, 6 Series/C200 Series Chipset Family SMBus Controller
:(32902:7168:5218:30337) pci, ata_piix, STORAGE, 6 Series/C200 Series Chipset Family 4 port SATA IDE Controller
:(32902:7238:5218:30337) pci, None, PCI/ISA, P67 Express Chipset Family LPC Controller
:(32902:7176:5218:30337) pci, ata_piix, STORAGE, 6 Series/C200 Series Chipset Family 2 port SATA IDE Controller
:(6523:9058:5218:30337) pci, ahci, STORAGE, JMB362 AHCI Controller
:(32902:7213:5218:30337) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2
:(32902:7206:5218:30337) pci, ehci_hcd, USB, 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1
:(32902:7226:5218:30337) pci, None, SIMPLE, 6 Series/C200 Series Chipset Family MEI Controller #1
:(4147:404:5218:30337) pci, xhci_hcd, USB, uPD720200 USB 3.0 Host Controller
:(4358:12356:5218:26653) pci, firewire_ohci, FIREWIRE, VT6306/7/8 [Fire II(M)] IEEE 1394 OHCI Controller
:(6987:37283:5218:30337) pci, ahci, STORAGE, N/A
:(32902:7188:5218:30337) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 3
:(32902:7190:5218:30337) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:5218:30337) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7196:5218:30337) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 7
:(32902:7198:5218:30337) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 8
:(32902:9294:5218:30337) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:7200:5218:30337) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(4098:43608:6023:43608) pci, snd_hda_intel, MULTIMEDIA, Juniper HDMI Audio [Radeon HD 5700 Series]
:(4098:26808:6023:8202) pci, radeon, VIDEO, Juniper [Radeon HD 5700 Series]
:(32902:7194:5218:30337) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 6
:(6945:4224:0:0) pci, None, PCI/PCI, N/A
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_paul-lv_root / ext4 4096 4096 12901535 10821687 10166327 3276800 3000175 3000175
:/dev/sda3 /boot ext4 1024 1024 495844 412184 386584 128016 127789 127789
:/dev/mapper/vg_paul-lv_home /home ext4 4096 4096 36285600 31028051 29184851 9216000 9146339 9146339
:
Comment 1 Josh Boyer 2012-01-24 14:09:41 EST
Can you attach the output of dmesg and /proc/interrupts?  Also, do you see this on the 3.1.9 or 3.2.1 kernel updates?
Comment 2 Josh Boyer 2012-02-02 15:38:00 EST
Your motherboard is using the ASM108x PCI bridge.  There is a problem identified with this particular chip upstream that might be causing this issue:

http://thread.gmane.org/gmane.linux.kernel/1245767
Comment 3 Josh Boyer 2012-03-05 16:57:57 EST
We're going to consolidate all of these bugs with the impacted hardware into a single bug.  The latest F15 and F16 kernel updates that should hit the mirrors soon have a patch to at least fall back to the irqpoll method when this happens.  Hopefully it results in a bit better experience for you.
Comment 4 Josh Boyer 2012-03-05 16:58:33 EST

*** This bug has been marked as a duplicate of bug 755956 ***

Note You need to log in before you can comment on or make changes to this bug.