Bug 770292 - Provide native systemd service
Provide native systemd service
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: jabberd (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adrian Reber
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 751869
  Show dependency treegraph
 
Reported: 2011-12-25 12:39 EST by Jóhann B. Guðmundsson
Modified: 2012-03-24 17:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-24 17:17:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Native systemd unit file for jabberd (418 bytes, text/plain)
2011-12-25 12:41 EST, Jóhann B. Guðmundsson
no flags Details
Native systemd unit file for jabber client to server (260 bytes, text/plain)
2011-12-25 12:42 EST, Jóhann B. Guðmundsson
no flags Details
Native systemd unit file for jabber router (260 bytes, text/plain)
2011-12-25 12:42 EST, Jóhann B. Guðmundsson
no flags Details
Native systemd unit file for jabber server to server (260 bytes, text/plain)
2011-12-25 12:43 EST, Jóhann B. Guðmundsson
no flags Details
Native systemd unit file for jabber im session manager (195 bytes, text/plain)
2011-12-25 12:44 EST, Jóhann B. Guðmundsson
no flags Details
The missing jabber router service (215 bytes, text/plain)
2012-03-21 18:14 EDT, Jóhann B. Guðmundsson
no flags Details

  None (edit)
Description Jóhann B. Guðmundsson 2011-12-25 12:39:44 EST
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd
https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jóhann B. Guðmundsson 2011-12-25 12:41:34 EST
Created attachment 549497 [details]
Native systemd unit file for jabberd

This is just a dummy unit that controls the startup and stopping of all the other units and keeps backwards compatibility to the legacy sysv init script
Comment 2 Jóhann B. Guðmundsson 2011-12-25 12:42:17 EST
Created attachment 549498 [details]
Native systemd unit file for jabber client to server
Comment 3 Jóhann B. Guðmundsson 2011-12-25 12:42:54 EST
Created attachment 549499 [details]
Native systemd unit file for jabber router
Comment 4 Jóhann B. Guðmundsson 2011-12-25 12:43:30 EST
Created attachment 549500 [details]
Native systemd unit file for jabber server to server
Comment 5 Jóhann B. Guðmundsson 2011-12-25 12:44:55 EST
Created attachment 549501 [details]
Native systemd unit file for jabber im session manager
Comment 6 Jóhann B. Guðmundsson 2011-12-25 12:46:54 EST
To test this drop all the files into /etc/systemd/system directory and run 
systemctl daemon-reload

systemctl start jabberd.service

systemctl status jabberd.service jabberd-router.service jabberd-sm.service jabberd-c2s.service jabberd-s2s.service

systemctl stop jabberd.service

systemctl status jabberd.service jabberd-router.service jabberd-sm.service jabberd-c2s.service jabberd-s2s.service
Comment 7 Adrian Reber 2012-03-21 08:13:05 EDT
Thanks for your help. Trying to integrate those unit files into the package.
Comment 8 Adrian Reber 2012-03-21 08:19:46 EDT
Do you still have the jabber-router.service file. The one attached here is wrong.
Comment 9 Jóhann B. Guðmundsson 2012-03-21 11:21:13 EDT
Hmm what do you mean wrong?
Comment 10 Adrian Reber 2012-03-21 17:41:58 EDT
Clicking on "Native systemd unit file for jabber router" downloads the s2s file and not the router file. The description is correct but the file seems to be the same as the server to server file.
Comment 11 Jóhann B. Guðmundsson 2012-03-21 18:14:14 EDT
Created attachment 571879 [details]
The missing jabber router service
Comment 12 Adrian Reber 2012-03-24 17:17:16 EDT
Thanks a lot for your systemd scripts. Included in: jabberd-2.2.14-3.fc18

Note You need to log in before you can comment on or make changes to this bug.