Bug 770301 - xulrunner builds include OpenWebapps.js, breaking add-on installation in Fedora
Summary: xulrunner builds include OpenWebapps.js, breaking add-on installation in Fedora
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xulrunner
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 781803 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-25 21:15 UTC by Heiko Adams
Modified: 2012-02-06 11:18 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-02-06 11:18:34 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 713468 None None None Never

Description Heiko Adams 2011-12-25 21:15:11 UTC
Description of problem:
After updating firefox to v9.0 it's no longer possible to install addons from addons.mozilla.org. When opening the page of an addon the list of similar addons on the bottom of the page isn't loading and firefox error log shows 3 errors for that page.

Version-Release number of selected component (if applicable):
firefox-9.0-3.fc16.x86_64
xulrunner-9.0-2.fc16.x86_64

How reproducible:
allways

Steps to Reproduce:
1. start firefox
2. navigate to i.e. https://addons.mozilla.org/de/firefox/addon/ghostery/?src=hp-dl-featured
3. try to install the addon
  
Actual results:
Installing addons is impossible and Firefox error log shows 3 errors:
1) Fehler: uncaught exception: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: resource:///components/OpenWebapps.js :: OpenWebapps :: line 50"  data: no]

2) Fehler: z.button is undefined
Quelldatei: https://static-ssl-cdn.addons.mozilla.net/de/firefox/addons/buttons.js?b=01ad944
Zeile: 13

3) Fehler: $(".install").installButton is not a function
Quelldatei: https://static-ssl-cdn.addons.mozilla.net/media/js/impala-min.js?build=01ad944
Zeile: 1

Expected results:
It should be possible to install addons from addons.mozilla.org

Additional info:

Comment 1 Robin Green 2012-01-15 10:32:20 UTC
*** Bug 781803 has been marked as a duplicate of this bug. ***

Comment 2 Glen Black 2012-01-18 20:25:31 UTC
For others having this problem and awaiting a solution, a temporary workaround when trying to install add-ons is to open the "Download Now" button in a new tab (click with middle mouse button); for some reason, that works and allows the add-on to be installed.

Comment 3 Heiko Adams 2012-02-02 19:11:37 UTC
Problem seems to be solved with Firefox 10/Xulrunner 10

Comment 4 Martin Stransky 2012-02-06 11:18:34 UTC
Thanks, should be fixed now, FF10 is in rawhide/updates.


Note You need to log in before you can comment on or make changes to this bug.