Bug 770341 - unable to create guestOS using KVM on a glusterfs mount. (Works for nfs mount)
unable to create guestOS using KVM on a glusterfs mount. (Works for nfs mount)
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: fuse (Show other bugs)
mainline
Unspecified Unspecified
medium Severity high
: ---
: ---
Assigned To: Csaba Henk
: Triaged
Depends On:
Blocks: 848336
  Show dependency treegraph
 
Reported: 2011-12-26 00:29 EST by Shwetha Panduranga
Modified: 2013-07-24 13:10 EDT (History)
2 users (show)

See Also:
Fixed In Version: glusterfs-3.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 848336 (view as bug list)
Environment:
Last Closed: 2013-07-24 13:10:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Strace of client-glusterfs process during the creation of guestos. (706.73 KB, application/octet-stream)
2011-12-26 00:29 EST, Shwetha Panduranga
no flags Details

  None (edit)
Description Shwetha Panduranga 2011-12-26 00:29:43 EST
Created attachment 549540 [details]
Strace of client-glusterfs process during the creation of guestos.

Description of problem: 
Unable to create a guestOS using KVM on a glusterfs mount. The same works for the nfs mount

Version-Release number of selected component (if applicable):
glusterfs 3.3.0qa17

How reproducible:


Steps to Reproduce:
1. Create a volume with replica 2-> vm_replica
2. Mount to volume(vm_replica) from client (Ex: mount-type:glusterfs, mountdir:/mnt/vmstore) 
3. Create a new guestOS using virt-manager. 
4. Select the storage location /mnt/vmstore while creating guestos. 
5. Complete the all steps for creting new guest. Final stage, reports an error. 
  
Actual results:

Unable to complete install: 'internal error Process exited while reading console log output: char device redirected to /dev/pts/2
qemu-kvm: -drive file=/mnt/vmstore/cent.img,if=none,id=drive-ide0-0-0,format=raw,cache=none: could not open disk image /mnt/vmstore/cent.img: Invalid argument
'

Traceback (most recent call last):
  File /usr/share/virt-manager/virtManager/asyncjob.py, line 44, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File /usr/share/virt-manager/virtManager/create.py, line 1903, in do_install
    guest.start_install(False, meter=meter)
  File /usr/lib/python2.6/site-packages/virtinst/Guest.py, line 1223, in start_install
    noboot)
  File /usr/lib/python2.6/site-packages/virtinst/Guest.py, line 1291, in _create_guest
    dom = self.conn.createLinux(start_xml or final_xml, 0)
  File /usr/lib64/python2.6/site-packages/libvirt.py, line 2064, in createLinux
    if ret is None:raise libvirtError('virDomainCreateLinux() failed', conn=self)
libvirtError: internal error Process exited while reading console log output: char device redirected to /dev/pts/2
qemu-kvm: -drive file=/mnt/vmstore/cent.img,if=none,id=drive-ide0-0-0,format=raw,cache=none: could not open disk image /mnt/vmstore/cent.img: Invalid argument


Expected results:

Successful creation of the guestos

Additional info:
Comment 1 shishir gowda 2012-09-13 03:21:38 EDT
Creation of vm's fails due to ownership issues on the volume.
Changing the ownership to 36:36 on the volume (by changing these manually on all exports of the volume) fixes this issue.
Can you please check if the issues gets fixed?

Note You need to log in before you can comment on or make changes to this bug.