Bug 7706 - FTP installation dies with 'CWD ': command not understood
FTP installation dies with 'CWD ': command not understood
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
sparc Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-12-09 12:32 EST by Bryce Denney
Modified: 2015-01-07 18:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-02-09 16:05:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bryce Denney 1999-12-09 12:32:14 EST
I'm having trouble with a RedHat 6.1 network installation on sparc.
I'm using anonymous FTP, and it reads the second stage ramdisk, etc.
but when it gets to the point of reading "hdlist" it dies with a
python exception, saying: 'CWD ' command not understood.

Here is part of the stack trace.  This is typed by hand from another
machine, so it's not complete.

... some stuff omitted ...
File "/tmp/lib/python1.5/site-packages/urlinstall.py", line 45, in
readHeaders u
rl=urllib.urlopen(self.baseUrl + "/RedHat/base/hdlist")
File "/tmp/lib/python1.5/site-packages/urlinstall.py", line 59, in urlopen
retur
n _urlopener.open(url)
File "/tmp/lib/python1.5/site-packages/urlinstall.py", line 157, in open
return
getattr(self, name)(url)
File "/tmp/lib/python1.5/site-packages/urlinstall.py", line 378, in
open_ftp sel
f.ftpcache[key] = \
File "/tmp/lib/python1.5/site-packages/urlinstall.py", line 559, in
__init__ sel
f.init()
File "/tmp/lib/python1.5/site-packages/urlinstall.py", line 568, in init
self.ft
p.cwd(dir)
File "/var/tmp/python-root/usr/lib/python1.5/ftplib.py", line 441, in cwd
File "/var/tmp/python-root/usr/lib/python1.5/ftplib.py", line 233, in
voidcmd
File "/var/tmp/python-root/usr/lib/python1.5/ftplib.py", line 288, in
voidresp
File "/var/tmp/python-root/usr/lib/python1.5/ftplib.py", line 281, in
getresp IO
Error: [Errno ftp error] 500 'CWD ': command not understood.

This error is exactly what our FTP server says if you tell it "CWD "
with no directory name.  Other people on newsgroups have noticed the
same problem in sparc installations via FTP.

In comp.os.linux.misc Paul Gazella <pgazella@neo.rr.com> wrote:
> I'm also having the same problem with my IPX.  I have RedHat 6.0
> currently on it.  I tried the FTP install only to bail with an exception
> when gathering the package information.  I then ftp'ed the entire sparc
> directories onto my hard disk and proceeded to install from my hard
> drive.  Guess what?  Same exception at the same point.  I've tried doing
> an upgrade, a graphical install and a text install.  No luck.  I'm about
> ready to look for another solution if I can't find the answer.  If
> anyone knows, I would appreciate it also.

> Chetan Ahuja wrote
>
> Every instal dies with some error or the other in the python   scripts.
It die
s
> at different points in the process everytime I try   it. It throws out a
stack
> trace of the python functions but the   failures  seem to be rather
strange.
> e.g on an ftp install attempts,   the error was that the ftp server did
not
> understand the CWD command ( I can't remember the exact wording). Now
that's
> simply   ridiculous. It's a standard wu-ftpd running on another linux
machine
> running redhat 6.0.
Comment 1 Bryce Denney 1999-12-09 17:37:59 EST
Workaround for this bug, and others related to 6.1 FTP installation problems:

Boot on the 6.0 install disk, but give it the path to a RedHat 6.1 FTP site!
You get an error about install3.tr not found, and comps has the wrong
version number, but you can go ahead with the menu interface and install
it anyway.  Ugly, but it works.
Comment 2 petr 1999-12-29 03:48:59 EST
I verified that ProFTPD upto last version 1.2.0pre9 returns:
500 'CWD ' is an unknown command.
wu-ftpd version 2.4.2 shows response to "pwd"
550 /home/ftp: No such file or directory.
and to "pwd " (with space)
500 'CWD ': command not understood.
wu-ftpd version 2.5 accepts "pwd", but shows response to "pwd "
500 'CWD ': command not understood.
wu-ftpd 2.6, Microsoft FTP service 3.0, 4.0, 5.0 accepts both "pwd" and "pwd "
By recommendation is to avoid semding cwd without directory name.
Comment 3 Jay Turner 2000-02-09 16:05:59 EST
This issue is resolved in the latest installer from RawHide.

Note You need to log in before you can comment on or make changes to this bug.