Bug 770631 - [abrt] xen-4.1.2-2.fc16: tempfile.py:201:_get_default_tempdir:IOError: [Errno 2] No usable temporary directory found in ['/tmp', '/var/tmp', '/usr/tmp', '/']
[abrt] xen-4.1.2-2.fc16: tempfile.py:201:_get_default_tempdir:IOError: [Errno...
Status: CLOSED DUPLICATE of bug 741042
Product: Fedora
Classification: Fedora
Component: xen (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Xen Maintainance List
Fedora Extras Quality Assurance
abrt_hash:4a2edb4f6d7b268aa9652db07e2...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-28 01:30 EST by geminic86
Modified: 2012-01-03 17:24 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-03 17:24:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description geminic86 2011-12-28 01:30:05 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        /usr/bin/python /usr/sbin/xm list
event_log:      2011-12-28-01:51:13> Smolt profile successfully saved
executable:     /usr/sbin/xm
kernel:         3.1.6-1.fc16.i686.PAEdebug
reason:         tempfile.py:201:_get_default_tempdir:IOError: [Errno 2] No usable temporary directory found in ['/tmp', '/var/tmp', '/usr/tmp', '/']
time:           Wed 28 Dec 2011 01:49:57 AM EST
uid:            0
username:       root

backtrace:
:tempfile.py:201:_get_default_tempdir:IOError: [Errno 2] No usable temporary directory found in ['/tmp', '/var/tmp', '/usr/tmp', '/']
:
:Traceback (most recent call last):
:  File "/usr/sbin/xm", line 5, in <module>
:    from xen.xm import main
:  File "/usr/lib/python2.7/site-packages/xen/xm/main.py", line 51, in <module>
:    from xen.xend.server.DevConstants import xenbusState
:  File "/usr/lib/python2.7/site-packages/xen/xend/server/DevConstants.py", line 21, in <module>
:    xoptions = XendOptions.instance()
:  File "/usr/lib/python2.7/site-packages/xen/xend/XendOptions.py", line 566, in instance
:    inst = XendOptionsFile()
:  File "/usr/lib/python2.7/site-packages/xen/xend/XendOptions.py", line 158, in __init__
:    self.configure()
:  File "/usr/lib/python2.7/site-packages/xen/xend/XendOptions.py", line 176, in configure
:    self.loglevel_default))
:  File "/usr/lib/python2.7/site-packages/xen/xend/XendLogging.py", line 135, in init
:    logfilename = tempfile.mkstemp("-xend.log")[1]
:  File "/usr/lib/python2.7/tempfile.py", line 286, in mkstemp
:    dir = gettempdir()
:  File "/usr/lib/python2.7/tempfile.py", line 254, in gettempdir
:    tempdir = _get_default_tempdir()
:  File "/usr/lib/python2.7/tempfile.py", line 201, in _get_default_tempdir
:    ("No usable temporary directory found in %s" % dirlist))
:IOError: [Errno 2] No usable temporary directory found in ['/tmp', '/var/tmp', '/usr/tmp', '/']
:
:Local variables in innermost frame:
:dirlist: ['/tmp', '/var/tmp', '/usr/tmp', '/']
:e: OSError(13, 'Permission denied')
:name: '3e9U7A'
:seq: 0
:filename: '/3e9U7A'
:flags: 131266
:namer: <tempfile._RandomNameSequence instance at 0x92a730c>
:dir: '/'

smolt_data:
:
:
:General
:=================================
:UUID: aafd4db8-42a2-45a9-89f9-4ff2d41e25cf
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: i686
:BogoMIPS: 5985.77
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Xeon(TM) CPU 3.00GHz
:CPU Stepping: 4
:CPU Family: 15
:CPU Model Num: 6
:Number of CPUs: 8
:CPU Speed: 3000
:System Memory: 4006
:System Swap: 5311
:Vendor: Dell Inc.
:System: PowerEdge 1900 
:Form factor: Main Server Chassis
:Kernel: 3.1.6-1.fc16.i686.PAEdebug
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:9721:0:0) pci, pcieport, PCI/PCI, 5000 Series Chipset PCI Express x8 Port 6-7
:(32902:9713:32902:32902) pci, None, HOST/PCI, 5000 Series Chipset Reserved Registers
:(32902:9703:0:0) pci, pcieport, PCI/PCI, 5000 Series Chipset PCI Express x4 Port 7
:(32902:9712:4136:440) pci, None, HOST/PCI, 5000 Series Chipset FSB Registers
:(32902:9712:4136:440) pci, i5000_edac, HOST/PCI, 5000 Series Chipset FSB Registers
:(32902:9712:4136:440) pci, None, HOST/PCI, 5000 Series Chipset FSB Registers
:(32902:9688:32902:32902) pci, None, HOST/PCI, 5000P Chipset Memory Controller Hub
:(4454:259:0:0) pci, None, PCI/PCI, EPB PCI-Express to PCI-X Bridge
:(32902:9856:4136:440) pci, ata_piix, STORAGE, 631xESB/632xESB/3100 Chipset SATA IDE Controller
:(32902:9886:4136:440) pci, ata_piix, STORAGE, 631xESB/632xESB IDE Controller
:(32902:9840:0:0) pci, None, PCI/ISA, 631xESB/632xESB/3100 Chipset LPC Interface Controller
:(32902:9294:0:0) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:9865:4136:440) pci, uhci_hcd, USB, 631xESB/632xESB/3100 Chipset UHCI USB Controller #2
:(32902:9864:4136:440) pci, uhci_hcd, USB, 631xESB/632xESB/3100 Chipset UHCI USB Controller #1
:(32902:13588:0:0) pci, pcieport, PCI/PCI, 6311ESB/6321ESB PCI Express Downstream Port E2
:(32902:9718:32902:32902) pci, None, HOST/PCI, 5000 Series Chipset FBD Registers
:(32902:9868:4136:440) pci, ehci_hcd, USB, 631xESB/632xESB/3100 Chipset EHCI USB2 Controller
:(32902:13584:0:0) pci, pcieport, PCI/PCI, 6311ESB/6321ESB PCI Express Downstream Port E1
:(32902:9717:32902:32902) pci, None, HOST/PCI, 5000 Series Chipset FBD Registers
:(32902:9698:0:0) pci, pcieport, PCI/PCI, 5000 Series Chipset PCI Express x4 Port 2
:(4098:20830:4136:440) pci, radeon, VIDEO, ES1000
:(32902:9872:4136:440) pci, pcieport, PCI/PCI, 631xESB/632xESB/3100 Chipset PCI Express Root Port 1
:(32902:9699:0:0) pci, pcieport, PCI/PCI, 5000 Series Chipset PCI Express x4 Port 3
:(4136:21:4136:7939) pci, megaraid_sas, RAID, PERC 5/i Integrated RAID Controller
:(32902:13568:0:0) pci, pcieport, PCI/PCI, 6311ESB/6321ESB PCI Express Upstream Port
:(32902:13580:0:0) pci, None, PCI/PCI, 6311ESB/6321ESB PCI Express to PCI-X Bridge
:(32902:880:0:0) pci, None, PCI/PCI, 80333 Segment-A PCI Express-to-PCI Express Bridge
:(32902:9715:32902:32902) pci, None, HOST/PCI, 5000 Series Chipset Reserved Registers
:(32902:882:0:0) pci, None, PCI/PCI, 80333 Segment-B PCI Express-to-PCI Express Bridge
:(32902:6712:32902:32902) pci, ioatdma, BASE, 5000 Series Chipset DMA Engine
:(32902:9866:4136:440) pci, uhci_hcd, USB, 631xESB/632xESB/3100 Chipset UHCI USB Controller #3
:(5348:5708:4136:440) pci, bnx2, ETHERNET, NetXtreme II BCM5708 Gigabit Ethernet
:(32902:9700:0:0) pci, pcieport, PCI/PCI, 5000 Series Chipset PCI Express x4 Port 4
:(32902:9701:0:0) pci, pcieport, PCI/PCI, 5000 Series Chipset PCI Express x4 Port 5
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_bigboy-lv_root / ext4 4096 4096 12901535 9761968 9630936 3276800 2802562 2802562
:/dev/sda1 /boot ext4 1024 1024 495844 327309 301709 128016 127724 127724
:/dev/mapper/vg_bigboy-lv_home /home ext4 4096 4096 994780222 994678847 944146905 252665856 252662743 252662743
:
Comment 1 Michael Young 2012-01-03 17:24:08 EST
This is almost certainly because selinux is blocking what you are trying to do.

*** This bug has been marked as a duplicate of bug 741042 ***

Note You need to log in before you can comment on or make changes to this bug.