Bug 770707 - gnome-keyring and passwords stockage (fix)
Summary: gnome-keyring and passwords stockage (fix)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: gajim
Version: 16
Hardware: All
OS: Linux
unspecified
low
Target Milestone: ---
Assignee: Michal Schmidt
QA Contact: Fedora Extras Quality Assurance
URL: https://trac.gajim.org/ticket/7067
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-28 13:41 UTC by Alexandre Singh
Modified: 2012-03-26 17:56 UTC (History)
1 user (show)

Fixed In Version: gajim-0.15-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-03-26 03:59:06 UTC
Type: ---


Attachments (Terms of Use)
corrected file (8.76 KB, text/x-python)
2011-12-28 13:41 UTC, Alexandre Singh
no flags Details

Description Alexandre Singh 2011-12-28 13:41:32 UTC
Created attachment 549824 [details]
corrected file

Description of problem:

After login, when Gajim is launched, it asks again for a password via gnome-keyring, because Gajim' passwords are stocked into ~/.gnome2/keyrings/default.keyring instead of ~/.gnome2/keyrings/login.keyring.

Don't know if this bug happens in a Gnome session by the way, only tested on other sessions, like Openbox, Wmaker, etc... but all my contacts have this bugs.

I give you the fix further in this report, which is OK for me.


Version-Release number of selected component (if applicable):

0.14.3-1


How reproducible:

Launch Gajim after login.


Steps to Reproduce:
1. login in your session (activate the normal keyring)
2. launch Gajim (with already created accounts and passwords)
  
Actual results:

It will ask a password in order to unlock the keyring created by Gajim which is not the good file (default.keyring instead of login.keyring).


Expected results:

Gajim should just be launched without asking anything, because the real keyring was already unlocked at login.


Additional info:

There is the bugfix : in /usr/share/gajim/src/common/passwords.py file, at line 66 "self.keyring = 'default'", change "default" by "login" like this : "self.keyring = 'login'"

The corrected file is attached with this report.

Comment 1 Alexandre Singh 2011-12-29 15:53:23 UTC
EDIT
Hmmm it seems that it doesn't work anymore after reboot... have to look deeper.

Comment 2 Alexandre Singh 2011-12-29 16:05:11 UTC
EDIT 2
It's ok, just be sure that "/usr/bin/gnome-keyring-daemon --start" is launched at startup (in Openbox autostart file for example).

Sorry for the two "edit" replies.

Comment 3 Michal Schmidt 2012-01-02 13:22:20 UTC
As a workaround you can use seahorse to 'Set as default' on the 'login' keyring.

I believe you that the change works as expected, but I can't tell if it is the correct fix. Could you please propose it to gajim developers upstream (http://gajim.org/)?

Comment 4 Alexandre Singh 2012-01-02 22:08:30 UTC
(In reply to comment #3)
> I believe you that the change works as expected, but I can't tell if it is the
> correct fix. Could you please propose it to gajim developers upstream
> (http://gajim.org/)?

Proposition submitted : https://trac.gajim.org/ticket/7067

Comment 5 Alexandre Singh 2012-01-03 21:04:30 UTC
Fixed and closed upstream.
https://trac.gajim.org/ticket/7067#comment:6

Comment 6 Michal Schmidt 2012-01-16 16:06:31 UTC
The fix is on the gajim_0.15 branch, so it will get into Fedora with the next upstream beta or final release.

Comment 7 Alexandre Singh 2012-01-16 16:33:46 UTC
Great :)
Thanks for all Michal.

Comment 8 Fedora Update System 2012-01-27 11:29:45 UTC
gajim-0.15-0.4.beta4.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/FEDORA-2011-15286/gajim-0.15-0.4.beta4.fc16

Comment 9 Fedora Update System 2012-01-28 03:29:11 UTC
Package gajim-0.15-0.4.beta4.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gajim-0.15-0.4.beta4.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15286/gajim-0.15-0.4.beta4.fc16
then log in and leave karma (feedback).

Comment 10 Fedora Update System 2012-03-21 02:36:40 UTC
Package gajim-0.15-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gajim-0.15-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2011-15286/gajim-0.15-1.fc16
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2012-03-26 03:59:06 UTC
gajim-0.15-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2012-03-26 17:56:39 UTC
gajim-0.15-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.