Bug 770805 - [abrt] kernel: BUG: soft lockup - CPU#1 stuck for 22s! [biosdevname:867]
Summary: [abrt] kernel: BUG: soft lockup - CPU#1 stuck for 22s! [biosdevname:867]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: biosdevname
Version: 16
Hardware: i686
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Narendra K
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:f206cfc91eace215fd5b5bdfbaa...
: 772339 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-29 09:03 UTC by ale-magro
Modified: 2012-07-26 22:31 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-26 22:31:28 UTC


Attachments (Terms of Use)
biosdecode (1.16 KB, text/plain)
2012-06-13 19:12 UTC, Fabien de Saint pern
no flags Details
dmidecode (10.88 KB, text/plain)
2012-06-13 19:12 UTC, Fabien de Saint pern
no flags Details
lspci (174.80 KB, text/plain)
2012-06-13 19:13 UTC, Fabien de Saint pern
no flags Details

Description ale-magro 2011-12-29 09:03:30 UTC
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/boot/vmlinuz-3.1.6-1.fc16.i686 root=UUID=7b53916c-9357-4d99-ae7c-d0f3123ddea9 ro rd.md=0 rd.lvm=0 rd.dm=0 quiet SYSFONT=latarcyrheb-sun16 rhgb rd.luks=0 KEYTABLE=it LANG=en_US.UTF-8
kernel:         3.1.6-1.fc16.i686
reason:         BUG: soft lockup - CPU#1 stuck for 22s! [biosdevname:867]
time:           gio 29 dic 2011 09:33:36 CET

backtrace:
:BUG: soft lockup - CPU#1 stuck for 22s! [biosdevname:867]
:Modules linked in: iwlwifi(+) ir_mce_kbd_decoder ir_sony_decoder atl1e ir_jvc_decoder ir_rc6_decoder ir_rc5_decoder rc_rc6_mce uvcvideo ir_nec_decoder ite_cir rc_core i2c_i801 snd_hda_codec_hdmi snd_hda_codec_realtek mac80211 cfg80211 snd_hda_intel videodev snd_hda_codec snd_hwdep snd_seq snd_seq_device microcode snd_pcm snd_timer snd soundcore snd_page_alloc acer_wmi iTCO_wdt iTCO_vendor_support media serio_raw uinput joydev sparse_keymap rfkill nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core mxm_wmi wmi video
:Modules linked in: iwlwifi(+) ir_mce_kbd_decoder ir_sony_decoder atl1e ir_jvc_decoder ir_rc6_decoder ir_rc5_decoder rc_rc6_mce uvcvideo ir_nec_decoder ite_cir rc_core i2c_i801 snd_hda_codec_hdmi snd_hda_codec_realtek mac80211 cfg80211 snd_hda_intel videodev snd_hda_codec snd_hwdep snd_seq snd_seq_device microcode snd_pcm snd_timer snd soundcore snd_page_alloc acer_wmi iTCO_wdt iTCO_vendor_support media serio_raw uinput joydev sparse_keymap rfkill nouveau ttm drm_kms_helper drm i2c_algo_bit i2c_core mxm_wmi wmi video
:Pid: 867, comm: biosdevname Not tainted 3.1.6-1.fc16.i686 #1 Acer Aspire 8930/Aspire 8930
:EIP: 0060:[<c0656654>] EFLAGS: 00000202 CPU: 1
:EIP is at pci_user_read_config_dword+0x64/0xa0
:EAX: 00000000 EBX: f31e4800 ECX: 00000000 EDX: 00000056
:ESI: 00000070 EDI: c0ba5020 EBP: f26cbe98 ESP: f26cbe7c
: DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
:Process biosdevname (pid: 867, ti=f26ca000 task=f2bf7110 task.ti=f26ca000)
:Stack:
: 00000004 f26cbe88 f26cbec8 ffffffff 00000000 00000000 00000000 f26cbed8
: c06568db 00000001 f31bb00c 00000000 f257c408 f31e4800 f31bb000 00001000
: 00000000 00000408 00000000 00000000 c09470c0 00001000 00008000 f26cbef0
:Call Trace:
: [<c06568db>] pci_vpd_pci22_read+0x13b/0x1e0
: [<c0655ee1>] pci_read_vpd+0x31/0x50
: [<c065f13e>] read_vpd_attr+0x4e/0xb0
: [<c0585279>] read+0xe9/0x250
: [<c065f0f0>] ? write_vpd_attr+0xb0/0xb0
: [<c0527e9c>] vfs_read+0x8c/0x160
: [<c0585190>] ? write+0x1b0/0x1b0
: [<c05280cb>] sys_pread64+0x7b/0x80
: [<c090d4f4>] syscall_call+0x7/0xb
: [<c0900000>] ? profile_cpu_callback+0x91/0x1ac
:Code: 04 00 00 20 75 4a 8b 43 08 8d 4d f0 8b 53 1c 8b 78 40 89 4c 24 04 89 f1 c7 04 24 04 00 00 00 ff 17 89 c1 fe 05 40 e5 d2 c0 fb 90 <8d> 74 26 00 8b 45 f0 85 c9 8b 55 ec 89 02 b8 ea ff ff ff 0f 4f

Comment 1 Josh Boyer 2012-01-03 16:24:40 UTC
This looks like a bug that was hit quite a while ago.  Please make sure you have the most up-to-date biosdevname package.

Comment 2 Josh Boyer 2012-01-06 21:31:53 UTC
*** Bug 772339 has been marked as a duplicate of this bug. ***

Comment 3 Narendra K 2012-02-01 19:16:20 UTC
Hi, could you please try with biosdevname-0.3.11 and let us know if you see the issue ?

Also, please share the output from the following -

dmidecode
biosdecode
lspci -vvvxxxx

Comment 4 Fabien de Saint pern 2012-06-13 19:12:24 UTC
Created attachment 591603 [details]
biosdecode

Comment 5 Fabien de Saint pern 2012-06-13 19:12:59 UTC
Created attachment 591604 [details]
dmidecode

Comment 6 Fabien de Saint pern 2012-06-13 19:13:30 UTC
Created attachment 591605 [details]
lspci

Comment 7 Fabien de Saint pern 2012-06-13 19:15:21 UTC
Some issue for me :

biosdevname.x86_64 / 0.3.11-6.fc17

3.4.0-1.fc17.x86_64 #1 SMP Sun Jun 3 06:35:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

/var/log/messages :

Jun 12 20:55:26 localhost kernel: [   36.059639] BUG: soft lockup - CPU#1 stuck for 22s! [biosdevname:517]
Jun 12 20:55:26 localhost kernel: [   36.059650] iTCO_wdt: Intel TCO WatchDog Timer Driver v1.07
Jun 12 20:55:26 localhost kernel: [   36.059692] Modules linked in: iTCO_wdt(+) iTCO_vendor_support cfg80211(+) rfkill scsi_wait_scan ir_lirc_codec lirc_dev ir_mce_kbd_decoder ir_sanyo_decoder ir_sony_decoder ir_jvc_decoder ir_rc6_decoder ir_rc5_decoder ir_nec_decoder rc_rc6_mce ite_cir rc_core uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media atl1e i2c_i801 coretemp serio_raw microcode uinput nouveau mxm_wmi wmi video i2c_algo_bit drm_kms_helper ttm drm i2c_core
Jun 12 20:55:26 localhost kernel: [   36.059715] CPU 1
Jun 12 20:55:26 localhost kernel: [   36.059716] Modules linked in: iTCO_wdt(+) iTCO_vendor_support cfg80211(+) rfkill scsi_wait_scan ir_lirc_codec lirc_dev ir_mce_kbd_decoder ir_sanyo_decoder ir_sony_decoder ir_jvc_decoder ir_rc6_decoder ir_rc5_decoder ir_nec_decoder rc_rc6_mce ite_cir rc_core uvcvideo videobuf2_vmalloc videobuf2_memops videobuf2_core videodev media atl1e i2c_i801 coretemp serio_raw microcode uinput nouveau mxm_wmi wmi video i2c_algo_bit drm_kms_helper ttm drm i2c_core
Jun 12 20:55:26 localhost kernel: [   36.059738]
Jun 12 20:55:26 localhost kernel: [   36.059740] Pid: 517, comm: biosdevname Not tainted 3.4.0-1.fc17.x86_64 #1 Acer Aspire 8930/Aspire 8930
Jun 12 20:55:26 localhost kernel: [   36.059744] RIP: 0010:[<ffffffff812dc2dd>]  [<ffffffff812dc2dd>] pci_user_read_config_dword+0x6d/0xa0
Jun 12 20:55:26 localhost kernel: [   36.059753] RSP: 0018:ffff880136883dc8  EFLAGS: 00000202
Jun 12 20:55:26 localhost kernel: [   36.059755] RAX: 0000000000000000 RBX: 0000000000000056 RCX: 0000000000000000
Jun 12 20:55:26 localhost kernel: [   36.059757] RDX: 0000000000000cfc RSI: 0000000000000056 RDI: 0000000000000056
Jun 12 20:55:26 localhost kernel: [   36.059760] RBP: ffff880136883df8 R08: 0000000000000004 R09: ffff880136883dd4
Jun 12 20:55:26 localhost kernel: [   36.059762] R10: 0000000000000000 R11: 0000000000000001 R12: 0000000000000000
Jun 12 20:55:26 localhost kernel: [   36.059764] R13: 0000000000000000 R14: 0000000000000002 R15: ffff880136883d94
Jun 12 20:55:26 localhost kernel: [   36.059766] FS:  00007f3feebe6740(0000) GS:ffff88013fc80000(0000) knlGS:0000000000000000
Jun 12 20:55:26 localhost kernel: [   36.059769] CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
Jun 12 20:55:26 localhost kernel: [   36.059770] CR2: 0000000000c93000 CR3: 0000000136237000 CR4: 00000000000007e0
Jun 12 20:55:26 localhost kernel: [   36.059773] DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
Jun 12 20:55:26 localhost kernel: [   36.059775] DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
Jun 12 20:55:26 localhost kernel: [   36.059777] Process biosdevname (pid: 517, threadinfo ffff880136882000, task ffff880136ea4500)
Jun 12 20:55:26 localhost kernel: [   36.059779] Stack:
Jun 12 20:55:26 localhost kernel: [   36.059780]  0000000000000018 ffffffff812dc3fa ffff8801388d84b0 ffff8801388d84b0
Jun 12 20:55:26 localhost kernel: [   36.059784]  ffff8801394ac180 ffff8801394e1000 ffff880136883e68 ffffffff812dc519
Jun 12 20:55:26 localhost kernel: [   36.059788]  ffff880136883fd8 ffff880136883fd8 0000000000001000 ffff8801394ac198
Jun 12 20:55:26 localhost kernel: [   36.059791] Call Trace:
Jun 12 20:55:26 localhost kernel: [   36.059795]  [<ffffffff812dc3fa>] ? pci_user_write_config_word+0x5a/0x90
Jun 12 20:55:26 localhost kernel: [   36.059799]  [<ffffffff812dc519>] pci_vpd_pci22_read+0xe9/0x180
Jun 12 20:55:26 localhost kernel: [   36.059802]  [<ffffffff812db960>] pci_read_vpd+0x20/0x40
Jun 12 20:55:26 localhost kernel: [   36.059806]  [<ffffffff812e6400>] read_vpd_attr+0x30/0x40
Jun 12 20:55:26 localhost kernel: [   36.059809]  [<ffffffff811eef3f>] read+0xef/0x210
Jun 12 20:55:26 localhost kernel: [   36.059813]  [<ffffffff8117d7c9>] vfs_read+0xa9/0x180
Jun 12 20:55:26 localhost kernel: [   36.059815]  [<ffffffff8117da52>] sys_pread64+0x92/0xb0
Jun 12 20:55:26 localhost kernel: [   36.059820]  [<ffffffff815f8ae9>] system_call_fastpath+0x16/0x1b
Jun 12 20:55:26 localhost kernel: [   36.059821] Code: 75 4c 48 8b 7b 10 8b 73 38 4c 8d 45 dc b9 04 00 00 00 44 89 e2 48 8b 87 80 00 00 00 ff 10 89 c1 80 05 27 28 c5 00 01 fb 66 66 90 <66> 66 90 8b 45 dc 85 c9 41 89 45 00 7e 05 b9 ea ff ff ff 89 c8
Jun 12 20:55:26 localhost kernel: [   36.059850] Call Trace:
Jun 12 20:55:26 localhost kernel: [   36.059853]  [<ffffffff812dc3fa>] ? pci_user_write_config_word+0x5a/0x90
Jun 12 20:55:26 localhost kernel: [   36.059856]  [<ffffffff812dc519>] pci_vpd_pci22_read+0xe9/0x180
Jun 12 20:55:26 localhost kernel: [   36.059859]  [<ffffffff812db960>] pci_read_vpd+0x20/0x40
Jun 12 20:55:26 localhost kernel: [   36.059861]  [<ffffffff812e6400>] read_vpd_attr+0x30/0x40
Jun 12 20:55:26 localhost kernel: [   36.059864]  [<ffffffff811eef3f>] read+0xef/0x210
Jun 12 20:55:26 localhost kernel: [   36.059866]  [<ffffffff8117d7c9>] vfs_read+0xa9/0x180
Jun 12 20:55:26 localhost kernel: [   36.059869]  [<ffffffff8117da52>] sys_pread64+0x92/0xb0
Jun 12 20:55:26 localhost kernel: [   36.059871]  [<ffffffff815f8ae9>] system_call_fastpath+0x16/0x1b

Comment 8 Narendra K 2012-06-14 07:50:39 UTC
Hi, could you please test biosdevname-0.4.0 and share results ?

Comment 9 Narendra K 2012-06-14 07:51:28 UTC
(In reply to comment #8)
> Hi, could you please test biosdevname-0.4.0 and share results ?

Sorry, 0.4.0 is available here - 
http://linux.dell.com/biosdevname/biosdevname-0.4.0/

Comment 10 Fabien de Saint pern 2012-06-22 10:34:57 UTC
Hi,

Ok, everything works fine with this version : no more lockup/crashes or message in the logs and the startup is very fast.

A note for those who have the same problem and can not start their computer, I added the kernel parameter biosdevname=0. (Press 'e' in the grub menu and look for the line below)

I no longer need biosdevname=0 with version 0.4

Do you know when this version will be available in the repository ?

Thank you very much for the help,

Comment 11 Fedora Update System 2012-07-18 13:32:04 UTC
biosdevname-0.4.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/biosdevname-0.4.1-1.fc17

Comment 12 Fedora Update System 2012-07-19 09:00:44 UTC
Package biosdevname-0.4.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing biosdevname-0.4.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-10778/biosdevname-0.4.1-1.fc17
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2012-07-26 22:31:28 UTC
biosdevname-0.4.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.