Bug 770828 - pycairo needs to be properly renamed to python-cairo and built as per Fedora packaging guidelines
pycairo needs to be properly renamed to python-cairo and built as per Fedora ...
Status: CLOSED DUPLICATE of bug 731891
Product: Fedora
Classification: Fedora
Component: pycairo (Show other bugs)
All Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: John (J5) Palmieri
Fedora Extras Quality Assurance
: Reopened
Depends On:
  Show dependency treegraph
Reported: 2011-12-29 06:32 EST by Peter Robinson
Modified: 2013-09-07 03:34 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2013-09-07 03:34:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2011-12-29 06:32:14 EST
Version 1.8.10 was released and updated in the package but due to not going through the proper packaging process for a rename it doesn't actually build in koji.

From the spec commit:
# With version 1.8.10, the upstream pycairo project began releasing multiple
# tarballs for different Python versions: py2cairo for Python 2, and pycairo
# for Python 3.  In order to provide a smooth upgrade path for users wishing
# to stay on the Python 2 version, this package was renamed to python-cairo
# and a python3-cairo package was introduced for Python 3.

The process to do this properly is listed here
Comment 1 Peter Robinson 2012-06-06 05:48:07 EDT
Rename rolled back as maintainer is unresponsive
Comment 2 Christopher Meng 2013-09-07 03:28:48 EDT
*** Bug 731891 has been marked as a duplicate of this bug. ***
Comment 3 Christopher Meng 2013-09-07 03:32:40 EDT

This package needs update and rename so we can continue another package.
Comment 4 Christopher Meng 2013-09-07 03:34:49 EDT
Sorry for the mess.

*** This bug has been marked as a duplicate of bug 731891 ***

Note You need to log in before you can comment on or make changes to this bug.