Bug 77084 - No 3D acceleration playing tux racer or chromium
No 3D acceleration playing tux racer or chromium
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-31 17:27 EST by Andrew Lynch
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-06 17:28:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/XFree86.0.log (24.57 KB, text/plain)
2002-11-01 12:13 EST, Andrew Lynch
no flags Details
/etc/X11/XF86Config (3.53 KB, text/plain)
2002-11-01 12:15 EST, Andrew Lynch
no flags Details
/var/log/XFree86.0.log (29.20 KB, text/plain)
2002-11-03 19:00 EST, Andrew Lynch
no flags Details
/tmp/xdpyinfo.out (3.06 KB, text/plain)
2002-11-06 15:06 EST, Andrew Lynch
no flags Details
/tmp/glxinfo.out (1.27 KB, text/plain)
2002-11-06 15:07 EST, Andrew Lynch
no flags Details

  None (edit)
Description Andrew Lynch 2002-10-31 17:27:26 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
I can't seem to get more than 1 frame every 2 seconds with a Voodoo 3 3000 video
card. I didn't have problems with RH 7.x releases.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run Tux Racer or Chromium
2.
3.
	

Actual Results:  Slow performance

Expected Results:  Fast performance

Additional info:

I've also tried  Stealth III 540 agp card, same slow results. Also as root too.
Comment 1 Mike A. Harris 2002-10-31 21:53:09 EST
Attach your X server log and config file using the link below.
Comment 2 Andrew Lynch 2002-11-01 12:13:04 EST
Created attachment 83045 [details]
/var/log/XFree86.0.log
Comment 3 Andrew Lynch 2002-11-01 12:15:39 EST
Created attachment 83046 [details]
/etc/X11/XF86Config
Comment 4 Mike A. Harris 2002-11-03 03:15:41 EST
From your log file:

(II) TDFX(0): [dri] VideoRAM = 16384, VirtualXres = 1280, VirtualYres= 1024,
(WW) TDFX(0): [dri] To use DRI, with a 16Mb Voodoo 3 or Banshee card, you must
	invoke the server using a maximum resolution of 1024x768 or lower.

The warning message clearly shows that you must use a resolution
of 1024x768 for 3D acceleration to work.  This isn't a bug, just
a misconfiguration on your part.

I've just tested a Voodoo 3 3000 at 1024x768 with tuxracer and it
works fine.
Comment 5 Andrew Lynch 2002-11-03 19:00:09 EST
Created attachment 83384 [details]
/var/log/XFree86.0.log
Comment 6 Andrew Lynch 2002-11-03 19:01:25 EST
It's still slow. Do I need to run as root? I use Icewm, do I need to use gnome?
Comment 7 Mike A. Harris 2002-11-04 02:27:05 EST
No, you don't need to run as root, 1024x768 is the max res for DRI on this
card, but it certainly isn't the best performance-wise.  If you want
better performance, configure for 640x480, or 800x600.  The lower the res,
the faster performance you'll get because of 2 factors:

1) Lower res consumes less video memory for 2D, leaving more memory for 3D

2) Lower res means less work needs to be done for 3D, which speeds things up

Your window manager and/or desktop is irrelevant and wont affect
performance at all.

Please attach the output of 'xdpyinfo' and 'glxinfo' also as separate file
attachments.
Comment 8 Mike A. Harris 2002-11-06 15:00:55 EST
Awaiting attachments...
Comment 9 Andrew Lynch 2002-11-06 15:06:44 EST
Created attachment 83884 [details]
/tmp/xdpyinfo.out
Comment 10 Andrew Lynch 2002-11-06 15:07:32 EST
Created attachment 83885 [details]
/tmp/glxinfo.out
Comment 11 Andrew Lynch 2002-11-06 15:09:12 EST
I also have a Stealth III 540 video board with a S3 Savage4Pro+ gpu, would that
work better for the GL stuff than the voodoo 3?
Comment 12 Andrew Lynch 2002-11-06 17:28:10 EST
I also have a Stealth III 540 video board with a S3 Savage4Pro+ gpu, would that
work better for the GL stuff than the voodoo 3?
Comment 13 Mike A. Harris 2002-11-06 17:48:19 EST
You did not do what I told you to do.  You are using 1280x1024.
You can NOT use resolution that high with 3D acceleration.  It does _not_
work.  And that is not a bug.  It is a limitation of the video hardware
and implementation.

The files you've attached, clearly indicate you're using an illegal
video mode for 3D acceleration to work, and clearly indicate that
DRI is not enabled.

I've just pulled out a Voodoo 3, set it to 1024x768, and fired up a game
of tuxracer.  It works perfectly, as does Return to Castle Wolfenstein,
although the latter doesn't perform the best - 3D is enabled and working
fine.

I'm closing this as WORKSFORME, as it works for me, and you're using
an invalid configuration for 3D.

To answer your Savage question - no, it wont perform or work better as
Savage is only supported 2D only, there is no 3D acceleration.

Note You need to log in before you can comment on or make changes to this bug.