Bug 770866 - [abrt] kernel: irq 16: nobody cared (try booting with the "irqpoll" option) ASM108x
[abrt] kernel: irq 16: nobody cared (try booting with the "irqpoll" option) A...
Status: CLOSED DUPLICATE of bug 755956
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:20552bd8158471aefc8aa190e45...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-29 15:03 EST by Juan Orti
Modified: 2012-03-05 16:59 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-05 16:59:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel crash 3.2.1-3.fc16.x86_64 (4.68 KB, text/plain)
2012-01-24 17:12 EST, Juan Orti
no flags Details
interrupts (5.44 KB, text/plain)
2012-01-24 17:13 EST, Juan Orti
no flags Details
dmesg (89.93 KB, text/plain)
2012-01-24 17:13 EST, Juan Orti
no flags Details

  None (edit)
Description Juan Orti 2011-12-29 15:03:51 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.6-1.fc16.x86_64 root=UUID=51083f47-db67-4072-baba-9da5c040dc28 ro rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=latarcyrheb-sun16 rd.luks=0 LANG=es_ES.UTF-8 KEYTABLE=es
comment:        I'm not sure the cause of this problem, I was debugging a network shell script with a link in /sbin/ifup-pre-local and this error appeared.
kernel:         3.1.6-1.fc16.x86_64
reason:         irq 16: nobody cared (try booting with the "irqpoll" option)
time:           jue 29 dic 2011 16:36:04 CET

backtrace:
:irq 16: nobody cared (try booting with the "irqpoll" option)
:Pid: 0, comm: kworker/0:1 Not tainted 3.1.6-1.fc16.x86_64 #1
:Call Trace:
: <IRQ>  [<ffffffff810dc8cd>] __report_bad_irq+0x3d/0xe0
: [<ffffffff810dcb8d>] note_interrupt+0x16d/0x220
: [<ffffffff810da949>] handle_irq_event_percpu+0xa9/0x220
: [<ffffffff810dab04>] handle_irq_event+0x44/0x70
: [<ffffffff810dd4ef>] handle_fasteoi_irq+0x5f/0xf0
: [<ffffffff810151e9>] handle_irq+0x49/0xa0
: [<ffffffff815df7da>] do_IRQ+0x5a/0xe0
: [<ffffffff815d526e>] common_interrupt+0x6e/0x6e
: <EOI>  [<ffffffff813055db>] ? intel_idle+0xcb/0x120
: [<ffffffff813055bd>] ? intel_idle+0xad/0x120
: [<ffffffff814841e6>] cpuidle_idle_call+0xc6/0x280
: [<ffffffff81012225>] cpu_idle+0xc5/0x120
: [<ffffffff815c14c3>] start_secondary+0x260/0x262

smolt_data:
:
:
:General
:=================================
:UUID: 4423192c-c193-4002-8dbf-77389c99bcb5
:SO: Fedora release 16 (Verne)
:Nivel de ejecución por defecto: Unknown
:Idioma: es_ES.utf8
:Plataforma: x86_64
:BogoMIPS: 6822.44
:Fabricante de CPU: GenuineIntel
:Modelo de CPU: Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz
:Paso del UCP: 7
:Familia de UCP: 6
:Número de Modelo de CPU: 42
:Número de CPUs: 8
:Velocidad del CPU: 3401
:Memoria del Sistema: 15961
:Intercambio (swap) del Sistema: 8191
:Vendedor: System manufacturer
:Sistema: System Product Name System Version
:Factor de forma: Desktop
:Kernel: 3.1.6-1.fc16.x86_64
:SELinux Habilitado: 1
:Política de SELinux: targeted
:SELinux Obligado: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Dispositivos
:=================================
:(6945:4224:4163:33929) pci, None, PCI/PCI, N/A
:(32902:256:4163:33869) pci, agpgart-intel, HOST/PCI, P8P67 Deluxe Motherboard
:(32902:257:4163:33869) pci, pcieport, PCI/PCI, Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port
:(32902:7202:4163:33869) pci, i801_smbus, SERIAL, P8P67 Deluxe Motherboard
:(32902:7170:4163:33869) pci, ahci, STORAGE, P8P67 Deluxe Motherboard
:(32902:7236:4163:33869) pci, None, PCI/ISA, Z68 Express Chipset Family LPC Controller
:(32902:7188:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 3
:(32902:7213:4163:33869) pci, ehci_hcd, USB, P8P67 Deluxe Motherboard
:(32902:7206:4163:33869) pci, ehci_hcd, USB, P8P67 Deluxe Motherboard
:(32902:7226:4163:33869) pci, None, SIMPLE, P8P67 Deluxe Motherboard
:(4332:33128:4163:33842) pci, r8169, ETHERNET, P8P67 Deluxe Motherboard [Realtek RTL8111E]
:(32902:290:4163:33869) pci, i915, VIDEO, 2nd Generation Core Processor Family Integrated Graphics Controller
:(32902:7190:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 4
:(32902:7184:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 1
:(32902:7196:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 7
:(32902:9294:4163:33869) pci, None, PCI/PCI, 82801 PCI Bridge
:(32902:7192:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 5
:(32902:7200:4163:33819) pci, snd_hda_intel, MULTIMEDIA, 6 Series/C200 Series Chipset Family High Definition Audio Controller
:(6945:4162:4163:33928) pci, xhci_hcd, USB, ASM1042 SuperSpeed USB Host Controller
:(32902:7194:4163:33869) pci, pcieport, PCI/PCI, 6 Series/C200 Series Chipset Family PCI Express Root Port 6
:(5772:26:5868:290) pci, ath5k, ETHERNET, Wireless PCI Adapter Model 5418
:(6945:4162:4163:33928) pci, xhci_hcd, USB, ASM1042 SuperSpeed USB Host Controller
:
:
:Información relacionada con el sistema de archivos
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 8819390 6950426 6502426 2240224 1976588 1976588
:/dev/sda5 /var ext4 4096 4096 17444728 16410913 15524769 4431872 4376265 4376265
:/dev/sda2 /boot ext4 4096 4096 516052 479998 453784 131072 130840 130840
:/dev/mapper/vg_raid5-nova--volumes WITHHELD ext4 4096 4096 51606190 51558249 48936809 13107200 13107188 13107188
:/dev/mapper/vg_raid5-libvirt WITHHELD ext4 4096 4096 51606190 50326394 47704954 13107200 13107167 13107167
:/dev/mapper/vg_raid5-home /home ext4 4096 4096 264223533 143325130 129903358 67108864 67008555 67008555
:
Comment 1 Josh Boyer 2012-01-24 14:10:23 EST
Can you attach the output of dmesg and /proc/interrupts?  Also, do you see this on the 3.1.9 or 3.2.1 kernel updates?
Comment 2 Juan Orti 2012-01-24 17:11:56 EST
I had another crash this morning with kernel 3.2.1-3.fc16.x86_64 . I attach the dump.
Comment 3 Juan Orti 2012-01-24 17:12:46 EST
Created attachment 557331 [details]
Kernel crash 3.2.1-3.fc16.x86_64
Comment 4 Juan Orti 2012-01-24 17:13:12 EST
Created attachment 557332 [details]
interrupts
Comment 5 Juan Orti 2012-01-24 17:13:33 EST
Created attachment 557333 [details]
dmesg
Comment 6 Josh Boyer 2012-02-02 15:38:18 EST
Your motherboard is using the ASM108x PCI bridge.  There is a problem identified with this particular chip upstream that might be causing this issue:

http://thread.gmane.org/gmane.linux.kernel/1245767
Comment 7 Juan Orti 2012-02-02 16:15:43 EST
Thank you.
Comment 8 Josh Boyer 2012-03-05 16:57:36 EST
We're going to consolidate all of these bugs with the impacted hardware into a single bug.  The latest F15 and F16 kernel updates that should hit the mirrors soon have a patch to at least fall back to the irqpoll method when this happens.  Hopefully it results in a bit better experience for you.
Comment 9 Josh Boyer 2012-03-05 16:59:16 EST

*** This bug has been marked as a duplicate of bug 755956 ***

Note You need to log in before you can comment on or make changes to this bug.