Bug 770935 - [abrt] tumbler-0.1.23-1.fc16: zip_find_trailer: Process /usr/lib/tumbler-1/tumblerd was killed by signal 7 (SIGBUS)
[abrt] tumbler-0.1.23-1.fc16: zip_find_trailer: Process /usr/lib/tumbler-1/tu...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: tumbler (Show other bugs)
16
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christoph Wickert
Fedora Extras Quality Assurance
abrt_hash:fd3badd4bbd278e4679c5889f94...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-30 05:55 EST by Lecroq
Modified: 2012-01-09 16:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-09 16:07:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: event_log (9.22 KB, text/plain)
2011-12-30 05:55 EST, Lecroq
no flags Details
File: backtrace (35.19 KB, text/plain)
2011-12-30 05:55 EST, Lecroq
no flags Details
File: maps (18.83 KB, text/plain)
2011-12-30 05:55 EST, Lecroq
no flags Details
File: dso_list (5.66 KB, text/plain)
2011-12-30 05:55 EST, Lecroq
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 8319 None None None Never

  None (edit)
Description Lecroq 2011-12-30 05:55:43 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        /usr/lib/tumbler-1/tumblerd
crash_function: zip_find_trailer
executable:     /usr/lib/tumbler-1/tumblerd
kernel:         3.1.6-1.fc16.i686.PAE
pid:            4201
pwd:            /
reason:         Process /usr/lib/tumbler-1/tumblerd was killed by signal 7 (SIGBUS)
time:           vr 30 dec 2011 11:31:54 CET
uid:            1000
username:       lecroq
xsession_errors: 

backtrace:      Text file, 36031 bytes
dso_list:       Text file, 5799 bytes
event_log:      Text file, 9439 bytes
maps:           Text file, 19284 bytes

build_ids:
:1df53725e371c75ee897f32d82ec0497ecbb8599
:e86c829bf8553d6b593dbd8c4df0957268dc8328
:da0e1bd530e07cbb70263ed8d14499bda019b342
:bdbcb7ad0ae16806e9002af3c6d1ec65353108a0
:96b666a7f6d7a80ea6f9aef54f0cdd0f6190c058
:9deee7748e370dea083f735124e62863e87dc99d
:641296f1c3020865058939e8629a44acffcc3339
:92b99890f5d3dd6816e1a8125e9de9ac08931ac7
:11e752a8e19a41ab95fc6d418fcc0a706fefcf27
:5b853064c3d832d471e71bb67b714a7f69ff11d3
:82674b49345364df4c158e8258b93fd4d8fdbae0
:b2d5c5f02b6e6eb34dc593699c0b0bf516280159
:647951954dab9eadcf521b97c5f9d7566b1e79c8
:b6f5edce629fe342c0f0b28bba5dc944c6f859a8
:9b74e05fa75cf73df1da0c05a7b1528f0ec8a0f0
:9826db849075e7cfdc49bd6315d274d1f31f5e51
:63ef5361cd24ebd5a451c9fe289742972fe4cbbe
:42859023e4ec83a16446984b1e0c7510a38731c4
:425fbfbf600b830639ae3781fbf8bbeb4d1d9dad
:aa9a4df5fa16320332ea125a458d7c569194d323
:d31267db07bb7f102633c43adc7b083b45aef1d5
:dcedf9d0146a0ce09b31264f5ace5497cf56adff
:fda3e6da8c0459b7b76437dadfc89bfa21180c63
:d0045fa652ab4f2023afd554ae2c50b09c42ef25
:9e557521cbc1bfa5f60a7be1b5a6bda768ee5f7f
:d1bd2374eb12ee6116690a80ce23d695b3d585e8
:f7b0a9560a418a5688c923b587595cbaa736b60d
:820c3862dd6a9efdf9c5ca2589be31fa58b6dec0
:8eb8ed4296576c20b9541968bb9a5342215262a3
:83819b4947ad802212e04f438eb4c7d20a8aa01d
:ecf065826f19e4099148f7a5b57db2ba1528ff04
:af5eca4c988424912f1cbe04629f5c8a11109184
:36cc7c0490b1d29bbe496654fe01dea01f6c8615
:fb138a019cd93aa6212be49f31654f7bcb474640
:15bab279752ad8e30f901abae77bcb1ed1f38977
:f36e5bf805c388ce4d6e78300c58045320b5d2c1
:3b5d160bc67e95593211fd623fc34ee2ca23381a
:d55e1abef167768e36fb69f865f31a43ca4a9866
:b28c3093f3f16a3e8ad12c09b2b3c7abea9951fb
:ba33797fbd8e76278b767e6cf602a023b4cf973e
:79671f1e424a7a98556d10a8c396417f91ec964f
:12da4d1dc9764d3990ab6a2def5a88c4687d4550
:798697a352bae4178953ba502fb04f33dd0ed987
:85d6747093886eff44cf10e88d3eb9c88b6eb95d
:adca4c604227da51f7a095c00f343e39dda76d54
:5031c4c03882fc3c5cc3dd84e2b4491d8bd08af3
:4ad17dce13b95c3f6543c3ab56624e321dc1fce8
:8403f33f0be1a3653acd05b560f87aa1363d02d7
:d7cd016536dcce05ea28a1219c92eb9507121fa3
:71da089024decc6184dbfec13d08eee1c9224743
:0cc5c4bc97b347c85c28a24db9e236d4c727ed91
:d94f52f020f5a21d89ce70745a9bfb78cee38ba4
:04d07800664a4f9b3f07bafbc458226ff17d3909
:a3d032df474429a0a60a68b525c3d9e2a8693061
:28b8cc9cda751c67558ec59cc16019154ebf56ae
:0c66f47155090aa88fa0174effc38414db016842
:55433495aa80cf9e1f994ea7e7ae278422ef1ede
:1e5766bb5ec0cfd23fa28f3a962505db64e908f9
:4b045111479e1ec97d0ef5668482bf808e8dadba
:10cec21724c13b95ec03f00985b0405412817a49

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-tHjfBA4fOC,guid=ac22800d82e7778ec9b38e2e00000021
:XDG_SESSION_COOKIE=280bc39c4707b27cc634ad2b00000010-1325232348.598943-91994677
:XDG_RUNTIME_DIR=/run/user/lecroq
:DISPLAY=:0
:DESKTOP_SESSION=xfce
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin
:GDMSESSION=xfce
:XDG_VTNR=1
:USERNAME=lecroq
:XDG_SESSION_ID=2
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-tHjfBA4fOC,guid=ac22800d82e7778ec9b38e2e00000021
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-lecroq-RA0nzL/database
:USER=lecroq
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=1002
:SHLVL=1
:PWD=/home/lecroq
:GNOME_KEYRING_CONTROL=/tmp/keyring-K02sty
:LANG=nl_NL.UTF-8
:_=/usr/bin/dbus-launch
:LOGNAME=lecroq
:HOME=/home/lecroq

smolt_data:
:
:
:Algemeen
:=================================
:UUID: 5a0b36cf-fe1e-412b-92b6-a62d97ea58a2
:Besturingssysteem: Fedora release 16 (Verne)
:Standaard runlevel: Unknown
:Taal: nl_NL.UTF-8
:Platform: i686
:BogoMIPS: 3200.45
:CPU fabrikant: GenuineIntel
:CPU model: Intel(R) Celeron(R) M CPU        420  @ 1.60GHz
:CPU Stepping: 8
:CPU familie: 6
:CPU model nummer: 14
:Aantal CPU's: 1
:CPU snelheid: 1599
:Systeem geheugen: 873
:Systeem wisselgeheugen: 1759
:Fabrikant: Packard Bell BV
:Systeem: EasyNote MZ35 PB77Q100A7
:Form factor: Notebook
:Kernel: 3.1.6-1.fc16.i686.PAE
:SELinux aangezet: 1
:SELinux tactiek: targeted
:SELinux afdwingend: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Apparaten
:=================================
:(4332:33081:5681:49409) pci, 8139too, ETHERNET, RTL-8139/8139C/8139C+
:(4098:17270:5681:49409) pci, pata_atiixp, STORAGE, IXP SB400 IDE Controller
:(4098:17266:5681:49409) pci, piix4_smbus, SERIAL, IXP SB400 SMBus Controller
:(4098:17271:5681:49409) pci, None, PCI/ISA, IXP SB400 PCI-ISA Bridge
:(4098:17275:5681:49409) pci, snd_hda_intel, MULTIMEDIA, IXP SB4x0 High Definition Audio Controller
:(4098:17265:0:0) pci, None, PCI/PCI, IXP SB400 PCI-PCI Bridge
:(4098:23103:4098:23103) pci, None, PCI/PCI, RS480 PCI Bridge
:(4098:23138:5681:49409) pci, radeon, VIDEO, RC410 [Radeon Xpress 200M]
:(6164:770:6376:24980) pci, rt61pci, NETWORK, RT2561/RT61 rev B 802.11g
:(4098:17267:5681:49409) pci, ehci_hcd, USB, IXP SB400 USB2 Host Controller
:(4098:23089:5681:49409) pci, None, HOST/PCI, N/A
:(4098:17269:5681:49409) pci, ohci_hcd, USB, IXP SB400 USB Host Controller
:(4098:17268:5681:49409) pci, ohci_hcd, USB, IXP SB400 USB Host Controller
:(4098:17273:5681:49409) pci, sata_sil, STORAGE, IXP SB400 Serial ATA Controller
:
:
:Bestandssysteem informatie
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda5 / ext4 4096 4096 5291487 3456872 3188072 1346400 1181653 1181653
:/dev/sda4 /home ext4 4096 4096 18176330 16253803 15330488 4620288 4614825 4614825
:/dev/sda2 /boot ext4 1024 1024 495844 437854 412254 128016 127794 127794
:/dev/sdd1 WITHHELD vfat 4096 4096 1950744 707927 707927 0 0 0
:

var_log_messages:
:Dec 30 11:31:55 Dunne abrt[5260]: Saved core dump of pid 4201 (/usr/lib/tumbler-1/tumblerd) to /var/spool/abrt/ccpp-2011-12-30-11:31:54-4201 (43167744 bytes)
:Dec 30 11:31:57 Dunne abrt[5276]: Not dumping repeating crash in '/usr/lib/tumbler-1/tumblerd'
Comment 1 Lecroq 2011-12-30 05:55:47 EST
Created attachment 550053 [details]
File: event_log
Comment 2 Lecroq 2011-12-30 05:55:50 EST
Created attachment 550054 [details]
File: backtrace
Comment 3 Lecroq 2011-12-30 05:55:52 EST
Created attachment 550055 [details]
File: maps
Comment 4 Lecroq 2011-12-30 05:55:54 EST
Created attachment 550056 [details]
File: dso_list
Comment 5 Christoph Wickert 2011-12-30 07:38:31 EST
Thanks for submitting this crash report. Do you remember what folder you had opened when tumbler crashed and what files were in this folder? It looks like it was trying to generate thumbnails of OpenOffice/LibreOffice files.

looks like the debugsymbols for libgsf were not installed. If you created the backtrace locally on your computer, please run

debuginfo-install libgsf

Then try to reproduce the crash and generate a new backtrace.
Comment 6 Lecroq 2011-12-31 04:24:29 EST
I was trying to open a .docx-file from my USB Pendrive which was full of .docx- and PDF-files. At that moment I was checking if the PDF was matching the .docx-file correctly and contained all the formulas of MS Word, since LibreOffice cannot reproduce those formulas as they should be.

I ran debuginfo-install libgsf and tried to reproduce the crash with another Pendrive. I moved all my files to another Pendrive yesterday because there was also a problem with the permissions on the first drive. Sometimes the drive changed automatically to read-only, resulting in a lot of frustration. So I formatted the old drive after moving everything to the new one.
Reproducing the crash with the new drive didn't work. I opened all the .docx-files without any problems except for some documents prompting to ask the right encoding.

Does this mean the problem is solved or is it just because of me moving the entire directory that tumbler doesn't crash anymore?
Comment 7 Christoph Wickert 2011-12-31 04:40:11 EST
Thanks for your feedback.

I don't think the problem is already solved, I guess it's more like you already have thumbnails for all documents in question now. You can remove your thumbnail cache by running 

rm -rf ~/.thumbnails

Let me know if you can then reproduce the crash. And even if not, I will forward your report to the developers to give them a chance to look at it. But I prefer having a complete backtrace or that.

Once you have regenerated the backtrace, you can uninstall all debuginfo packages as root with

yum remove "*-debuginfo"
Comment 8 Lecroq 2012-01-02 09:07:18 EST
I cleared the thumbnail cache and tried regenerating the crash by opening different .docx-files, but (unfortunately) I didn't succeed to let tumbler crash again. 
I did try to report the bug again on BugZilla with the old backtrace but because the bug already existed (770935 = this bug ID), it hasn't been completed. Is the old backtrace useful for you? Should I try generating a new one in the error which I can find in the report history of ABRT?

I would like to help you correcting the problem so if there's anything I can try, let me know.
Comment 9 Christoph Wickert 2012-01-09 16:07:46 EST
Frankly speaking there is not too much I can do. I am the package maintainer for Fedora, but this bug is in the code and the developer needs to look at it. I have forwarded your report to the Xfce people at 
https://bugzilla.xfce.org/show_bug.cgi?id=8319


Feel free to subscribe to this report in order to get notified of any changes. I will get back to you if I need more information and let you know when the bug is resolved in Fedora.

Further investigation of this bug will take place in the Xfce bug tracker, therefor I am now closing this report.

Note You need to log in before you can comment on or make changes to this bug.