This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 770957 - libvirtd fails to start due to mDNS requirement
libvirtd fails to start due to mDNS requirement
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libvirt (Show other bugs)
6.2
x86_64 Linux
unspecified Severity high
: rc
: ---
Assigned To: Daniel Veillard
Virtualization Bugs
: ZStream
Depends On: 746111
Blocks: 785269
  Show dependency treegraph
 
Reported: 2011-12-30 10:05 EST by Ken Reilly
Modified: 2012-02-15 21:31 EST (History)
15 users (show)

See Also:
Fixed In Version: libvirt-0.9.4-23.el6_2.2
Doc Type: Bug Fix
Doc Text:
The libvirt package was missing a dependency on the avahi-libs package. The dependency is required due to libvirt linking in libavahi-client for mDNS support. As a consequence, the libvirtd daemon failed to start if the libvirt package was installed on the system without the avahi-libs package. With this update, the dependency on avahi-libs is now defined in the libvirt.spec file, and avahi-libs is installed along with libvirt.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-17 05:25:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 4 yanbing du 2011-12-31 04:54:35 EST
As comment 8 of bug 746111 described, libvirt require avahi rpm package, but if run "libvirtd" in the foreground, still need mDNS running.
https://bugzilla.redhat.com/show_bug.cgi?id=746111#c8
Comment 6 yanbing du 2012-01-06 02:28:46 EST
Retest it, after install avahi, we should reboot the host, then libvirtd will be started automatically.(In reply to comment #4)
> As comment 8 of bug 746111 described, libvirt require avahi rpm package, but if
> run "libvirtd" in the foreground, still need mDNS running.
> https://bugzilla.redhat.com/show_bug.cgi?id=746111#c8
Comment 7 yanbing du 2012-01-09 22:03:19 EST
Retest this bug, when update libvirt to libvirt-0.9.4-23.el6_2.4.x86_64, it require avahi rpm package installed, and after install it and reboot the host, libvirtd can start in the foreground.
So bug verified.
Comment 8 errata-xmlrpc 2012-01-17 05:25:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0013.html
Comment 9 Miroslav Svoboda 2012-01-17 07:53:37 EST
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
The libvirt package was missing a dependency on the avahi package. The dependency is required due to mDNS support which is turned on by default. As a consequence, the libvirtd daemon failed to start if the libvirt package was installed on the system without Avahi. With this update, the dependency on avahi is now defined in the libvirt.spec file, and Avahi is installed along with libvirt.
Comment 11 Laine Stump 2012-02-15 21:31:37 EST
I updated the Technical Notes to reflect current reality per Bug 770957.
Comment 12 Laine Stump 2012-02-15 21:31:37 EST
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-The libvirt package was missing a dependency on the avahi package. The dependency is required due to mDNS support which is turned on by default. As a consequence, the libvirtd daemon failed to start if the libvirt package was installed on the system without Avahi. With this update, the dependency on avahi is now defined in the libvirt.spec file, and Avahi is installed along with libvirt.+The libvirt package was missing a dependency on the avahi-libs package. The dependency is required due to libvirt linking in libavahi-client for mDNS support. As a consequence, the libvirtd daemon failed to start if the libvirt package was installed on the system without the avahi-libs package. With this update, the dependency on avahi-libs is now defined in the libvirt.spec file, and avahi-libs is installed along with libvirt.

Note You need to log in before you can comment on or make changes to this bug.