This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 770967 - AS 7 Plugin Fails During Discovery of 7.1 AS Instance in RHQ 4.2
AS 7 Plugin Fails During Discovery of 7.1 AS Instance in RHQ 4.2
Status: CLOSED CURRENTRELEASE
Product: RHQ Project
Classification: Other
Component: Plugins (Show other bugs)
4.2
x86_64 Mac OS
unspecified Severity high (vote)
: ---
: ---
Assigned To: Libor Zoubek
Mike Foley
:
Depends On:
Blocks: as7-plugin
  Show dependency treegraph
 
Reported: 2011-12-30 10:18 EST by Ted Jones
Modified: 2015-11-01 19:42 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 14:20:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
NPE during AS 7 discovery (37 bytes, text/plain)
2012-01-03 11:17 EST, Ted Jones
no flags Details

  None (edit)
Description Ted Jones 2011-12-30 10:18:01 EST
Description of problem: 

Exception received during discovery of AS 7 instance:

Caused by: java.lang.NumberFormatException: For input string: ""
	at java.lang.NumberFormatException.forInputString(NumberFormatException.java:48)
	at java.lang.Integer.parseInt(Integer.java:470)
	at java.lang.Integer.valueOf(Integer.java:554)
	at org.rhq.modules.plugins.jbossas7.AbstractBaseDiscovery.getManagementPortFromHostXml(AbstractBaseDiscovery.java:129)



Version-Release number of selected component (if applicable):
RHQ 4.2
JBoss AS 7.1.0.CR1b and JBoss AS 7.1.0.Beta1b


How reproducible:
Start an AS 7 instance then run rhq agent discovery

Steps to Reproduce:
1. Start AS 7
2. Start RHQ Server and Agent
3. Run discovery for AS 7 plugin
  
Actual results:
java.lang.NumberFormatException is thrown and AS 7 instance is not disocvered

Expected results:

AS 7 instance is discovered

Additional info:
Comment 1 Mike Foley 2012-01-03 10:01:30 EST
7.1 security was only added after rhq 4.2 was released.   Possibly need to handle this unhandled better exception in a more informative way...and/or release note to clarify AS7 version support ... and steps to disable or deal with this.
Comment 2 Ted Jones 2012-01-03 11:17:29 EST
Created attachment 550462 [details]
NPE during AS 7 discovery
Comment 3 Ted Jones 2012-01-03 11:18:55 EST
After commenting out security in the standalone.xml from CR1b and the version in master, I encountered the attached NPE.
Comment 4 Heiko W. Rupp 2012-01-04 15:32:41 EST
The newest versions of AS7 now also have a ${} expression for the management port
Comment 5 Heiko W. Rupp 2012-01-05 05:49:59 EST
0fdee77760fd6a in master
Comment 6 Heiko W. Rupp 2012-01-05 05:54:12 EST
Actually it is aa4ec7d05bb3 -- pull --rebase modified it
Comment 7 Libor Zoubek 2012-01-25 10:06:05 EST
verified on EAP6 DR12 - detection works with ${<prop>:default} either prop is passed to standalone.sh or not
Comment 8 Mike Foley 2012-02-07 14:20:44 EST
changing status of VERIFIED BZs for JON 2.4.2 and JON 3.0 to CLOSED/CURRENTRELEASE

Note You need to log in before you can comment on or make changes to this bug.