Bug 770970 - lvm2 man page and documentation for "normal" Allocation Policy needs to be improved
lvm2 man page and documentation for "normal" Allocation Policy needs to be im...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: lvm2 (Show other bugs)
5.7
All Linux
high Severity high
: rc
: ---
Assigned To: Alasdair Kergon
Cluster QE
: Documentation, ManPageChange
Depends On:
Blocks: 743405
  Show dependency treegraph
 
Reported: 2011-12-30 11:04 EST by Luca Villa
Modified: 2013-01-08 02:11 EST (History)
13 users (show)

See Also:
Fixed In Version: lvm2-2.02.88-10.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 796977 796978 (view as bug list)
Environment:
Last Closed: 2013-01-08 02:11:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Luca Villa 2011-12-30 11:04:12 EST
Description of problem:
Documentation describing lvm2 "normal" allocation policy is not very comprehensive and needs to be improved in order to allow the reader to be fully aware about how the extents of a logical volume are allocated.

Version-Release number of selected component (if applicable):


How reproducible:
N/A

Steps to Reproduce:
N/A
  
Actual results:
This is the only description available about how normal policy works in the man page:
"The default for a volume group is normal which applies common-sense rules such as not placing parallel stripes on the same physical volume"
In the Logical Volume Manager Administration guide the description is pretty the same.

Expected results:
A more comprehensive description about how extents are allocated throughout PVs possibly with details and examples.

Additional info:
The same applies to RHEL6 as well.
Comment 1 Alasdair Kergon 2012-03-07 15:11:40 EST
Yes, we can provide more-detailed documentation.

To cover:
  - How the set of 'available' extents is generated (command line, existing space)
  - Outline of the process and how the --alloc policy affects it
  - Rules for 'parallel' extents (mirror, stripes)
    - Description of each policy

Not to cover specific implementation details (i.e. the bits that are not guaranteed and might change from release to release)
Comment 2 RHEL Product and Program Management 2012-04-02 06:46:34 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 9 Corey Marthaler 2012-09-06 15:59:42 EDT
Verified the new "ALLOCATION" section in the lvm man page.

"ALLOCATION
       When an operation needs to allocate Physical Extents for one or more Logical Volumes, the tools proceed as follows:

[...]
"

lvm2-2.02.88-10.el5    BUILT: Tue Aug 28 01:21:59 CDT 2012
Comment 11 errata-xmlrpc 2013-01-08 02:11:42 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0023.html

Note You need to log in before you can comment on or make changes to this bug.