Bug 77098 - pstops filter corrupts file produced by Mac
pstops filter corrupts file produced by Mac
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: cups (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-10-31 23:13 EST by Jonathan Kamens
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version: 1.1.19-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-05-28 05:29:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Mac PS file corrupted by cups (73.72 KB, application/postscript)
2002-10-31 23:15 EST, Jonathan Kamens
no flags Details

  None (edit)
Description Jonathan Kamens 2002-10-31 23:13:41 EST
The attached file, produced by AppleWorks 6 on MacOS 9, can't be printed with
cups-1.1.15-2, because the pstops filter corrupts.  It appears that the filter
replaces all carriage returns with newlines, which is a problem with files that
contain binary eexecs.  The same file can be printed successfully after it is
run through the "ps2ps" filter that comes with ghostscript, because that filter
converted binary data into encoded data and gets rid of carriage returns.

One potential solution to this bug would that rather than converting carriage
returns to line feeds, pstops should probably leave intact whatever line endings
are in place and just adjust its own idea of what the correct line ending
character is.
Comment 1 Jonathan Kamens 2002-10-31 23:15:53 EST
Created attachment 83010 [details]
Mac PS file corrupted by cups
Comment 2 Tim Waugh 2003-03-04 09:03:05 EST
I think this is the cups 'binary PostScript' problem that is fixed upstream.
Comment 3 Jonathan Kamens 2003-03-30 13:17:27 EST
Fixed upstream in what CUPS version?
Comment 4 Tim Waugh 2003-03-30 15:32:11 EST
I thought I saw it in the release notes for 1.1.18, but apparently not.  Maybe
it's in CVS then.  Google won't remind me where it was I saw it, it seems.
Comment 5 Michael Sweet 2003-04-18 10:55:19 EDT
This is fixed in 1.1.19.

Note: in conjunction with the new binary-safe pstops filter in 1.1.19, you
usually also must configure the binary transmission protocol for PostScript
printers - see the web configuration page or "man lpadmin" for more info.

Note You need to log in before you can comment on or make changes to this bug.