Bug 770999 - segmentation violation when trying to turn on fips mode
Summary: segmentation violation when trying to turn on fips mode
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: nss-softokn
Version: 16
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Elio Maldonado Batiz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-30 22:35 UTC by Elio Maldonado Batiz
Modified: 2012-01-14 17:49 UTC (History)
4 users (show)

Fixed In Version: nss-softokn-3.13.1-15.fc16, nss-softokn-3.13.1-15.fc15
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-11 06:18:56 UTC


Attachments (Terms of Use)
Use the upstream version that works (1.98 KB, patch)
2011-12-30 22:35 UTC, Elio Maldonado Batiz
no flags Details | Diff

Description Elio Maldonado Batiz 2011-12-30 22:35:04 UTC
Created attachment 550097 [details]
Use the upstream version that works

Description of problem:
When turning fips mode on an nss databse a seg fault occurs.

Version-Release number of selected component (if applicable):
nss-softokn-3.13.1-14

How reproducible:


Steps to Reproduce:
1. mkdir nssdb
2. certutil -d `pwd`/nssdb -N
3. Enter a password when prompted
4. modutil -dbdir `pwd/nssdb -fips true -force
  
Actual results:
A segmentation violation occurs

Expected results:
No segmantion occurs and "FIPS mode enabled." is printed

Additional info:

The segfault is due to an unneeded free in BLAPI_SHVerifyFile which should have been removed when we updated nss-softokn to to 3.13.1 but wasn't.

The nss-softokn-3.12.4-preelink.patch has this portion:
@@ -486,6 +486,9 @@ BLAPI_SHVerifyFile(const char *shName)
 
 loser:
+    if (shName != NULL) {
+	PR_Free(shName);
+    }
     if (checkName != NULL) {
 	PORT_Free(checkName);
     }
which should be removed. 

The simplest solution is to replace it with the upstream version currently under review

Comment 1 Fedora Update System 2011-12-31 20:54:20 UTC
nss-3.13.1-8.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/nss-3.13.1-8.fc16

Comment 2 Fedora Update System 2012-01-01 03:23:40 UTC
nss-softokn-3.13.1-15.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/nss-softokn-3.13.1-15.fc15

Comment 3 Fedora Update System 2012-01-01 21:22:50 UTC
Package nss-softokn-3.13.1-15.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing nss-softokn-3.13.1-15.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-0004/nss-softokn-3.13.1-15.fc16
then log in and leave karma (feedback).

Comment 4 Fedora Update System 2012-01-11 06:18:56 UTC
nss-softokn-3.13.1-15.fc16, nss-3.13.1-10.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.