Bug 77101 - Sound doesnt' work on systems with Intel P4 chipsets (Intel 845G for example) with in-built ICH4 audio
Summary: Sound doesnt' work on systems with Intel P4 chipsets (Intel 845G for example)...
Status: CLOSED DUPLICATE of bug 76830
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i686 Linux
high
high
Target Milestone: ---
Assignee: Doug Ledford
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-01 05:47 UTC by Need Real Name
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-11-08 10:23:26 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2002-11-01 05:47:10 UTC
Description of Problem:
Sound doesn't work on Intel (original) motherboards with in-built ICH4 audio.
The following error message comes on using modprobe with the i810_audio driver
(which is what is supposed to be used): Primary codec not ready
On using sndconfig, the error is "init_module failed"


Version-Release number of selected component (if applicable):
kernel version 2.4.18-17 (which is the latest update)

How Reproducible:
This happens always and on all systems with the above-mentioned hardware.

Steps to Reproduce:
1. not applicalble
2. 
3. 

Actual Results:
The module should have got inserted without any errors and sound should have
worked correctly.

Expected Results:
sound doesn't work

Additional Information:
	
I have fixed this bug by placing a very small hack in the i810_audio.c which is
the kernel sound driver. The hack is ugly but it makes sound work perfectly once
the kernel/modules are recompiled. This also worked perfectly for other people
who had the same hardware and they were able to get audio perfectly !!

Comment 1 Leonid Mamtchenkov 2002-11-01 08:48:07 UTC
I beleive this bug is related to bug 76830 .

Comment 2 Need Real Name 2002-11-08 10:23:19 UTC
The problem can be fixed the following way by adding a small hack to the driver
source code. Go to /usr/src/`uname -a`/drivers/sound/i810_audio.c and add 
"return 1" at the beginning of the function i810_ac97_exists() so that it always
returns 1. Recompile the modules and install them. Sound would work now !!!.

This is definitely a bug in the i810_audio.c file of this kernel version which
needs to be fixed by the maintainer/developer.



Comment 3 Doug Ledford 2002-11-08 17:59:40 UTC

*** This bug has been marked as a duplicate of 76830 ***


Note You need to log in before you can comment on or make changes to this bug.