Bug 771025 - clamd-0.97.3-2.el6 breaks clamd init script
Summary: clamd-0.97.3-2.el6 breaks clamd init script
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: clamav
Version: el6
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Steven Pritchard
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-31 09:26 UTC by Milan Kerslager
Modified: 2020-09-07 17:08 UTC (History)
6 users (show)

Fixed In Version: clamav-0.97.3-3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-17 17:56:29 UTC
Type: ---


Attachments (Terms of Use)
Redux of earlier patch (11.09 KB, patch)
2012-01-02 09:28 UTC, Philip Prindeville
no flags Details | Diff

Description Milan Kerslager 2011-12-31 09:26:58 UTC
Latest update (clamd-0.97.3-2.el6) changed the name of initscript from clamd to clamav. The new script has not been addes to the list of init scripts too (chkconfig --add clamav).

This change beraks running systems because after reboot, the daemon will not be running.

This is worthless change in stable feed...

Comment 1 Fedora Update System 2012-01-01 23:08:29 UTC
clamav-0.97.3-3.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/clamav-0.97.3-3.el6

Comment 2 Fedora Update System 2012-01-01 23:08:38 UTC
clamav-0.97.3-3.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/clamav-0.97.3-3.el5

Comment 3 Nick Bebout 2012-01-01 23:09:06 UTC
Sorry, that was not intended.  I didn't notice that change when I applied the patches included in -2.  I've re-built the previous version as 0.97.3-2.

Comment 4 Nick Bebout 2012-01-01 23:09:40 UTC
re-built the previous version as 0.97.3-3 I mean.

Comment 5 Philip Prindeville 2012-01-02 09:10:42 UTC
(In reply to comment #0)
> Latest update (clamd-0.97.3-2.el6) changed the name of initscript from clamd to
> clamav. The new script has not been addes to the list of init scripts too
> (chkconfig --add clamav).

Actually, the original .spec was confusing to begin with:

Source1: clamav.init
...
install -Dp -m0755 %{SOURCE1} %{buildroot}%{_initrddir}/clamd

which begs the question, "why wasn't the source file just called "clamd.init" to begin with and avoid confusion?


> 
> This change beraks running systems because after reboot, the daemon will not be
> running.

No, that breaks for a different reason...  You need to explicitly do a:

chkconfig clamd on

to explicitly enable the service.

> This is worthless change in stable feed...

Comment 6 Philip Prindeville 2012-01-02 09:28:16 UTC
Created attachment 550216 [details]
Redux of earlier patch

Found the regression and fixed it: the init script was being installed into the wrong name.

This patch makes 3 changes:

* break out the embedded files from the .spec file directly into the SCM;

* put the clamd-wrapper script into the correct (sub)package;

* deprecate the clamd-wrapper tarball.

Comment 7 Fedora Update System 2012-01-02 19:53:16 UTC
Package clamav-0.97.3-3.el5:
* should fix your issue,
* was pushed to the Fedora EPEL 5 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing clamav-0.97.3-3.el5'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2012-0005/clamav-0.97.3-3.el5
then log in and leave karma (feedback).

Comment 8 Fedora Update System 2012-01-17 17:56:29 UTC
clamav-0.97.3-3.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2012-01-17 17:56:47 UTC
clamav-0.97.3-3.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 10 Philip Prindeville 2012-01-17 19:23:50 UTC
(In reply to comment #6)
> Created attachment 550216 [details]
> Redux of earlier patch
> 
> Found the regression and fixed it: the init script was being installed into the
> wrong name.
> 
> This patch makes 3 changes:
> 
> * break out the embedded files from the .spec file directly into the SCM;
> 
> * put the clamd-wrapper script into the correct (sub)package;
> 
> * deprecate the clamd-wrapper tarball.

Wow, not even a comment acknowledging that a patch that addresses the issue had been attached?


Note You need to log in before you can comment on or make changes to this bug.