Bug 771047 - dvbscan: Unable to query frontend status
Summary: dvbscan: Unable to query frontend status
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dvb-apps
Version: 16
Hardware: i386
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Peter Robinson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2011-12-31 13:29 UTC by Jan ONDREJ
Modified: 2012-07-05 23:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-07-05 23:32:18 UTC


Attachments (Terms of Use)
[PATCH] don't install broken dvbscan utility (957 bytes, patch)
2012-06-26 08:11 UTC, Jirka Klimes
no flags Details | Diff

Description Jan ONDREJ 2011-12-31 13:29:17 UTC
Description of problem:
Current version of dvbscan in Fedora does not work. I can see my current DVB-T channels, but can't scan them using dvbscan.

Version-Release number of selected component (if applicable):
dvb-apps-1.1.2-0.d4e8bf5658ce.fc16.i686

How reproducible:
always

Steps to Reproduce:
1. dvbscan /usr/share/dvb/dvb-t/sk-Kosice
  
Actual results:
Unable to query frontend status

Expected results:
scanning /usr/share/dvb/dvb-t/sk-Kosice
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
initial transponder 778000000 0 2 9 3 1 3 0
initial transponder 506000000 0 2 9 3 1 3 0
>>> tune to: 778000000:INVERSION_AUTO:BANDWIDTH_8_MHZ:FEC_2_3:FEC_AUTO:QAM_64:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
...

Additional info:
This version works in Fedora too:
http://download.opensuse.org/distribution/12.1/repo/oss/suse/i586/dvb-1.1.1_20100509-10.1.2.i586.rpm
It's enough to unpack "bin" directory and run "scan" binary.
You can check, what's different.

Comment 2 Jan ONDREJ 2012-01-08 11:09:11 UTC
Still same problem. :(

<home:pts0:~>$ rpm -q dvb-apps                                                  dvb-apps-1.1.2-0.1457.bec11f78be51.fc16.i686                                    <home:pts0:~>$ dvbscan /usr/share/dvb/dvb-t/sk-Kosice 
Unable to query frontend status
<home:pts0:~>$

Comment 3 Jan ONDREJ 2012-03-18 09:09:35 UTC
Any progress here? Can you backport suse changes?

Comment 4 Peter Robinson 2012-03-18 17:58:27 UTC
(In reply to comment #3)
> Any progress here? Can you backport suse changes?

I recently pulled in the head from upstream, when suse's changes are upstreamed we will get them.

Comment 5 Jan ONDREJ 2012-04-12 16:05:28 UTC
1.1.2-0.1479.37781d27a444 - same problem

[root@home ~]# rpm -q dvb-apps
dvb-apps-1.1.2-0.1479.37781d27a444.fc16.i686
[root@home ~]# dvbscan /usr/share/dvb/dvb-t/sk-Kosice 
Unable to query frontend status

Comment 6 Jirka Klimes 2012-06-26 08:08:50 UTC
Upsteam dvb-apps tree actually contains two scan utilities:
scan - works OK
dvbscan - is broken and actually not implemented

Fedora packages rename "scan" to "scandvb" possibly to avoid collision with other utilities. Older packages contained just this scandvb utility.
However, newer packages made of ustream snapshots also contain broken "dvbscan" which makes the confusion.

So, just use "scandvb" instead od "dvbscan":
$ scandvb /usr/share/dvb/dvb-t/sk-Kosice

I suggested removing dvbscan completely to ustream as the utility seems to be abandoned and scanning is not actually implemented in it.

Comment 7 Jirka Klimes 2012-06-26 08:11:37 UTC
Created attachment 594393 [details]
[PATCH] don't install broken dvbscan utility

Exclude /usr/bin/dvbscan

Comment 8 Fedora Update System 2012-06-26 14:04:24 UTC
dvb-apps-1.1.2-1.1479.37781d27a444.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/dvb-apps-1.1.2-1.1479.37781d27a444.fc16

Comment 9 Fedora Update System 2012-06-26 14:04:36 UTC
dvb-apps-1.1.2-1.1479.37781d27a444.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dvb-apps-1.1.2-1.1479.37781d27a444.fc17

Comment 10 Fedora Update System 2012-06-26 21:29:13 UTC
Package dvb-apps-1.1.2-1.1479.37781d27a444.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing dvb-apps-1.1.2-1.1479.37781d27a444.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9935/dvb-apps-1.1.2-1.1479.37781d27a444.fc16
then log in and leave karma (feedback).

Comment 11 Fedora Update System 2012-07-05 23:32:18 UTC
dvb-apps-1.1.2-1.1479.37781d27a444.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 12 Fedora Update System 2012-07-05 23:33:06 UTC
dvb-apps-1.1.2-1.1479.37781d27a444.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.