This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 771053 - new nepomuk config group
new nepomuk config group
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kdebase-runtime (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks: kde-4.8
  Show dependency treegraph
 
Reported: 2011-12-31 09:26 EST by Rex Dieter
Modified: 2012-02-07 04:34 EST (History)
8 users (show)

See Also:
Fixed In Version: kde-runtime-4.8.0-3.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-02-07 04:34:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rex Dieter 2011-12-31 09:26:45 EST
Newer nepomuk now includes options to enable/disable indexing for files and email individually.

File indexing was handled by nepomukserverrc:
[Service-nepomukstrigiservice]
autostart=[true|false]

now,
[Service-nepomukfileindexer]
autostart=[true|false]


Offhand, cant seem to figure out what config file/key controls Email indexing.


Secondarily, there seems to be no kconf script to migrate settings from [Service-nepomukstrigiservice] group.
Comment 1 Kevin Kofler 2012-02-07 03:22:58 EST
nepomukstrigiservice was renamed to nepomukfileindexer. I guess they didn't realize that it would affect the config file, in fact I see a commit saying "Replaced the term "strigi" with "file indexer" everywhere.
The only exception is the config file so we do not loose folder
configurations and do not have to do tedious config migration.", but apparently the impact on nepomukserverrc was missed.

E-mail indexing appears to be totally separate, handled by Akonadi. It was never configured through nepomukserverrc.

We only need a kconf_update script handling the rename of the Service-nepomukstrigiservice group to Service-nepomukfileindexer in nepomukserverrc.
Comment 2 Kevin Kofler 2012-02-07 03:30:37 EST
This should do the trick:

# nepomukstrigiservice-migrate.upd
Id=nepomukstrigiservice-migrate
File=nepomukserverrc
Group=Service-nepomukstrigiservice,Service-nepomukfileindexer
AllKeys
RemoveGroup=Service-nepomukstrigiservice
Comment 3 Kevin Kofler 2012-02-07 04:34:06 EST
Should be fixed in kde-runtime-4.8.0-3.fc17, which is now built in Rawhide, please test.

Note You need to log in before you can comment on or make changes to this bug.