Bug 77108 - no charset info in email sent from anacron, broken non-ascii chars
Summary: no charset info in email sent from anacron, broken non-ascii chars
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anacron (Show other bugs)
(Show other bugs)
Version: 8.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jens Petersen
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2002-11-01 10:18 UTC by Daniel Resare
Modified: 2007-04-18 16:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-30 23:04:22 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Daniel Resare 2002-11-01 10:18:21 UTC
Description of Problem:

When I have system language set to swedish, swedish messages are starting to
show up here and there, for example in commands that anacron runs. Unfortunately
the emails that anacron sends do not have charset properly indicated. This leads
to broken non-ascii characters in popular email clients.

Version-Release number of selected component (if applicable):
anacron-2.3-23

How Reproducible:
always

Steps to Reproduce:
1. create a cronscript in /etc/cron.daily containing for example the line
'LANG=sv_SE.UTF-8 chmod 0 /nonexistant'
2. Wait for anacron to run the script and send mail. The fourth word should
include ä but doesn't 
3. 

Actual Results:
 The raw utf-8 sequence is displayed in the sent mail due to missing charset
email header

Expected Results:
 The fourth word should include ä

Additional Information:
 I believe the correct way to do this is to always include Content-Type:
text/plain; charset=CHARSET in all email sent from anacron. The CHARSET value
should be fetched from nl_langinfo(3)

Comment 1 Jens Petersen 2003-07-10 06:36:46 UTC
I added an untested patch to address this in anacron-2.3-28.

Could you please test it is ok, and if so close the bug?


Note You need to log in before you can comment on or make changes to this bug.