Bug 771086 - usb pass thru shutdown down qemu-kvm process Fedora 16
usb pass thru shutdown down qemu-kvm process Fedora 16
Status: CLOSED DUPLICATE of bug 769625
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2011-12-31 21:35 EST by gcarter
Modified: 2013-01-09 19:39 EST (History)
19 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-30 15:02:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description gcarter 2011-12-31 21:35:42 EST
Description of problem:
Attempt to use USB pass through device in Fedora 16 results in shutdown of entire qemu-kvm process.  Problem doesn't appear to be kernel related, as a proper shutdown happens and gdb reports no exception

The device in question:
USB 0cf3:7015 Atheros (TP-LINK TL-WN821N V3)

The devices module, or device drive was blacklisted, so that it is not in use before virtual machine is launched.  (i.e. /etc/modules/

SELinux is disabled.

Module appears and loads fine under the virtual machine.  However, when an attempt is made to connect the virtual machine to an access point, the entire qemu-kvm process quits.

The log of the virtual machine displays:

qemu-kvm: /builddir/build/BUILD/qemu-kvm-0.15.1/hw/usb.c:336: usb_packet_complete: Assertion `p->owner != ((void *)0)' failed.
2011-12-31 19:23:51.814: shutting down

Version-Release number of selected component (if applicable):

Fedora Linux, with Linux 3.1.6-1.fc16.x86_64 and Guest.

Although, same thing happens regardless of kernel version.

How reproducible:

1) Assign htc_ath9k to black list so it doesn't load, or unload it.
2) Insert USB 0cf3:7015 Atheros (TP-LINK TL-WN821N V3)
3) Start the Fedora 16 3.1.x kernel.
4) Boot into KDE desktop.
5) Click on the AP in the Network Manager, my example required WPA2 password.
6) Type in the KDE keychain password.

Steps to Reproduce:
1) Assign htc_ath9k to black list so it doesn't load, or unload it.
2) Insert USB 0cf3:7015 Atheros (TP-LINK TL-WN821N V3)
3) Start the Fedora 16 3.1.x kernel.
4) Boot into KDE desktop.
5) Click on the AP in the Network Manager, my example required WPA2 password.
6) Type in the KDE keychain password.
 
Actual results:

qemu-kvm exception
qemu-kvm: /builddir/build/BUILD/qemu-kvm-0.15.1/hw/usb.c:336: usb_packet_complete: Assertion `p->owner != ((void *)0)' failed.
2011-12-31 19:23:51.814: shutting down


Expected results:
Connection to the AP for the Guest with no quitting.

Additional info:

Various attempts to debug using the GNU debugger:

First Attempt

[gcarter@kali linux-3.1.2]$ gdb vmlinux
GNU gdb (GDB) Fedora (7.3.50.20110722-10.fc16)
Copyright (C) 2011 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "x86_64-redhat-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /mnt/ssd/kernel/build/linux-3.1.2/vmlinux...done.
(gdb) set remotebaud 115200 
(gdb) target remote /dev/pts/12
Remote debugging using /dev/pts/12
kgdb_breakpoint () at kernel/debug/debug_core.c:960
960             wmb(); /* Sync point after breakpoint */
(gdb) continue
Continuing.
Remote communication error.  Target disconnected.: Input/output error.
(gdb) 
(Target Crashed or Quit)

Doesn't appear to be a kernel problem otherwise I would expect a exception in gdb.
Comment 1 Paul Bolle 2012-01-25 06:15:52 EST
Mark as duplicate of bug #769625 ? That report has a (backported) patch
attached, which is claimed to fix this issue.
Comment 2 Justin M. Forbes 2012-01-30 15:02:42 EST

*** This bug has been marked as a duplicate of bug 769625 ***

Note You need to log in before you can comment on or make changes to this bug.