Bug 771167 - rhn-register GUI won't check for invalid login/password combination
Summary: rhn-register GUI won't check for invalid login/password combination
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rhn-client-tools   
(Show other bugs)
Version: 6.3
Hardware: Unspecified
OS: Unspecified
high
medium
Target Milestone: rc
: ---
Assignee: Miroslav Suchý
QA Contact: Jiří Mikulka
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 781336
TreeView+ depends on / blocked
 
Reported: 2012-01-02 09:00 UTC by Martin Minar
Modified: 2016-07-04 00:56 UTC (History)
3 users (show)

Fixed In Version: rhn-client-tools-1.0.0-76.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 781336 (view as bug list)
Environment:
Last Closed: 2012-06-20 12:00:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:0752 normal SHIPPED_LIVE rhn-client-tools and yum-rhn-plugin bug fix and enhancement update 2012-06-19 19:31:17 UTC

Description Martin Minar 2012-01-02 09:00:48 UTC
Description of problem:
When you try to register into RHN using rhn-register GUI and use wrong password GUI tool will still let you into next step (failing at the end of whole register process).

Version-Release number of selected component (if applicable):
rhn-client-tools-1.0.0-73.el6

How reproducible:
3 of 3

Steps to Reproduce:
1. Have GUI capable system.
2. Run rhn_register (GUI)
3. Select RHN and enter wrong password
  
Actual results:
GUI will let you to next step - even tho on terminal or in /var/log/up2date there will be error message:
Error Message:
    Invalid username/password combination

Expected results:
GUI will return wrong login/password combination message.

Additional info:
Log /var/log/up2date:
Error Message:
    Invalid username/password combination
Error Class Code: 2
Error Class Info: 
     Invalid username and password combination.

     If you are using email address as a login, try using your associated
     login name instead.
Explanation: 
     An error has occurred while processing your request. If this problem
     persists please enter a bug report at bugzilla.redhat.com.
     If you choose to submit the bug report, please be sure to include
     details of what you were trying to do when this error occurred and
     details on how to reproduce this problem.


[Mon Jan  2 09:59:06 2012] rhn_register 
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 256, in onChooseChannelPagePrepare
    self.chooseChannelPagePrepare()
  File "/usr/share/rhn/up2date_client/rhnregGui.py", line 586, in chooseChannelPagePrepare
    self.channels = self.eus_channels['channels']
<type 'exceptions.AttributeError'>: Gui instance has no attribute 'eus_channels'

Comment 2 Miroslav Suchý 2012-01-03 13:10:32 UTC
Note: this happend only if registering against hosted. It does *not* happen when registering against RHN Satellite.

Comment 3 Miroslav Suchý 2012-01-09 16:26:51 UTC
Fixed in spacewalk in 60555bc0bd4090cd39b87f964fd55cd3a9a29785
cherrypicked to satellite.git as 9e31f2ae21f88f15f7f28a79647b2cc0b0c6f997

Note this fix change behaviour of hardware reactivation a little. (it moved the activation to one of earlier screen). So this may need to be retested as well.

Comment 5 Jiří Mikulka 2012-01-20 10:53:30 UTC
While verifying this bug I hit another problem. 

When I tried to register against Hosted using rhn_register selecting the option "I have acces to a Red Hat Network Satellite or Red Hat Network Proxy. I'd like to receive software updates from the Satellite or Proxy below:" + Hosted location registration proceeded even if wrong login or password was used. Registration failed at the end of the process only with traceback in /var/log/up2date and error message in terminal (same as in comment 0).

Could you (Miroslav?) fix the problem described above?
Switching to FAILED_QA.

Otherwise when registering against RHN Satellite, even if wrong login/password is used, a window with error message is shown.

Comment 9 errata-xmlrpc 2012-06-20 12:00:03 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-0752.html


Note You need to log in before you can comment on or make changes to this bug.