Bug 771299 - Conflicts on update from gnome-keyring to gcr
Summary: Conflicts on update from gnome-keyring to gcr
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcr
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthias Clasen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-03 08:49 UTC by Tom Hughes
Modified: 2012-01-03 13:58 UTC (History)
2 users (show)

Fixed In Version: gcr-3.3.3.1-4.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-01-03 13:58:08 UTC
Type: ---


Attachments (Terms of Use)

Description Tom Hughes 2012-01-03 08:49:43 UTC
Description of problem:

Updating a rawhide install that has gnome-keyring installed reports a conflict.

Version-Release number of selected component (if applicable):

gnome-keyring-3.2.1-1.fc17.x86_64
gcr-3.3.3.1-3.fc17.x86_64

How reproducible:

Every time.

Steps to Reproduce:
1. Install gnome-keyring
2. Try a yum update
  
Actual results:

yum reports conflicts:

Transaction Check Error:
  file /usr/bin/gcr-viewer from install of gcr-3.3.3.1-3.fc17.x86_64 conflicts with file from package gnome-keyring-3.2.1-1.fc17.x86_64
  file /usr/lib64/libgck-1.so.0.0.0 from install of gcr-3.3.3.1-3.fc17.x86_64 conflicts with file from package gnome-keyring-3.2.1-1.fc17.x86_64
...

Expected results:

gnome-keyring is obsoleted and removed by the update.

Additional info:

I shouldn't really have passed the review for this with this error but I failed to notice the problem during the review.

Comment 1 Tomáš Bžatek 2012-01-03 09:48:39 UTC
There are gnome-keyring-3.3.3.1-1.fc17 and gnome-keyring-3.3.3.1-2.fc17 builds which you need to have. Not sure why they're not available in the repo. Check your whole yum log for the big picture.

Comment 2 Tom Hughes 2012-01-03 09:56:57 UTC
Ah yes, I was using --skip-broken as I normally do on rawhide and my gnome-keyring is refusing to update because I have gnome-keyring-devel installed:

Error: Package: gnome-keyring-devel-3.2.1-1.fc17.x86_64 (@fedora-rawhide)
           Requires: gnome-keyring = 3.2.1-1.fc17
           Removing: gnome-keyring-3.2.1-1.fc17.x86_64 (@fedora-rawhide)
               gnome-keyring = 3.2.1-1.fc17
           Updated By: gnome-keyring-3.3.3.1-2.fc17.x86_64 (fedora-rawhide)
               gnome-keyring = 3.3.3.1-2.fc17

So as that no longer exists I guess the new gnome-keyring needs to obsolete it? or maybe gcr-devel should do so that it gets installed instead?

Comment 3 Tomáš Bžatek 2012-01-03 10:03:29 UTC
(In reply to comment #0)
> Expected results:
> 
> gnome-keyring is obsoleted and removed by the update.

gnome-keyring is alive and healthly package and shouldn't be obsoleted. Gcr is just a split of an auxiliary library.

Added the "Conflicts: gnome-keyring < 3.3.0" and built gcr-3.3.3.1-4.fc17, hopefully it should be all set now.

Comment 4 Tomáš Bžatek 2012-01-03 10:05:37 UTC
(In reply to comment #2)
> Ah yes, I was using --skip-broken as I normally do on rawhide and my
> gnome-keyring is refusing to update because I have gnome-keyring-devel
> installed:
> 
> Error: Package: gnome-keyring-devel-3.2.1-1.fc17.x86_64 (@fedora-rawhide)
>            Requires: gnome-keyring = 3.2.1-1.fc17
>            Removing: gnome-keyring-3.2.1-1.fc17.x86_64 (@fedora-rawhide)
>                gnome-keyring = 3.2.1-1.fc17
>            Updated By: gnome-keyring-3.3.3.1-2.fc17.x86_64 (fedora-rawhide)
>                gnome-keyring = 3.3.3.1-2.fc17

Weird, should be pulled in automatically.

> So as that no longer exists I guess the new gnome-keyring needs to obsolete it?
> or maybe gcr-devel should do so that it gets installed instead?

You're fast :-) Did that already.

Comment 5 Tom Hughes 2012-01-03 10:43:57 UTC
It still doesn't seem to want to work for me even with the new gcr package. I downloaded the new gcr and gcr-devel packages from koji and asked yum to install them and this is what it said:

Setting up Install Process
Examining gcr-3.3.3.1-4.fc17.x86_64.rpm: gcr-3.3.3.1-4.fc17.x86_64
Marking gcr-3.3.3.1-4.fc17.x86_64.rpm to be installed
Examining gcr-devel-3.3.3.1-4.fc17.x86_64.rpm: gcr-devel-3.3.3.1-4.fc17.x86_64
Marking gcr-devel-3.3.3.1-4.fc17.x86_64.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package gcr.x86_64 0:3.3.3.1-4.fc17 will be installed
---> Package gcr-devel.x86_64 0:3.3.3.1-4.fc17 will be installed
--> Processing Conflict: gcr-3.3.3.1-4.fc17.x86_64 conflicts gnome-keyring < 3.3.0
--> Restarting Dependency Resolution with new changes.
--> Running transaction check
---> Package gnome-keyring.x86_64 0:3.2.1-1.fc17 will be updated
--> Processing Dependency: gnome-keyring = 3.2.1-1.fc17 for package: gnome-keyring-pam-3.2.1-1.fc17.x86_64
--> Processing Dependency: gnome-keyring = 3.2.1-1.fc17 for package: gnome-keyring-devel-3.2.1-1.fc17.x86_64
---> Package gnome-keyring.x86_64 0:3.3.3.1-2.fc17 will be an update
--> Running transaction check
---> Package gnome-keyring.x86_64 0:3.2.1-1.fc17 will be updated
--> Processing Dependency: gnome-keyring = 3.2.1-1.fc17 for package: gnome-keyring-devel-3.2.1-1.fc17.x86_64
---> Package gnome-keyring-pam.x86_64 0:3.2.1-1.fc17 will be updated
---> Package gnome-keyring-pam.x86_64 0:3.3.3.1-2.fc17 will be an update
--> Finished Dependency Resolution
Error: Package: gnome-keyring-devel-3.2.1-1.fc17.x86_64 (@fedora-rawhide)
           Requires: gnome-keyring = 3.2.1-1.fc17
           Removing: gnome-keyring-3.2.1-1.fc17.x86_64 (@fedora-rawhide)
               gnome-keyring = 3.2.1-1.fc17
           Updated By: gnome-keyring-3.3.3.1-2.fc17.x86_64 (fedora-rawhide)
               gnome-keyring = 3.3.3.1-2.fc17 

So there is still nothing forcing gnome-keyring-devel to be removed, which causes the update to fail because it requires the old gnome-keyring while gcr wants the new gnome-keyring (which doesn't have a -devel subpackage).

Comment 6 Tomáš Bžatek 2012-01-03 10:55:43 UTC
Hmm, right, that's another issue, the gnome-keyring-devel package no longer exists since 3.3.3.1-1, a change to gnome-keyring spec file needs to be done.

Comment 7 Tomáš Bžatek 2012-01-03 13:46:51 UTC
Added Obsoletes and Provides directives and built gnome-keyring-3.3.3.1-3.fc17.

Tom, please check if that fixes your issues.

Comment 8 Tom Hughes 2012-01-03 13:58:08 UTC
Yes, that seems to have solved the problem.


Note You need to log in before you can comment on or make changes to this bug.