Bug 771334 - [abrt] kernel: BUG: unable to handle kernel NULL pointer dereference at (null)
[abrt] kernel: BUG: unable to handle kernel NULL pointer dereference at ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:9d06695fc3f2b252b87305bad74...
:
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2012-01-03 06:58 EST by MartinG
Modified: 2012-05-14 13:10 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 13:10:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description MartinG 2012-01-03 06:58:53 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.6-1.fc16.x86_64 root=/dev/mapper/luks-93edd920-d219-404f-8c7c-30f7dacf5d6c ro rd.lvm.lv=VolGroup00/lv_root rd.md=0 rd.dm=0 rd.luks.uuid=luks-93edd920-d219-404f-8c7c-30f7dacf5d6c quiet SYSFONT=latarcyrheb-sun16 rhgb LANG=en_US.UTF-8 KEYTABLE=no rd.lvm.lv=VolGroup00/lv_swap
comment:        Laptop battery went low, causing automatic hibarnation to activate. Got this error either during hibernation, or during wake up.
event_log:      2012-01-03-12:43:21> Smolt profile successfully saved
kernel:         3.1.6-1.fc16.x86_64
reason:         BUG: unable to handle kernel NULL pointer dereference at           (null)
time:           Tue 03 Jan 2012 12:18:26 PM CET

backtrace:
:BUG: unable to handle kernel NULL pointer dereference at           (null)
:IP: [<ffffffff812bc9d6>] __list_add+0x26/0xa0
:PGD 1197a7067 PUD 1197a8067 PMD 0 
:Oops: 0000 [#1] SMP 
:CPU 1 
:Modules linked in: ppdev parport_pc lp parport fuse lockd rfcomm bnep ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter nf_conntrack_ipv4 ip6_tables nf_defrag_ipv4 xt_state nf_conntrack sha256_generic uvcvideo videodev media arc4 cdc_ether usbnet cdc_acm cdc_wdm v4l2_compat_ioctl32 mii snd_hda_codec_conexant microcode btusb bluetooth joydev r852 sm_common nand nand_ids nand_ecc snd_hda_intel snd_hda_codec snd_hwdep r592 mtd memstick snd_seq snd_seq_device i2c_i801 iwlwifi snd_pcm mac80211 iTCO_wdt iTCO_vendor_support cfg80211 e1000e snd_timer snd_page_alloc thinkpad_acpi rfkill snd soundcore uinput sunrpc xts gf128mul dm_crypt firewire_ohci sdhci_pci sdhci mmc_core firewire_core crc_itu_t yenta_socket wmi i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 1595, comm: kded4 Not tainted 3.1.6-1.fc16.x86_64 #1 LENOVO 6474AR4/6474AR4
:RIP: 0010:[<ffffffff812bc9d6>]  [<ffffffff812bc9d6>] __list_add+0x26/0xa0
:RSP: 0000:ffff880118d25d30  EFLAGS: 00010246
:RAX: ffff8801195f0000 RBX: ffff880087deb9b0 RCX: 00000000013f84d3
:RDX: ffff88012c82fdf8 RSI: 0000000000000000 RDI: ffff880087deb9b0
:RBP: ffff880118d25d50 R08: 0000000000000000 R09: 0000000180380038
:R10: ffff88012c82fdc8 R11: ffff8801197a67f8 R12: ffff88012c82fdf8
:R13: 0000000000000000 R14: ffff880118d86580 R15: ffff8801194b89a0
:FS:  00007f017a701840(0000) GS:ffff88013bc80000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 000000008005003b
:CR2: 0000000000000000 CR3: 00000001197a6000 CR4: 00000000000006e0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process kded4 (pid: 1595, threadinfo ffff880118d24000, task ffff8801195f0000)
:Stack:
: ffff880118d25d50 ffff88012c82fdc8 ffff8801194b8a50 ffff880087deb990
: ffff880118d25d80 ffffffff811450b6 ffff88012caa9180 ffff8801194b8a50
: ffff880118d86580 ffff8801194b89b8 ffff880118d25e00 ffffffff81068fa9
:Call Trace:
: [<ffffffff811450b6>] anon_vma_fork+0xd6/0x120
: [<ffffffff81068fa9>] dup_mm+0x279/0x650
: [<ffffffff8106a79a>] copy_process+0x13ea/0x14c0
: [<ffffffff8106a9ba>] do_fork+0xfa/0x330
: [<ffffffff8118df7f>] ? alloc_fd+0x4f/0x150
: [<ffffffff8117d312>] ? path_put+0x22/0x30
: [<ffffffff8101bfa8>] sys_clone+0x28/0x30
: [<ffffffff815dcfe3>] stub_clone+0x13/0x20
: [<ffffffff815dccc2>] ? system_call_fastpath+0x16/0x1b
:Code: 00 00 00 00 00 55 48 89 e5 48 83 ec 20 48 89 5d e8 4c 89 65 f0 48 89 fb 4c 89 6d f8 4c 8b 42 08 49 89 f5 49 89 d4 49 39 f0 75 27 <4d> 8b 45 00 4d 39 c4 75 40 49 89 5c 24 08 4c 89 23 4c 89 6b 08 
:RIP  [<ffffffff812bc9d6>] __list_add+0x26/0xa0
: RSP <ffff880118d25d30>
:CR2: 0000000000000000
:iwlwifi 0000:03:00.0: L1 Disabled; Enabling L0S
:iwlwifi 0000:03:00.0: Radio type=0x0-0x2-0x0

smolt_data:
:
:
:General
:=================================
:UUID: 67785824-19f3-4a88-a110-f166f285ac38
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4787.44
:CPU Vendor: GenuineIntel
:CPU Model: Intel(R) Core(TM)2 Duo CPU     P8600  @ 2.40GHz
:CPU Stepping: 6
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 2401
:System Memory: 3849
:System Swap: 5855
:Vendor: LENOVO
:System: 6474AR4 ThinkPad T400
:Form factor: Notebook
:Kernel: 3.1.6-1.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: MythCenter-wide.720.450
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10816:6058:8416) pci, agpgart-intel, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(32902:10544:6058:8441) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10537:6058:8440) pci, ahci, STORAGE, ICH9M/M-E SATA AHCI Controller
:(32902:10519:6058:8437) pci, None, PCI/ISA, ICH9M-E LPC Interface Controller
:(32902:4341:6058:8430) pci, e1000e, ETHERNET, 82567LM Gigabit Network Connection
:(32902:9288:6058:8436) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10566:6058:8435) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10549:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:6058:8433) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:6058:8433) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(32902:16950:32902:4113) pci, iwlwifi, NETWORK, Ultimate N WiFi Link 5300
:(32902:10818:6058:8420) pci, i915, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10819:6058:8420) pci, None, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10560:6058:8435) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10562:6058:8435) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(32902:10820:6058:8422) pci, None, SIMPLE, Mobile 4 Series Chipset MEI Controller
:(32902:10568:6058:8435) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:6058:8434) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(4480:1426:6058:8394) pci, r592, BASE, ThinkPad T61
:(4480:2130:6058:8395) pci, r852, BASE, xD-Picture Card Controller
:(4480:1142:6058:8390) pci, yenta_cardbus, PCI/CARDBUS, RL5c476 II
:(4480:2098:6058:8391) pci, firewire_ohci, FIREWIRE, R5C832 IEEE 1394 Controller
:(4480:2082:6058:8392) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/luks-93edd920-d219-404f-8c7c-30f7dacf5d6c / ext4 4096 4096 5450381 1737112 1460248 1384448 1029557 1029557
:/dev/sda1 /boot ext3 1024 1024 194442 112126 102087 50200 49930 49930
:/dev/mapper/luks-37ce0790-d1ed-4365-b510-bc62cb94bb70 /home ext3 4096 4096 8393802 822451 396064 2133936 1911062 1911062
:
Comment 1 Stanislaw Gruszka 2012-01-14 12:04:33 EST
This looks like memory corruption. There is known problem on hibernation with i915 driver, which can be the issue here (i915.modeset=0 kernel boot parameter workaround it).
Comment 2 Dave Jones 2012-03-22 13:04:05 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 3 Dave Jones 2012-03-22 13:07:05 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 4 Dave Jones 2012-03-22 13:18:09 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 5 Josh Boyer 2012-03-28 13:59:41 EDT
[Mass hibernate bug update]

Dave Airlied has found an issue causing some corruption in the i915 fbdev after a resume from hibernate.  I have included his patch in this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545

This will probably not solve all of the issues being tracked at the moment, but it is worth testing when the build completes.  If this seems to clear up the issues you see with hibernate, please report your results in the bug.

Note You need to log in before you can comment on or make changes to this bug.