Bug 771524 - Preupgrade from F14 -> F15 -> F16 leaves system unbootable
Preupgrade from F14 -> F15 -> F16 leaves system unbootable
Status: CLOSED DUPLICATE of bug 782144
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
16
i386 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-03 19:09 EST by Mike Iglesias
Modified: 2012-04-24 14:38 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-24 14:38:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gzip'd tar of all the anaconda logs (53.67 KB, application/x-gzip)
2012-04-23 19:00 EDT, Mike Iglesias
no flags Details

  None (edit)
Description Mike Iglesias 2012-01-03 19:09:39 EST
Description of problem:

I used preupgrade to upgrade a dual boot laptop (Fedora + Windows Vista) from F14 to F15 to F16.  The F14 system was up to date before this was started.  At the end of the F15 to F16 upgrade, I got a notice that there was an error installing the bootloader, and when the laptop tried to reboot it got the grub1 boot menu with just the F16 updgrade and Vista items.

I booted the system with an F16 recovery disk, and tried to install grub2 by hand.  I got the following messages:

sh-4.2# /sbin/grub2-install /dev/sda
/sbin/grub2-setup: warn: Your core.img is unusually large.  It won't fit in the 
embedding area..
/sbin/grub2-setup: warn: Embedding is not possible.  GRUB can only be installed 
in this setup by using blocklists.  However, blocklists are UNRELIABLE and their
 use is discouraged..
/sbin/grub2-setup: error: will not proceed with blocklists.

The disk has the following partitions:

/dev/sda1  Dell utility partition starting at block 63
/dev/sda2  Windows Vista
/dev/sda6  Linux / (no /boot partition)
/dev/sda7  Linux swap
/dev/sda8  Linux /home

using "/sbin/grub2-install --force /dev/sda" resulted in the two warning messages above and then "Installation finished.  No error reported."

The system booted and ran a relabeling pass on the filesystems.  It rebooted into Fedora 16 with no problems after that.

It seems like something along the line should have figured out that grub2-install needed to be run with --force to leave me with a bootable system.  I'm not sure if that's preupgrade, anaconda, or ??
Comment 1 Alex Tunc 2012-02-24 13:57:23 EST
Here is same!

waited couple of months to upgrade F16 and yesterday i did it with Preupgrade and i looked Common bugs section and saw preupgrade updated for not update bootloader problem and i checked my one its latest and begin upgrade all went normal without problem but at the end it gived error about bootloader not updated and machine possible not boot.. Now when I boot old grub menu appear and no F16 boot option.. What a big tragedy! Buggy GRUB2 and Not Working Upgrade TOOL! even fixed one?! and No information about this problem on the bugs sections! if i see it I never upgrade it!!! after that I tryed several things booted with DVD media and tryed to install GRUB2 again

grub2-mkconfig -o /boot/grub2/grub2.cfg
and it generates cfg file then
grub2-install /dev/sda Boom! Error! bug@grub2 bla bla! your partition is small core.img cant fit there or like this...and it doesnt re-install grub2! tryed --force option no result..

Now unbootable machine!
Comment 2 Julius Smith 2012-02-26 02:01:05 EST
I hit this one today, perhaps because my /boot partition is only 200MB.  I suggest that grub/grub.conf be put in a usable state before trying to install grub2 instead of being left pointing to the (now nonexistent) preupgrade.  That way the grub boot could work when the grub2 installation fails instead of dying with "not found".  Also, I more than complied with preupgrade's request for more space, deleting a good deal more in /boot than it asked for.  Hopefully that bug has been entered somewhere as well.
Comment 3 Mads Kiilerich 2012-04-16 18:57:53 EDT
(In reply to comment #0)
> I used preupgrade to upgrade a dual boot laptop (Fedora + Windows Vista) from
> F14 to F15 to F16.  The F14 system was up to date before this was started.

That do however sound a lot like bug 737731 ...

>  At
> the end of the F15 to F16 upgrade, I got a notice that there was an error
> installing the bootloader, and when the laptop tried to reboot it got the grub1
> boot menu with just the F16 updgrade and Vista items.

The anaconda logs will tell what happened and what failed.

> It seems like something along the line should have figured out that
> grub2-install needed to be run with --force to leave me with a bootable system.
>  I'm not sure if that's preupgrade, anaconda, or ??

Yes, that is how it usually works. Only the anaconda logs can tell what really happened.
Comment 4 Mike Iglesias 2012-04-16 19:41:08 EDT
This is what is at the end of /var/log/anaconda/anaconda.program.log:

12:37:46,635 INFO program: No delta-package files removed by presto
12:37:47,994 INFO program: Running... grub2-set-default Fedora Linux, with Linux 3.1.6-1.fc16.i686
12:37:48,690 INFO program: Running... grub2-install --no-floppy (hd0)
12:37:51,931 ERR program: /sbin/grub2-setup: warn: Your core.img is unusually large.  It won't fit in the embedding area..
12:37:51,932 ERR program: /sbin/grub2-setup: warn: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
12:37:51,932 ERR program: /sbin/grub2-setup: error: will not proceed with blocklists.
12:37:51,933 INFO program: Running... grub2-mkconfig -o /boot/grub2/grub.cfg
12:37:52,544 ERR program: Generating grub.cfg ...
12:37:52,803 ERR program: Found linux image: /boot/vmlinuz-3.1.6-1.fc16.i686
12:37:52,837 ERR program: Found initrd image: /boot/initramfs-3.1.6-1.fc16.i686.img
12:37:53,969 ERR program:   No volume groups found
12:37:56,216 ERR program: Found Windows Vista (loader) on /dev/sda2
12:37:57,137 ERR program: done
12:37:57,489 INFO program: Running... grub2-install --no-floppy (hd0)
12:37:59,198 ERR program: /sbin/grub2-setup: warn: Your core.img is unusually large.  It won't fit in the embedding area..
12:37:59,199 ERR program: /sbin/grub2-setup: warn: Embedding is not possible.  GRUB can only be installed in this setup by using blocklists.  However, blocklists are UNRELIABLE and their use is discouraged..
12:37:59,199 ERR program: /sbin/grub2-setup: error: will not proceed with blocklists.
Comment 5 Mads Kiilerich 2012-04-16 20:01:21 EDT
Please attach the full log file - that might tell the anaconda developers what happened and why it didn't use the force.

But ... they are probably giving f17 all their attention now ...
Comment 6 Alex Tunc 2012-04-20 17:07:03 EDT
they need to release proper upgrade solution first!  no one can install any new os every 6 months!   this is weird!
Comment 7 Mads Kiilerich 2012-04-20 17:49:50 EDT
(In reply to comment #6)
> they need to release proper upgrade solution first!  no one can install any new
> os every 6 months!   this is weird!

That is the rules of the game when using Fedora. Take it or leave it.

Upgrading is however usually easy and smooth, and the whole scheme gives the advantage of getting the latest software almost ASAP.

Software do however have bugs. They will be fixed once the developers understand the problem - and that requires testing and good bug reports.
Comment 8 Mike Iglesias 2012-04-23 19:00:24 EDT
Created attachment 579711 [details]
gzip'd tar of all the anaconda logs
Comment 9 Mads Kiilerich 2012-04-23 19:58:57 EDT
D'oh. I was looking in the right direction.

This seems to be Bug 782144 - Regression in core.img size in grub2-1.99-13.fc16

"Normal" installations will use the package versions on the installer media, but with preupgrade the latest version is used, and 782144 could then show up while upgrading - not something I had considered.

I assume you now have grub2-1.99-13.fc16.2 or later installed.

What size do "ll /boot/grub2/core.img" show?

Try to run "grub2-install /dev/sda" again. Will it succeed now? What is the new core.img size?

If it still fails then please run "bash -x /sbin/grub2-install /dev/sda 2> log" and attach the log. (It could also be more like Bug 737508 ... but you don't have a complex linux setup so it shouldn't ...)
Comment 10 Mike Iglesias 2012-04-24 12:13:49 EDT
(In reply to comment #9)
> D'oh. I was looking in the right direction.
> 
> This seems to be Bug 782144 - Regression in core.img size in grub2-1.99-13.fc16
> 
> "Normal" installations will use the package versions on the installer media,
> but with preupgrade the latest version is used, and 782144 could then show up
> while upgrading - not something I had considered.
> 
> I assume you now have grub2-1.99-13.fc16.2 or later installed.

Yes, that version is installed.

> 
> What size do "ll /boot/grub2/core.img" show?

-rw-r--r--. 1 root root 31747 Jan  3 07:26 /boot/grub2/core.img

> 
> Try to run "grub2-install /dev/sda" again. Will it succeed now? What is the new
> core.img size?

It works.  New size is:

-rw-r--r--. 1 root root 29295 Apr 24 09:03 /boot/grub2/core.img
Comment 11 Mads Kiilerich 2012-04-24 14:38:49 EDT

*** This bug has been marked as a duplicate of bug 782144 ***

Note You need to log in before you can comment on or make changes to this bug.