Bug 771559 - BUG: unable to handle kernel NULL pointer dereference at 000000000000005c dget_parent
BUG: unable to handle kernel NULL pointer dereference at 000000000000005c dge...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
abrt_hash:432760b4634681ada140f455469...
:
Depends On:
Blocks: kernel_hibernate
  Show dependency treegraph
 
Reported: 2012-01-04 00:46 EST by Harish Pillay
Modified: 2012-05-14 13:10 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-05-14 13:10:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Harish Pillay 2012-01-04 00:46:37 EST
libreport version: 2.0.8
abrt_version:   2.0.7
cmdline:        BOOT_IMAGE=/vmlinuz-3.1.6-1.fc16.x86_64 root=/dev/mapper/vg_vostro-lv_root ro rd.md=0 rd.dm=0 rd.lvm.lv=vg_vostro/lv_swap rd.luks.uuid=luks-9f58b398-eb5c-4a48-a388-87b8d6b99b15 KEYTABLE=us quiet SYSFONT=latarcyrheb-sun16 rhgb rd.lvm.lv=vg_vostro/lv_root LANG=en_US.UTF-8
kernel:         3.1.6-1.fc16.x86_64
reason:         BUG: unable to handle kernel NULL pointer dereference at 000000000000005c
time:           Wed 04 Jan 2012 01:46:10 PM

backtrace:
:BUG: unable to handle kernel NULL pointer dereference at 000000000000005c
:IP: [<ffffffff815d4fbe>] _raw_spin_lock+0xe/0x30
:PGD 0 
:Oops: 0002 [#1] SMP 
:CPU 1 
:Modules linked in: tcp_lp ppdev parport_pc lp parport fuse ebtable_nat ebtables ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle tun bridge stp llc lockd ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 ip6table_filter ip6_tables nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm snd_timer snd virtio_net kvm_intel kvm soundcore uvcvideo videodev media v4l2_compat_ioctl32 dell_laptop r8169 mii iTCO_wdt iTCO_vendor_support arc4 snd_page_alloc iwlwifi mac80211 cfg80211 rfkill dcdbas microcode i2c_i801 joydev sunrpc uinput xts gf128mul dm_crypt i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:Pid: 2014, comm: gnome-terminal Not tainted 3.1.6-1.fc16.x86_64 #1 Dell Inc. Vostro V13/031VJ5
:RIP: 0010:[<ffffffff815d4fbe>]  [<ffffffff815d4fbe>] _raw_spin_lock+0xe/0x30
:RSP: 0018:ffff880111fa3ae8  EFLAGS: 00010282
:RAX: 0000000000010000 RBX: 0000000000000000 RCX: 0000000040000010
:RDX: 0000000000000010 RSI: ffff88013006e000 RDI: 000000000000005c
:RBP: ffff880111fa3ae8 R08: 0000000000000000 R09: 0000000000000000
:R10: ffff880102861210 R11: 0000000000016468 R12: 000000000000005c
:R13: ffff88013006e000 R14: 0000000000000000 R15: 0000000000000010
:FS:  0000000000000000(0000) GS:ffff88013fd00000(0000) knlGS:0000000000000000
:CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
:CR2: 000000000000005c CR3: 0000000001a05000 CR4: 00000000000406e0
:DR0: 0000000000000000 DR1: 0000000000000000 DR2: 0000000000000000
:DR3: 0000000000000000 DR6: 00000000ffff0ff0 DR7: 0000000000000400
:Process gnome-terminal (pid: 2014, threadinfo ffff880111fa2000, task ffff88011b89dcc0)
:Stack:
: ffff880111fa3b18 ffffffff811875ec ffff880111fa3b38 ffff880102861210
: 0000000000000010 ffff88013006e000 ffff880111fa3b58 ffffffff811ac618
: ffff880111fa3b48 ffff880102861200 0000000000000010 ffff88012bd2b530
:Call Trace:
: [<ffffffff811875ec>] dget_parent+0x2c/0x60
: [<ffffffff811ac618>] __fsnotify_parent+0x68/0x100
: [<ffffffff81174323>] fput+0x1b3/0x260
: [<ffffffff8113dd35>] remove_vma+0x45/0x90
: [<ffffffff81140ae8>] exit_mmap+0xe8/0x140
: [<ffffffff81068b13>] mmput+0x73/0x110
: [<ffffffff8106f5c4>] exit_mm+0x124/0x160
: [<ffffffff8106f780>] do_exit+0x180/0x8a0
: [<ffffffff810701f2>] do_group_exit+0x42/0xa0
: [<ffffffff81080d37>] get_signal_to_deliver+0x207/0x5b0
: [<ffffffff81013165>] do_signal+0x65/0x770
: [<ffffffff81063070>] ? try_to_wake_up+0x290/0x290
: [<ffffffff81013918>] do_notify_resume+0x88/0xb0
: [<ffffffff815dcf90>] int_signal+0x12/0x17
:Code: 0f b7 c8 c1 e8 10 39 c1 74 07 f3 90 0f b7 0f eb f5 48 89 d0 5d c3 0f 1f 80 00 00 00 00 55 48 89 e5 66 66 66 66 90 b8 00 00 01 00 <f0> 0f c1 07 0f b7 d0 c1 e8 10 39 c2 74 07 f3 90 0f b7 17 eb f5 
:RIP  [<ffffffff815d4fbe>] _raw_spin_lock+0xe/0x30
: RSP <ffff880111fa3ae8>
:CR2: 000000000000005c

smolt_data:
:
:
:General
:=================================
:UUID: 27a83728-b828-4367-b363-7888641ecdde
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.utf8
:Platform: x86_64
:BogoMIPS: 2593.12
:CPU Vendor: GenuineIntel
:CPU Model: Genuine Intel(R) CPU           U7300  @ 1.30GHz
:CPU Stepping: 10
:CPU Family: 6
:CPU Model Num: 23
:Number of CPUs: 2
:CPU Speed: 1300
:System Memory: 3888
:System Swap: 5951
:Vendor: Dell Inc.
:System: Vostro V13 A01
:Form factor: Portable
:Kernel: 3.1.6-1.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(32902:10816:4136:1067) pci, agpgart-intel, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(32902:10544:4136:1067) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10537:4136:1067) pci, ahci, STORAGE, ICH9M/M-E SATA AHCI Controller
:(32902:10519:4136:1067) pci, None, PCI/ISA, ICH9M-E LPC Interface Controller
:(32902:10564:0:0) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 3
:(32902:9288:0:0) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10566:0:0) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10549:4136:1067) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:4136:1067) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:4136:1067) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:4136:1067) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:4136:1067) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:16946:32902:4897) pci, iwlwifi, NETWORK, WiFi Link 5100 AGN
:(4332:33128:4136:1067) pci, r8169, ETHERNET, RTL8111/8168B PCI Express Gigabit Ethernet controller
:(32902:10818:4136:1067) pci, i915, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10819:4136:1067) pci, None, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10560:0:0) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10568:0:0) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:4136:1067) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:4136:1067) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:4136:1067) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(32902:10556:4136:1067) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_vostro-lv_root / ext4 4096 4096 12901535 10993214 10337854 3276800 3048120 3048120
:/dev/sda2 /boot ext4 1024 1024 495844 407445 381845 128016 127746 127746
:/dev/mapper/vg_vostro-lv_home /home ext4 4096 4096 105647234 39402502 34035923 26836992 26668064 26668064
:
Comment 1 Dave Jones 2012-01-04 10:16:53 EST
did that happen after you resumed from suspend or hibernate ?
Comment 2 Harish Pillay 2012-01-04 10:30:17 EST
Yes but not immediately after suspend.  I had suspended the laptop and then brought it back up, plugged it to an external monitor, worked for about 4 hours or so, then wanted to shutdown and viola.

Harish
Comment 3 Dave Jones 2012-01-04 10:38:33 EST
we have a bunch of these "what the hell happened here?" bugs, and the common theme seems to be that they had suspended at some point.  Current theory is that something on resume is corrupting memory.
Comment 4 Harish Pillay 2012-01-04 10:44:15 EST
Interesting. Even though the kernel oops happened, I could still go about shutting down, although, I think I did have to press the power button off because it was taking too long. So, apart from corrupting memory, the shutdown process was also borked.
Comment 5 Dave Jones 2012-03-22 12:42:10 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 6 Dave Jones 2012-03-22 12:46:47 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 7 Dave Jones 2012-03-22 12:56:11 EDT
[mass update]
kernel-3.3.0-4.fc16 has been pushed to the Fedora 16 stable repository.
Please retest with this update.
Comment 8 Josh Boyer 2012-03-28 14:00:17 EDT
[Mass hibernate bug update]

Dave Airlied has found an issue causing some corruption in the i915 fbdev after a resume from hibernate.  I have included his patch in this scratch build:

http://koji.fedoraproject.org/koji/taskinfo?taskID=3940545

This will probably not solve all of the issues being tracked at the moment, but it is worth testing when the build completes.  If this seems to clear up the issues you see with hibernate, please report your results in the bug.

Note You need to log in before you can comment on or make changes to this bug.