Bug 771685 - [as_IN] Position and joint of 'ু', 'ূ', 'ৃ' in letters not correct
[as_IN] Position and joint of 'ু', 'ূ', 'ৃ' in letters not correct
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: lohit-assamese-fonts (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Pravin Satpute
Fedora Extras Quality Assurance
: i18n
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-04 11:04 EST by Nilamdyuti
Modified: 2012-03-23 20:34 EDT (History)
3 users (show)

See Also:
Fixed In Version: lohit-assamese-fonts-2.5.1-1.fc16
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-03-09 21:07:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Lohit Issues in OpenOffice Writer (Windows Xp) (47.96 KB, image/jpeg)
2012-01-04 11:04 EST, Nilamdyuti
no flags Details
Lohit Issues in OpenOffice Writer (RHEL) (15.13 KB, application/vnd.oasis.opendocument.text)
2012-01-04 11:05 EST, Nilamdyuti
no flags Details

  None (edit)
Description Nilamdyuti 2012-01-04 11:04:26 EST
Created attachment 550709 [details]
Lohit Issues in OpenOffice Writer (Windows Xp)

Description of problem:


The position and joint of 'ু', 'ূ', 'ৃ' in letters is not correct. In some cases they are shifted towards left and in some right when the joining point with the letter is a vertical line ('দু', 'দূ', দৃ') and when the joining point is a curve there is a gap ('চু', 'চূ', 'চৃ'). The gap is prominent when font size is more. This shift and gap is slight when the platform is RHEL or Fedora but for Windows it is bizarrely more. I have received screenshots from users of lohit-assamese in Windows which I am attaching with this bug.
Comment 1 Nilamdyuti 2012-01-04 11:05:46 EST
Created attachment 550710 [details]
Lohit Issues in OpenOffice Writer (RHEL)

I am also attaching an .odt file tested in RHEL. In this file the shift and gap is not enormous like Windows but still it's not correct.
Comment 2 Pravin Satpute 2012-02-23 06:58:44 EST
Problem mentioned in description is not reproducible in Fedora 16 with lohit-assamese-fonts-2.5.0-1.fc16.noarch, it looks like windows specific problem, do ask him to install support for complex scripts.
Comment 3 Pravin Satpute 2012-02-23 07:00:26 EST
Resolved issues mentioned in comment #1, will be available with new upstream release of lohit
Comment 4 Nilamdyuti 2012-02-23 07:05:44 EST
Thanks Pravin!
Comment 5 Fedora Update System 2012-03-01 05:42:59 EST
lohit-assamese-fonts-2.5.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/lohit-assamese-fonts-2.5.1-1.fc17
Comment 6 Fedora Update System 2012-03-01 05:43:55 EST
lohit-assamese-fonts-2.5.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/lohit-assamese-fonts-2.5.1-1.fc16
Comment 7 Fedora Update System 2012-03-01 19:59:13 EST
Package lohit-assamese-fonts-2.5.1-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing lohit-assamese-fonts-2.5.1-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-2819/lohit-assamese-fonts-2.5.1-1.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-03-09 21:07:47 EST
lohit-assamese-fonts-2.5.1-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2012-03-23 20:34:23 EDT
lohit-assamese-fonts-2.5.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.