Bug 77174 - PS/2 mouse not detected
PS/2 mouse not detected
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-02 02:58 EST by Marcus Moeller
Modified: 2008-08-01 12:22 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-30 11:40:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Marcus Moeller 2002-11-02 02:58:02 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20020830

Description of problem:
I4 ve got simple 3 Button PS/2 mouse. The mouse was detected during installation
of RH8.

During the first reboot (after installation) kudzu displays that there is no
generic PS/2 mouse available and asks me to keep configuration / remove
configuration / ignore.

   To make it clear: I tried every possibility - none of them caused any action.

So when I tried to log in, the mouse AND the keyboard freezes. I tired to plug
in several PS/2 mouses but the result is the same. Here is a desciption what I4
ve already tired.

- tried to take a look at /proc/pci to see if IRQ 12 (that is assigned to a PS/2
mouse by default) is already used -> it4 s not

- tried to take a look at /proc/isapnp to see if IRQ 12 is already used -> that4
s what I4 ve found:

...
 Logical device 3 'ESS0002:Unknown'
    Compatible device PNP0600
    Device is active
    Active port 0x168,0x36e
    Active IRQ 12 [0x2]
    Resources 0
...

So I guess that there is a conflict with that sound card. It is a ESS ES1868
Plug and Play AudioDrive.

Perhaps anyone could tell me how to fix that issue






Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.boot into system
2.kudzu starts
3.ps/2 mouse is not detected

	

Actual Results:  X freezes, Mouse and Keyboard do not work

Expected Results:  X should work

Additional info:
Comment 1 Bill Nottingham 2002-11-04 15:39:53 EST
The kernel should not be assigning IRQ 12 to anything with the PnP code, almost
surely.
Comment 2 Bugzilla owner 2004-09-30 11:40:09 EDT
Thanks for the bug report. However, Red Hat no longer maintains this version of
the product. Please upgrade to the latest version and open a new bug if the problem
persists.

The Fedora Legacy project (http://fedoralegacy.org/) maintains some older releases, 
and if you believe this bug is interesting to them, please report the problem in
the bug tracker at: http://bugzilla.fedora.us/

Note You need to log in before you can comment on or make changes to this bug.