This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 771901 - [UI] Anaconda allows RAID partitions to be encrypted
[UI] Anaconda allows RAID partitions to be encrypted
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda (Show other bugs)
5.8
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Brian Lane
Release Test Team
:
Depends On:
Blocks: rhel58rtt
  Show dependency treegraph
 
Reported: 2012-01-05 05:55 EST by Alexander Todorov
Modified: 2013-01-07 23:04 EST (History)
0 users

See Also:
Fixed In Version: anaconda-11.1.2.255-1
Doc Type: Bug Fix
Doc Text:
No Documentation Needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 23:04:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to disable encrypt when 'RAID' button is used (1.29 KB, patch)
2012-01-25 12:09 EST, Brian Lane
no flags Details | Diff

  None (edit)
Description Alexander Todorov 2012-01-05 05:55:39 EST
Description of problem:

In RHEL5 encrypting software RAID partitions is not supported. IIRC the reason was that RAID metadata is at the beginning of the partition and collides with LUKS metadata. 

New RAID partitions can be added from two places in Anaconda UI. The one properly disables the "Encrypt" checkbox the other doesn't. 


Version-Release number of selected component (if applicable):
anaconda-11.1.2.248-1

How reproducible:
Always

Steps to Reproduce:
1. Select custom partitioning
2. Click the New button and select software RAID partition - the Encrypt checkbox is disabled.
3. Click on RAID button and select Create a software RAID partition. The Encrypt checkbox is not disabled.
  
Actual results:
The UI is inconsistent which may lead to confusion. If encryption is selected for the RAID partition later on it can cause partitioning and installation to fail. (it failed in my case).

Expected results:


Additional info:
Comment 1 RHEL Product and Program Management 2012-01-24 13:29:01 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 2 Brian Lane 2012-01-25 12:09:12 EST
Created attachment 557486 [details]
patch to disable encrypt when 'RAID' button is used
Comment 5 RHEL Product and Program Management 2012-08-22 10:39:54 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 7 Alexander Todorov 2012-09-24 09:29:51 EDT
(In reply to comment #0)

> 3. Click on RAID button and select Create a software RAID partition. The
> Encrypt checkbox is not disabled.
>   


This is fixed in 0924.n.0 nightly tree.
Comment 9 errata-xmlrpc 2013-01-07 23:04:37 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0038.html

Note You need to log in before you can comment on or make changes to this bug.