Bug 772064 - Provide native systemd service
Summary: Provide native systemd service
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: dansguardian
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Felix Kaechele
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 751869
TreeView+ depends on / blocked
 
Reported: 2012-01-05 21:12 UTC by Jóhann B. Guðmundsson
Modified: 2012-05-04 23:07 UTC (History)
4 users (show)

Fixed In Version: dansguardian-2.10.1.1-9.fc17
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-20 13:07:30 UTC


Attachments (Terms of Use)
Native systemd service file for dansguardian (193 bytes, text/plain)
2012-01-05 21:13 UTC, Jóhann B. Guðmundsson
no flags Details
Native systemd service file for clamd dansguardian (270 bytes, text/plain)
2012-01-05 21:14 UTC, Jóhann B. Guðmundsson
no flags Details

Description Jóhann B. Guðmundsson 2012-01-05 21:12:10 UTC
Description of problem:

Let's get the ball rolling on this one...

http://fedoraproject.org/wiki/Features/SysVtoSystemd
https://fedoraproject.org/wiki/Packaging:Guidelines:Systemd
https://fedoraproject.org/wiki/Packaging:ScriptletSnippets#Systemd

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jóhann B. Guðmundsson 2012-01-05 21:13:18 UTC
Created attachment 551027 [details]
Native systemd service file for dansguardian

Comment 2 Jóhann B. Guðmundsson 2012-01-05 21:14:01 UTC
Created attachment 551028 [details]
Native systemd service file for clamd dansguardian

Comment 3 Felix Kaechele 2012-01-06 09:10:54 UTC
Thank you very much for the files you provided. I will commit this as soon as I find time (i.e. the weekend).

Comment 4 Felix Kaechele 2012-02-04 19:38:58 UTC
Well, as you can see I didn't manage to sort this out as of now. I tried building this for F17 and it failed due to GCC 4.7 being stricter. I unfortunately don't have the time to fix this anytime soon. Is there anyone here interested in taking over?

Comment 5 Gwyn Ciesla 2012-04-19 20:05:40 UTC
I'll take a look.

Comment 6 Gwyn Ciesla 2012-04-20 13:07:30 UTC
Migrated, and it builds fine in f18 now.  Done.

Comment 7 Nerijus Baliūnas 2012-04-20 13:22:17 UTC
Will it be in F17 too?

Comment 8 Gwyn Ciesla 2012-04-20 13:28:08 UTC
No, we're post-beta, that's too big a change.  Just f18+.

Comment 9 Nerijus Baliūnas 2012-04-20 14:13:53 UTC
Actually I had a problem when starting dansguardian by /etc/rc.d/init.d/dansguardian (it just hanged). So it'd be nice to include it in F17 too.

Comment 10 Gwyn Ciesla 2012-04-20 14:20:54 UTC
If the initscript is already broken, and it's ok with Felix, I'll do that.

Comment 11 Felix Kaechele 2012-04-20 14:26:20 UTC
Sure. If you like you can become a co-maintainer, as I currently don't have that much time. I expect that to change in the future though :D

Comment 12 Fedora Update System 2012-04-20 14:54:04 UTC
dansguardian-2.10.1.1-9.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/dansguardian-2.10.1.1-9.fc17

Comment 13 Gwyn Ciesla 2012-04-20 14:55:32 UTC
Done, please test and give feedback on the Bodhi update.

Comment 14 Nerijus Baliūnas 2012-04-20 15:28:30 UTC
It works, thanks!

Comment 15 Fedora Update System 2012-05-04 23:07:29 UTC
dansguardian-2.10.1.1-9.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.