Bug 772135 - gcc-4.7.0-0.4.fc17 armv7hl FTBFS
Summary: gcc-4.7.0-0.4.fc17 armv7hl FTBFS
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2012-01-06 05:21 UTC by Dennis Gilmore
Modified: 2012-02-02 11:53 UTC (History)
2 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2012-02-02 11:53:14 UTC


Attachments (Terms of Use)
simplify-rtx.gcda (24.28 KB, application/octet-stream)
2012-01-06 15:39 UTC, Dennis Gilmore
no flags Details
simplify-rtx.i (1016.09 KB, application/octet-stream)
2012-01-06 15:50 UTC, Dennis Gilmore
no flags Details

Description Dennis Gilmore 2012-01-06 05:21:27 UTC
Description of problem:
../../gcc/simplify-rtx.c: In function 'simplify_subreg':
../../gcc/simplify-rtx.c:5753:1: internal compiler error: output_operand: invalid shift operand
Please submit a full bug report,             
with preprocessed source if appropriate.     
See <http://bugzilla.redhat.com/bugzilla> for instructions.
The bug is not reproducible, so it is likely a hardware or OS problem.
make[3]: *** [simplify-rtx.o] Error 1
make[3]: *** Waiting for unfinished jobs....
rm gcj-dbtool.pod gij.pod jcf-dump.pod jv-convert.pod grmic.pod gcov.pod gcj.pod cpp.pod gfdl.pod fsf-funding.pod gc-analyze.pod gcc.pod gfortran.pod
make[3]: Leaving directory `/builddir/build/BUILD/gcc-4.7.0-20120105/obj-armv7hl-redhat-linux-gnueabi/gcc'
make[2]: *** [all-stagefeedback-gcc] Error 2
make[2]: Leaving directory `/builddir/build/BUILD/gcc-4.7.0-20120105/obj-armv7hl-redhat-linux-gnueabi'
make[1]: *** [stagefeedback-bubble] Error 2
make[1]: Leaving directory `/builddir/build/BUILD/gcc-4.7.0-20120105/obj-armv7hl-redhat-linux-gnueabi'
make: *** [profiledbootstrap] Error 2


there is no preprocessed source available

full build log is at http://ausil.us/gcc-4.7.0-0.4.fc17-armv7hl-build.log

Comment 1 Jakub Jelinek 2012-01-06 08:22:17 UTC
Is it reproduceable?
"The bug is not reproducible, so it is likely a hardware or OS problem."
suggests that it is not, the driver in case of ICEs retries to compile the same source 3 times and if they don't fail the same all the time, which is this case, it is likely HW bug.  Of course there are chances that this 3 times rebuild doesn't work reliably after being ported to 4.7 (in 4.6 I'm pretty sure it is), but there haven't been any significant changes to it, or there might be a bug triggered by ASLR.  So, even if you can't reproduce it, please try to stop the build after this spot and try to run the simplify-rtx.c -fprofile-use compilation many times in a loop to see if it triggers.  Unfortunately this is FDO, so it might depend on the simplify-rtx.gcda file changing concurrently from other compilations.

Comment 2 Jakub Jelinek 2012-01-06 08:34:38 UTC
And if you can reproduce it, I'm interested in both the preprocessed source (simplify-rtx.i) and simplify-rtx.gcda as well.

Comment 3 Dennis Gilmore 2012-01-06 15:39:47 UTC
Created attachment 551177 [details]
simplify-rtx.gcda

Comment 4 Dennis Gilmore 2012-01-06 15:50:34 UTC
Created attachment 551182 [details]
simplify-rtx.i

Comment 5 Peter Robinson 2012-02-02 11:53:14 UTC
well and truly fixed. Jakub thank you for your assistance


Note You need to log in before you can comment on or make changes to this bug.