Bug 772200 - Date check of importing manifest shouldn't be applied across orgs
Date check of importing manifest shouldn't be applied across orgs
Status: CLOSED CURRENTRELEASE
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.0.0
Unspecified Unspecified
high Severity high
: ---
: 1.0
Assigned To: Bryan Kearney
SAM QE List
:
Depends On: 769644
Blocks: 703617
  Show dependency treegraph
 
Reported: 2012-01-06 07:16 EST by yu zheng
Modified: 2012-04-26 20:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-04-26 20:21:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yu zheng 2012-01-06 07:16:21 EST
Description of problem:
During importing a manifest to an org, date check against other manifest which has been imported to another org was done. But they should not affect each other.

Version-Release number of selected component (if applicable):
katello-headpin-all-0.1.122-2.el6.noarch
thumbslug-0.0.21-1.el6.noarch

How reproducible:
always

Steps to Reproduce:
1.Prepare two manifests which are exported separately from two different distributors. manifest2 is exported earlier than manifest1. 

2.Create two orgs in SAM: org1, org2.

3.Import manifest1 to org1.
[root@sam-120106095640 ~]# headpin -u admin -p admin provider import_manifest --file=/root/manifest1.zip --name="Red Hat" --org=org1
Manifest imported

4.Try to import manifest2 to org2.
[root@sam-120106095640 ~]# headpin -u admin -p admin provider import_manifest --file=/root/manifest2.zip --name="Red Hat" --org=org2
Importing manifest, please wait... Manifest import for provider [ Red Hat ] failed, Candlepin::Owner: 409 Conflict {"displayMessage":"Import is older than existing data"} (POST /candlepin/owners/org2/imports)
  
Actual results:
Importing manifest is failed.

Expected results:
Existing data in org1 shouldn't affect and manifest2 should be imported to org2 successfully.
Comment 3 Eric Sammons 2012-01-10 08:25:02 EST
This issue appears to be related to / duplicate of 769644 and 769372.
Comment 4 Tom McKay 2012-01-25 08:25:15 EST
Fixed in candlepin 0.5.10
Comment 5 Eric Sammons 2012-02-07 10:39:53 EST
http://hudson.rhq.lab.eng.bos.redhat.com:8080/hudson/job/headpin-webui%20automation/147/HTML_Report/

katello-headpin-all-0.1.130-2.el6.noarch

VERIFIED

Note You need to log in before you can comment on or make changes to this bug.