Bug 772236 - Use %_cups_serverbin macro
Use %_cups_serverbin macro
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: bluez (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-06 09:49 EST by Tim Waugh
Modified: 2013-02-05 12:04 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-05 12:03:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Waugh 2012-01-06 09:49:50 EST
Description of problem:
Rather than having to hard-code /usr/lib/cups/... you can now use the %_cups_serverbin macro provided by the cups-devel package.

Add this to the spec file in order to use this macro, which is available starting in Fedora 15:

BuildRequires: cups-devel

Incidentally, it looks like the upstream package installs the backend in /usr/lib64/cups/backend in any case, which is wrong.  Instead it should use 'cups-config --serverbin' to find out where to put it.

Version-Release number of selected component (if applicable):
bluez-4.97-1.fc17
Comment 1 Fedora Update System 2012-11-21 12:29:09 EST
bluez-4.101-4.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/bluez-4.101-4.fc18
Comment 2 Fedora Update System 2012-11-21 15:54:35 EST
Package bluez-4.101-4.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing bluez-4.101-4.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-18715/bluez-4.101-4.fc18
then log in and leave karma (feedback).
Comment 3 Fedora Update System 2013-01-10 06:02:28 EST
bluez-4.101-6.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/bluez-4.101-6.fc18
Comment 4 Fedora Update System 2013-02-05 12:04:04 EST
bluez-4.101-6.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.