Bug 772371 - [abrt] java-1.6.0-openjdk-1.6.0.0-61.1.10.4.fc16: __GI_raise: Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
[abrt] java-1.6.0-openjdk-1.6.0.0-61.1.10.4.fc16: __GI_raise: Process /usr/li...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Alexander Kurtakov
Fedora Extras Quality Assurance
abrt_hash:06d6fc6dbe1016dce712163f9cc...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-06 20:47 EST by Emmett Culley
Modified: 2012-01-09 08:25 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-09 08:25:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (64.88 KB, text/plain)
2012-01-06 20:47 EST, Emmett Culley
no flags Details
File: maps (42.41 KB, text/plain)
2012-01-06 20:47 EST, Emmett Culley
no flags Details
File: dso_list (11.78 KB, text/plain)
2012-01-06 20:47 EST, Emmett Culley
no flags Details

  None (edit)
Description Emmett Culley 2012-01-06 20:47:36 EST
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 3
cmdline:        /usr/bin/java -Xms128m -Xmx512m -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -Dorg.eclipse.swt.browser.UseWebKitGTK=true -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles -XX:MaxPermSize=256m -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar -os linux -ws gtk -arch x86_64 -showsplash -launcher /usr/lib64/eclipse/eclipse -name Eclipse --launcher.library /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher.gtk.linux.x86_64_1.1.100.v20110505/eclipse_1407.so -startup /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar --launcher.overrideVmargs -exitdata 7850046 -vm /usr/bin/java -vmargs -Xms128m -Xmx512m -Dorg.eclipse.equinox.p2.reconciler.dropins.directory=/usr/share/eclipse/dropins -Dorg.eclipse.swt.browser.UseWebKitGTK=true -XX:CompileCommand=exclude,org/eclipse/core/internal/dtree/DataTreeNode,forwardDeltaWith -XX:CompileCommand=exclude,org/eclipse/jdt/internal/compiler/lookup/ParameterizedMethodBinding,<init> -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/dom/parser/cpp/semantics/CPPTemplates,instantiateTemplate -XX:CompileCommand=exclude,org/eclipse/cdt/internal/core/pdom/dom/cpp/PDOMCPPLinkage,addBinding -XX:CompileCommand=exclude,org/python/pydev/editor/codecompletion/revisited/PythonPathHelper,isValidSourceFile -XX:CompileCommand=exclude,org/python/pydev/ui/filetypes/FileTypesPreferencesPage,getDottedValidSourceFiles -XX:MaxPermSize=256m -jar /usr/lib64/eclipse//plugins/org.eclipse.equinox.launcher_1.2.0.v20110502.jar
crash_function: __GI_raise
executable:     /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java
kernel:         3.1.6-1.fc16.x86_64
pid:            7767
pwd:            /home/emmett
reason:         Process /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java was killed by signal 6 (SIGABRT)
reported_to:    file: /home/emmett/crash.log
time:           Fri 06 Jan 2012 05:29:15 PM PST
uid:            500
username:       emmett
xsession_errors: 

backtrace:      Text file, 66440 bytes
dso_list:       Text file, 12059 bytes
maps:           Text file, 43424 bytes

build_ids:
:80d1527bdbaa66a7f4467a3432a25332fb76758a
:1c6a95451ee19617be5abea3d121f0226d21ddda
:dc998e8c1e1dc44c684b9b86e753945a868e134a
:aaf7ed41612348bd1141db06cadd428244aa6ea5
:c86be19fed841233083673fe240fc61d9403a2be
:fd8a00c88eb1fd6872e45001f9ed4e5c6172995e
:537baebd2d24f735e535379dbfbe440b51868377
:ec72f897bbac2f33aadee57e01b7e01bbed4c534
:3ed9e61c2b7e707ce244816335776afa2ad0307d
:aa733447f84020c94a66814e501a36e248cbb43d
:e3c88cb9ea428bd61f4064dbd53acae2d396a1ec
:af30fb8d81d37c69c3c36148a193d226768adf45
:87461d97d0ba0bd94e4d74ff0879190b67b326c5
:f0d9547bc79fe4db4890a1ac0538203acc427ace
:5e8c36ca13a4af14fa6b1b45a0dbfb43ed6aed6e
:ab59942678bcdecb23756804dcd0aac63ccc1669
:942252a47b2f35dd8fd89468546c58591ca246e8
:c124e79ca47fee27b34b962e8144fd5ae98f1dae
:7110c8ac5ea9a650cbf77c51e8cc1df7c407fafd
:d11221f5ec057534aca4f441d932cde1b342e81f
:30af62b93e2ab7dbaf39c52e346cd52101b4b590
:9d1209fc79304f03cc839de1c0036c61b48dfff8
:28b0338d675569b5152de3d68df0fe884d085d56
:638db099ff5fb986d1a092629d1bb1dca5be4904
:e5429e0905bedecc534b057783916ba43e06a66e
:44ece411beb2ef1acdb5eb2161666de41cc2f31d
:36a149d1e2c29890b616402f6bc5e3f69ca2738e
:a594ab36356a9b6dc6ecf25a6124463ccbfd0a29
:8264e35452b2a930c1b9b092b87f32d42d69d8c5
:12ebe599358398f2c1a5294bb2dd387545474b65
:aaf62304b0fc10611d35b4f56005479d4c58868d
:c8a4e40c84c2f52e78c64d31efc0191c565a9049
:7f43019ed67dc2e8f999aa61624bb1d95390d1cc
:0f0c9eed63ed279ceb0aef109eff8bcbb351e4bb
:163b323da65b708418226eb5fa8b057c731d1475
:e2e67b3ae2579e1667b73ad385f61552931024e9
:0911ea7c180d733724f89037b8e8a34e64024aec
:959956292c316a2f423f640353b314e92b511277
:ccadad4ec7dab3bb6abc23f9d4cdf53ff01cb235
:6ecc3efaedf849a17c30a67fe15b4dacca1bd981
:48aea888319e1848137073c9cbde54a4c2a731c9
:4a7e68edf2778a9fbd3d4a8fbd3f9d1e7b785fc6
:4953d1f613914126bccceb3cb96386647ffba9df
:d460d68692c1b32346f469e0a9ab3933cf1f3d1c
:b0eabf9093defbfdd0857ea3ed1a4563b743434e
:4c842320387ff7f6f91b7842b223c16518be909f
:2baea27d41ef400c9b7be6df72a8affa5c44b60e
:f0d50e3af2dfee021a327fb85a993a2312a98145
:b0a2d0b4c09d819887ec7d711c8cf3977a074c4f
:7994f114cf7189e482f2665fae8e351ed8bc05e3
:07470201df55a5254027d05fa4dc509b10f2986a
:374add1ead31ccb449779bc7ee7877de3377e5ad
:be507c791e34415e8f42f0e6030c889b2895cf9a
:fa7dc878221deb8be2b164c150a23f7e75c8c289
:472e8613d0c06cb06b250f07d49ddb6abeeecf0e
:1c2ccaf923ac61efd874e4ca82bf6612f4cb0c31
:daec0ba0ef53c9f6c098d2b47f5974fa82aff498
:e5d7ac2dfe435e205e491f7ce827563859fca4f4
:2d48b3589b903d9be7d3340da87c7711e8870be8
:8acc43df965b3c0a70dcfad11c0ade056bdb055b
:3e2404bd469800afd61eda83d0292a2165ef0db0
:82cca0d5b06a649072a966dc4f05aded63d736bc
:921b64859b34786348daf376801c05efbf9bac81
:c8e7f118041a9f77e0dd673da11b5653be27b5a2
:c2d49d72ec1a1e68b39c3724693f83f44d80a259
:30d222cbaa7087ff6613d2737d967fc570ec8a72
:650b733aecfb9c46bdfc023661f19244a278df04
:bf541d741fd726e3d78daab0e3afaa81807f7e77
:a518a8b1b5c3e80dee813df05e951d205d6ac48c
:0a607cc62055e88126e254c2ec5604a8e0575ff1
:88d586ed67ebe5227b761b4ab2e02433f29c840f

comment:
:Moved directory structure from olle (CentOS  5.7) machine to Fedora 16 machine (same location).  Copied ~/.eclipse directory to new machine.  Started Eclipse via the KDE menu and selecte the newly copied directoty as the working directory.
:
:Then this crash.

environ:
:XDG_VTNR=1
:SSH_AGENT_PID=1929
:XDG_SESSION_ID=4
:DM_CONTROL=/var/run/xdmctl
:HOSTNAME=ws1.webengineer.com
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:XDG_MENU_PREFIX=kde4-
:SHELL=/bin/bash
:TERM=dumb
:XDG_SESSION_COOKIE=d37bf22c87e40260a8e9054700000019-1325644507.482314-659925299
:XDM_MANAGED=method=classic
:HISTSIZE=1000
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/emmett/.gtkrc-2.0:/home/emmett/.gtkrc-2.0-kde4:/home/emmett/.kde/share/config/gtkrc-2.0
:GS_LIB=
:GNOME_KEYRING_CONTROL=/tmp/keyring-3r8uBX
:QTDIR=/usr/lib64/qt-3.3
:QTINC=/usr/lib64/qt-3.3/include
:KDE_FULL_SESSION=true
:IMSETTINGS_MODULE=none
:USER=emmett
:SSH_AUTH_SOCK=/tmp/ssh-dSBiLpww1778/agent.1778
:DESKTOP_SESSION=kde-plasma
:PATH=/usr/lib64/qt-3.3/bin:/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/local/sbin:/usr/sbin:/sbin:/home/emmett/.local/bin:/home/emmett/bin
:MAIL=/var/spool/mail/emmett
:QT_IM_MODULE=xim
:PWD=/home/emmett
:XMODIFIERS=@im=none
:EDITOR=nano
:KDE_SESSION_UID=500
:GNOME_KEYRING_PID=1776
:LANG=en_US.UTF-8
:KDE_IS_PRELINKED=1
:KDEDIRS=/usr
:HISTCONTROL=ignoredups
:SSH_ASKPASS=/usr/bin/ksshaskpass
:SHLVL=2
:XDG_SEAT=seat0
:HOME=/home/emmett
:KDE_SESSION_VERSION=4
:LOGNAME=emmett
:CVS_RSH=ssh
:QTLIB=/usr/lib64/qt-3.3/lib
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-uGAvgSKbMD,guid=64b56733b113a2d647279b0a000026ff
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/emmett
:DISPLAY=:0
:QT_PLUGIN_PATH=/home/emmett/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:GTK_IM_MODULE=gtk-im-context-simple
:XAUTHORITY=/tmp/kde-emmettdXnbcl/xauth-500-_0
:_=/usr/libexec/kde4/start_kdeinit_wrapper
:KDE_MULTIHEAD=false
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/2038,unix/unix:/tmp/.ICE-unix/2038
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/emmett/.gtkrc:/home/emmett/.kde/share/config/gtkrc
:XCURSOR_THEME=default
:DESKTOP_STARTUP_ID=ws1.webengineer.com;1325899728;916063;2080_TIME265204515
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/lib/amd64:/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/../lib/amd64

smolt_data:
:
:
:General
:=================================
:UUID: ef403bae-6b67-4f3d-974e-920e19208257
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 3999.76
:CPU Vendor: AuthenticAMD
:CPU Model: Dual-Core AMD Opteron(tm) Processor 2212
:CPU Stepping: 2
:CPU Family: 15
:CPU Model Num: 65
:Number of CPUs: 4
:CPU Speed: 2000
:System Memory: 7986
:System Swap: 7573
:Vendor: ASUSTek Computer INC.
:System: KFN5-D SLI Rev 1.xx
:Form factor: Desktop
:Kernel: 3.1.6-1.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Permissive
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4318:880:4163:33264) pci, None, PCI/PCI, MCP55 PCI bridge
:(4318:881:4163:33296) pci, snd_hda_intel, MULTIMEDIA, MCP55 High Definition Audio
:(4318:873:4163:33264) pci, None, RAM, MCP55 Memory Controller
:(4318:872:4163:33264) pci, nForce2_smbus, SERIAL, MCP55 SMBus
:(4318:868:4163:33264) pci, None, PCI/ISA, MCP55 LPC Bridge
:(4172:32803:4163:33115) pci, firewire_ohci, FIREWIRE, P5W DH Deluxe Motherboard
:(5348:5754:4163:33289) pci, tg3, ETHERNET, NetXtreme BCM5754 Gigabit Ethernet PCI Express
:(4130:4352:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] HyperTransport Technology Configuration
:(4130:4353:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] Address Map
:(4130:4354:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] DRAM Controller
:(4130:4355:0:0) pci, k8temp, HOST/PCI, K8 [Athlon64/Opteron] Miscellaneous Control
:(4130:4353:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] Address Map
:(4130:4352:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] HyperTransport Technology Configuration
:(4130:4355:0:0) pci, k8temp, HOST/PCI, K8 [Athlon64/Opteron] Miscellaneous Control
:(4130:4354:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] DRAM Controller
:(4245:12594:4163:33183) pci, sata_sil24, STORAGE, SiI 3132 Serial ATA Raid II Controller
:(5348:5754:4163:33289) pci, tg3, ETHERNET, NetXtreme BCM5754 Gigabit Ethernet PCI Express
:(4318:876:4163:33264) pci, ohci_hcd, USB, MCP55 USB Controller
:(4318:877:4163:33264) pci, ehci_hcd, USB, MCP55 USB Controller
:(4318:888:4318:0) pci, pcieport, PCI/PCI, MCP55 PCI Express bridge
:(4318:887:4318:0) pci, pcieport, PCI/PCI, MCP55 PCI Express bridge
:(4318:467:5762:8830) pci, nouveau, VIDEO, G72 [GeForce 7300 SE/7200 GS]
:(4318:878:4163:33264) pci, pata_amd, STORAGE, MCP55 IDE
:(4318:884:4318:0) pci, pcieport, PCI/PCI, MCP55 PCI Express bridge
:(4318:895:4163:33264) pci, sata_nv, STORAGE, MCP55 SATA Controller
:(4318:895:4163:33264) pci, sata_nv, STORAGE, MCP55 SATA Controller
:(4318:895:4163:33264) pci, sata_nv, STORAGE, MCP55 SATA Controller
:(4318:884:4318:0) pci, pcieport, PCI/PCI, MCP55 PCI Express bridge
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/ws1-root1 / ext4 4096 4096 5160607 1831916 1569772 1310720 973934 973934
:/dev/mapper/ws1-var1 /var ext4 4096 4096 10321232 9883123 9358835 2621440 2603381 2603381
:/dev/mapper/ws1-home1 /home ext4 4096 4096 6555411 1574429 1241425 1667904 1619300 1619300
:/dev/mapper/ws1-home WITHHELD ext4 4096 4096 6547732 3391290 3059480 1659728 1624052 1624052
:/dev/mapper/ws1-var WITHHELD ext4 4096 4096 49388357 49214773 46705973 12550144 12545697 12545697
:/dev/mapper/ws1-root WITHHELD ext4 4096 4096 5289623 3733351 3464654 1343488 1125593 1125593
:

var_log_messages:
:Jan  5 21:50:16 ws1 yum[3184]: Installed: gdata-java-1.45.0-1.fc16.noarch
:Jan  6 17:29:18 ws1 abrt[7824]: Saved core dump of pid 7767 (/usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0.x86_64/jre/bin/java) to /var/spool/abrt/ccpp-2012-01-06-17:29:15-7767 (223752192 bytes)
Comment 1 Emmett Culley 2012-01-06 20:47:40 EST
Created attachment 551317 [details]
File: backtrace
Comment 2 Emmett Culley 2012-01-06 20:47:42 EST
Created attachment 551318 [details]
File: maps
Comment 3 Emmett Culley 2012-01-06 20:47:43 EST
Created attachment 551319 [details]
File: dso_list
Comment 4 Omair Majid 2012-01-07 02:23:26 EST
The crash seems to have occurred in swt code (but it might be a gtk problem - I cant say)

#5  <signal handler called>
No symbol table info available.
#6  0x00000035ebe186d0 in g_object_get_qdata (object=0x7f9b7c53f9c0, quark=614) at gobject.c:2816
        __inst = 0x7f9b7c53f9c0
        __r = <optimized out>
        _g_boolean_var_ = <optimized out>
        __PRETTY_FUNCTION__ = "g_object_get_qdata"
#7  0x00007f9b788ffcfe in Java_org_eclipse_swt_internal_gtk_OS__1g_1object_1get_1qdata () from /home/emmett/.eclipse/org.eclipse.platform_3.7.0_793567567/configuration/org.eclipse.osgi/bundles/115/1/.cp/libswt-pi-gtk-3738.so

Ressigning to eclipse folks as they will know more about this.
Comment 5 Emmett Culley 2012-01-07 11:27:37 EST
After this happpend I tried to start eclipse again.  It prompted me again for the workspace directory and I entered the same newly copied directory.  Then Eclipse started normally.  So it did not crash again and seems to be working correctly.

I don't see my "what happened" notes above so I'll write them again, as I believe they might explain this one time crash.  I had copied the workspace directory from another machine with CentOS 5.7 to my Fedora 16 workstation.  I also copied the .eclipse directory from the old Fedora 15 home directory to the new.

The crash happend only the first time I attemted to start Eclipse.
Comment 6 Andrew Overholt 2012-01-09 08:25:31 EST
(In reply to comment #5)
> I also copied the .eclipse directory from the old Fedora 15 home
> directory to the new.

I think this is what caused the problem.  You'll note that the swt library location in the stack trace is in ~/.eclipse.  That seems to have been used the first time instead of the libraries in /usr/lib/eclipse.

I'd say if it happens again we can re-investigate but if not let's chalk it up to an edge case with moving the home directory (which really shouldn't have had SWT shared libraries in it but that's another story :) ).  I'll close this but like I said, re-open if it happens again.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.