Bug 772400 - system does not always shutdown immediately
system does not always shutdown immediately
Status: CLOSED DUPLICATE of bug 739836
Product: Fedora
Classification: Fedora
Component: systemd (Show other bugs)
16
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: systemd-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-07 11:12 EST by hannes
Modified: 2012-01-11 19:29 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-11 19:29:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
dmesg output from affected shutdown (122.28 KB, text/plain)
2012-01-11 18:17 EST, hannes
no flags Details

  None (edit)
Description hannes 2012-01-07 11:12:55 EST
Description of problem:
Hi, 
since quite some time I observe a random pattern that the system does not shutdown immediately. Sometimes it works and sometimes it kills the X Server and stays in the console for some time (approx 3min timeout) until the shutdown process continues. 
I have no idea how to debug this since I don't have the possibility to access it via ssh. I already added systemd.log_level=debug systemd.log_target=kmsg to the grub.cfg. Let me know how I could give you information and I will do so.

Version-Release number of selected component (if applicable):
systemd-gtk-37-3.fc16.x86_64
systemd-37-3.fc16.x86_64
systemd-units-37-3.fc16.x86_64
systemd-sysv-37-3.fc16.x86_64

How reproducible:
random - no pattern detected
Comment 1 Michal Schmidt 2012-01-09 09:07:10 EST
Make sure SELinux is permissive or disabled.
Save this script as /lib/systemd/system-shutdown/debug :

#!/bin/sh
mount -o remount,rw /
dmesg > /dmesg-shutdown.txt
mount -o remount,ro /

Make it executable. When you reproduce the problem, attach the dmesg-shutdown.txt file to this BZ. Thanks.
Comment 2 hannes 2012-01-11 18:17:54 EST
Created attachment 552253 [details]
dmesg output from affected shutdown
Comment 3 hannes 2012-01-11 18:18:39 EST
The problem just occured again. Hope that the output is helpful.
Comment 4 Michal Schmidt 2012-01-11 19:29:03 EST
[10221.500594] systemd[1]: NetworkManager.service stopping timed out. Killing.

*** This bug has been marked as a duplicate of bug 739836 ***

Note You need to log in before you can comment on or make changes to this bug.