Bug 77247 - Problems with XFree86 after changing system clock
Problems with XFree86 after changing system clock
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
8.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2002-11-04 02:19 EST by Need Real Name
Modified: 2007-04-18 12:48 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-14 10:58:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X server log file (671.88 KB, text/plain)
2002-11-04 19:09 EST, Need Real Name
no flags Details
X config file (3.46 KB, text/plain)
2002-11-04 19:12 EST, Need Real Name
no flags Details
This patch seems to solve my problem. (803 bytes, patch)
2002-11-07 18:53 EST, Need Real Name
no flags Details | Diff

  None (edit)
Description Need Real Name 2002-11-04 02:19:08 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.0.1) Gecko/20021003

Description of problem:
XFree86-4.2.0: the keys do not repeat after changing system time backwards.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Change the system clock a coupel of minutes backwards using `date'.

2. The keys do not repeat any more under X before system time gets
   to the point when the time was changed. On my laptop (ATI Rage     
   Mob.), the windows are also frozen (i.e., they can't be dragged).

   I ran into this problem after suspending/resuming my laptop and
   finally I figured out that the problem was caused by the
   'hwclock' command in /etc/sysconfig/apm-scripts/apmscript

   I believe that this bug is related to some timing functions
   in XFree86 4.2.0

Additional info:
Comment 1 Mike A. Harris 2002-11-04 03:45:08 EST
I probably don't need it, but just in case.... could you attach your
X server config file and log?  It might come in handy perhaps while
troubleshooting.
Comment 2 Thais Smith 2002-11-04 06:03:10 EST
Might this be because X events are timestamped? "Old" events would therefore 
get ignored. I get the same problem when correcting the clock under a number 
of different window managers (kwin, metacity, afterstep). Quick workaround is 
to switch to another VT and back again. Just a thought.
Comment 3 Need Real Name 2002-11-04 19:09:09 EST
Created attachment 83604 [details]
X server log file
Comment 4 Need Real Name 2002-11-04 19:11:27 EST
Switching to a VT then back does not solve the problem.

I have attached my X config/log files.
Comment 5 Need Real Name 2002-11-04 19:12:03 EST
Created attachment 83605 [details]
X config file
Comment 6 Need Real Name 2002-11-07 18:53:58 EST
Created attachment 84104 [details]
This patch seems to solve my problem.
Comment 7 pedro_rodriguez 2002-11-13 13:18:21 EST
There is a also a fix by Egbert Eich in xfree cvs :

http://cvsweb.xfree86.org/cvsweb/xc/programs/Xserver/hw/xfree86/common/xf86Io.c.diff?r1=3.49&r2=3.50

290. Fixed GetTimeInMillis() to use deltas instead of absolute time
     returend by gettimeofday(). This ensures time is monotonic in X
     (Egbert Eich).
Comment 8 Mike A. Harris 2002-12-14 10:58:09 EST
Indeed Egbert's fix is in CVS.  I have backported the fix to 4.2.1 and 4.1.0,
and it will appear in all future erratum releases.

Thanks guys.

Note You need to log in before you can comment on or make changes to this bug.