Bug 772551 - USB Passthrough Generates qemu-kvm process assertion shutdown
USB Passthrough Generates qemu-kvm process assertion shutdown
Status: CLOSED DUPLICATE of bug 769625
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
16
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Justin M. Forbes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-01-09 02:37 EST by gcarter
Modified: 2013-01-09 19:40 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-01-30 15:03:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description gcarter 2012-01-09 02:37:40 EST
Description of problem:
Using USB passthrough fails.

Version-Release number of selected component (if applicable):
qemu-kvm-0.15.1

How reproducible:
Insert Wireless USB, assign in virt-manager to virtual machine.


Steps to Reproduce:
1. Insert USB Wireless device
2. start virtual machine
3. login KDE, try to access and use USB device
  
Actual results:
qemu-kvm process shutdown



Expected results:
Should use USB wireless device OK.

Additional info:
qemu-kvm process log dump:

2012-01-09 07:27:26.975+0000: starting up
LC_ALL=C PATH=/sbin:/usr/sbin:/bin:/usr/bin QEMU_AUDIO_DRV=none /usr/bin/qemu-kvm -S -M pc-0.14 -enable-kvm -m 1024 -s\
mp 1,sockets=1,cores=1,threads=1 -name Fedora16 -uuid 294e95c9-0b7b-8bb0-af36-3c2e0bf9ecfe -nodefconfig -nodefaults -c\
hardev socket,id=charmonitor,path=/var/lib/libvirt/qemu/Fedora16.monitor,server,nowait -mon chardev=charmonitor,id=mon\
itor,mode=control -rtc base=utc -device virtio-serial-pci,id=virtio-serial0,bus=pci.0,addr=0x5 -drive file=/mnt/ssd/Fe\
dora16/Fedora16Dev,if=none,id=drive-virtio-disk0,format=raw,cache=writeback -device virtio-blk-pci,bus=pci.0,addr=0x6,\
drive=drive-virtio-disk0,id=virtio-disk0,bootindex=1 -drive if=none,media=cdrom,id=drive-ide0-1-0,readonly=on,format=r\
aw -device ide-drive,bus=ide.1,unit=0,drive=drive-ide0-1-0,id=ide0-1-0 -netdev tap,fd=23,id=hostnet0 -device virtio-ne\
t-pci,netdev=hostnet0,id=net0,mac=52:54:00:d9:e9:db,bus=pci.0,addr=0x3 -chardev pty,id=charserial0 -device isa-serial,\
chardev=charserial0,id=serial0 -usb -device usb-tablet,id=input0 -vnc 127.0.0.1:1 -vga cirrus -device intel-hda,id=sou\
nd0,bus=pci.0,addr=0x4 -device hda-duplex,id=sound0-codec0,bus=sound0.0,cad=0 -device usb-host,hostbus=2,hostaddr=8,id\
=hostdev0 -device virtio-balloon-pci,id=balloon0,bus=pci.0,addr=0x7
char device redirected to /dev/pts/8
husb: open device 2.8
husb: config #1 need -1
husb: 1 interfaces claimed for configuration 1
husb: grabbed usb device 2.8
husb: config #1 need 1
husb: 1 interfaces claimed for configuration 1
husb: config #1 need 1
husb: 1 interfaces claimed for configuration 1
husb: config #1 need 1
husb: 1 interfaces claimed for configuration 1
husb: config #1 need 1
husb: 1 interfaces claimed for configuration 1
qemu-kvm: malloc.c:3805: _int_malloc: Assertion `victim->fd_nextsize->bk_nextsize == victim' failed.
2012-01-09 07:28:14.070+0000: shutting down
Comment 1 Justin M. Forbes 2012-01-30 15:03:26 EST

*** This bug has been marked as a duplicate of bug 769625 ***

Note You need to log in before you can comment on or make changes to this bug.