Bug 772637 - Generated PNG files are different on various arches
Summary: Generated PNG files are different on various arches
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: graphviz
Version: 6.2
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Miroslav Hradílek
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-09 13:44 UTC by Honza Horak
Modified: 2012-09-19 10:17 UTC (History)
2 users (show)

Fixed In Version: graphviz-2.26.0-8.el6
Doc Type: Bug Fix
Doc Text:
Previously dot could generate different images on i386 and x86_64 architectures, which could lead to multilib conflicts for packages that use graphviz during its build process. The problem was caused by i386 FPU. It's registers are wider than C double type and if compiled with -O2 more arithmetic is done in FPU registers. The error increases which finally could lead to round/trunc error and shift in output images. Now the code is compiled with -ffloat-store compiler flag on i386 and intermediate results are not stored in FPU registers. Also the -ffast-math compiler flag was removed, because the performance benefit is very low, but it could cause a lot of hard to debug problems.
Clone Of:
Environment:
Last Closed: 2012-09-19 10:17:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 658034 'medium' 'CLOSED' 'File conflicts between libisofs-devel multilib packages in Optional repo' 2019-12-03 13:06:13 UTC
Red Hat Product Errata RHBA-2012:1291 normal SHIPPED_LIVE graphviz bug fix update 2012-09-19 14:16:30 UTC

Internal Links: 658034

Description Honza Horak 2012-01-09 13:44:18 UTC
Description of problem:
During generating documentation of libisofs-devel-0.6.32 using doxygen there is a multilib conflict caused by different PNG images generated on i386 and x86_64. The problem is not caused by different timestamp, the images are really different (arrows are shifted by a couple of pixels). The mentioned multilib conflict is reported in bug #658034. I think PNG files should be the same regardless of arch.

Version-Release number of selected component (if applicable):
doxygen.i686 1:1.6.1-6.el6
doxygen.x86_64 1:1.6.1-6.el6

How reproducible:
every-time

Steps to Reproduce:
1. build libisofs-0.6.32 on i386 and x86_64
2. compare image /usr/share/doc/libisofs-devel-0.6.32/html/structiso__stream__coll__graph.png in both rpms
  
Actual results:
PNG images differ.

Expected results:
PNG images are same.

Additional info:

Comment 3 Suzanne Yeghiayan 2012-02-14 23:27:22 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unfortunately unable to
address this request at this time. Red Hat invites you to
ask your support representative to propose this request, if
appropriate and relevant, in the next release of Red Hat
Enterprise Linux. If you would like it considered as an
exception in the current release, please ask your support
representative.

Comment 4 Than Ngo 2012-06-27 15:48:50 UTC
it's a bug in graphviz, doxygen calls graphviz tools to create the png files. A workaround for libisofs is to set HAVE_DOT= no in doxygen.conf.in to not use dot from graphviz.

Comment 7 Jaroslav Škarvada 2012-07-25 09:17:07 UTC
Analysis of this problem written in Bug 827927 comment 5.

Comment 10 Jaroslav Škarvada 2012-07-25 14:03:42 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Previously dot could generate different images on i386 and x86_64 architectures, which could lead to multilib conflicts for packages that use graphviz during its build process. The problem was caused by i386 FPU. It's registers are wider than C double type and if compiled with -O2 more arithmetic is done in FPU registers. The error increases which finally could lead to round/trunc error and shift in output images. Now the code is compiled with -ffloat-store compiler flag on i386 and intermediate results are not stored in FPU registers. Also the -ffast-math compiler flag was removed, because the performance benefit is very low, but it could cause a lot of hard to debug problems.

Comment 14 errata-xmlrpc 2012-09-19 10:17:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1291.html


Note You need to log in before you can comment on or make changes to this bug.