Bug 772664 - libxklavier doesn't support GObject introspection (cannot be used easily in other languages)
Summary: libxklavier doesn't support GObject introspection (cannot be used easily in o...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libxklavier
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-09 14:58 UTC by Vratislav Podzimek
Modified: 2012-04-13 13:57 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-13 13:57:21 UTC


Attachments (Terms of Use)

Description Vratislav Podzimek 2012-01-09 14:58:36 UTC
Description of problem:
Since libxklavier doesn't support GObject introspection, it can't be used easily in other languages (e.g. in Python). There is a Python binding -- python-xklavier, but it cannot be used while using Gtk3 (it uses Gtk2 which leads into fatal errors -- tracebacks, segfaults).

How reproducible:
100%

Steps to Reproduce:
1. run: python -c "from gi.repository import Gtk; import xklavier"
  
Actual results:
Python segfaults.

Expected results:
Should work this way:

>>> from gi.repository Gtk, xklavier

Additional info:
This feauture is urgent for Anaconda installer.


Note You need to log in before you can comment on or make changes to this bug.