Bug 772850 - Status of provider's synchronization couldn't display via katello CLI
Status of provider's synchronization couldn't display via katello CLI
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.0.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Tom McKay
SAM QE List
: Triaged
Depends On:
Blocks: sam11-tracker
  Show dependency treegraph
 
Reported: 2012-01-10 01:27 EST by yu zheng
Modified: 2012-06-20 11:20 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
An attempt to query the repository sync status via "headpin provider status" resulted in an undefined method error. This update removes "provider status" from the headpin CLI because it is a redundant command.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 11:20:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yu zheng 2012-01-10 01:27:54 EST
Description of problem:
Command "headpin provider status" couldn't show status of provider's synchronization.

Version-Release number of selected component (if applicable):
katello-headpin-all-0.1.122-2.el6.noarch
katello-headpin-0.1.122-2.el6.noarch
katello-cli-headpin-0.1.13-2.el6.noarch
katello-cli-common-0.1.32-2.el6.noarch

How reproducible:
always

Steps to Reproduce:
1.Show status of provider's synchronization.
# headpin -u admin -p admin provider status --org=org1 --name="Red Hat"
  
Actual results:
undefined method `empty?' for #<Product:0x7f4337fd2ce0>

Expected results:
Status of provider's synchronization should display successfully.
Comment 1 Bryan Kearney 2012-04-27 13:38:56 EDT
Can not recreate with:

katello-certs-tools-1.0.6-1.el6.noarch
katello-cli-common-0.3.1-1.el6_2.noarch
katello-glue-candlepin-0.3.0-2.el6_2.noarch
katello-cli-headpin-0.2.0-1.el6_2.noarch
katello-headpin-0.2.4-3.el6_2.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-common-0.3.0-2.el6_2.noarch
katello-headpin-all-0.2.4-3.el6_2.noarch
katello-configure-upgrade-0.3.1-2.el6_2.noarch
katello-configure-0.3.1-2.el6_2.noarch
katello-selinux-0.1.10-1.el6.noarch
Comment 2 Tazim Kolhar 2012-04-30 04:05:30 EDT
Verified with the build :
[root@tyan-gt24-12 ~]# rpm -qa | grep katello
katello-configure-0.3.1-2.el6_2.noarch
katello-selinux-0.1.10-1.el6.noarch
katello-cli-headpin-0.2.0-1.el6_2.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-configure-upgrade-0.3.1-2.el6_2.noarch
katello-cli-common-0.3.1-1.el6_2.noarch
katello-glue-candlepin-0.3.0-2.el6_2.noarch
katello-certs-tools-1.0.6-1.el6.noarch
katello-headpin-0.2.4-3.el6_2.noarch
katello-common-0.3.0-2.el6_2.noarch
katello-headpin-all-0.2.4-3.el6_2.noarch


Actual Results produced :

[root@tyan-gt24-12 ~]# headpin -u admin -p admin provider list --org ACME_Corporation
--------------------------------------------------------------------------------
                                Provider List

 Id   Name      Type      Url                      Description  
--------------------------------------------------------------------------------
 1    Red Hat   Red Hat   https://cdn.redhat.com   None         

[root@tyan-gt24-12 ~]# headpin -u admin -p admin provider status --org ACME_Corporation --name "Red Hat"
undefined method `empty?' for #<Product:0x7f9994941af8>
Comment 3 Tom McKay 2012-05-10 08:53:25 EDT
  Branch: refs/heads/master
  Home:   https://github.com/Katello/katello
  Commit: 97fcd8838e5b43eacc23fc44d3e51ffe5a303d0d
      https://github.com/Katello/katello/commit/97fcd8838e5b43eacc23fc44d3e51ffe5a303d0d
  Author: Tom McKay <thomasmckay@redhat.com>
  Date:   2012-05-09 (Wed, 09 May 2012)

'provider status' command removed for headpin CLI
Comment 5 Tazim Kolhar 2012-05-21 01:56:23 EDT
VERIFIED with the build :

[root@dhcp201-111 ~]# rpm -qa | grep katello
katello-common-0.3.1-1.el6_2.noarch
katello-headpin-all-0.2.9-1.el6_2.noarch
katello-cli-common-0.3.4-1.el6_2.noarch
katello-selinux-0.2.4-1.el6_2.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.1.5-1.el6_2.noarch
katello-headpin-0.2.9-1.el6_2.noarch
katello-configure-0.3.5-1.el6_2.noarch
katello-glue-candlepin-0.3.1-1.el6_2.noarch
katello-cli-headpin-0.2.2-1.el6_2.noarch


[root@dhcp201-111 ~]# headpin -u admin -p admin provider --help
Usage: headpin <options> provider <action> <options>
Supported Actions:
	info           list information about a provider
	list           list all known providers
	import_manifest import a manifest file

Options:
  -h, --help  show this help message and exit


'provider status' removed from headpin-cli .
Comment 6 sachua 2012-06-13 23:12:24 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Command "headpin provider status" does not show status of provider's synchronization in CLI. This update removes the 'headpin provider status' from the CLI.
Comment 7 Dan Macpherson 2012-06-15 01:04:38 EDT
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Command "headpin provider status" does not show status of provider's synchronization in CLI. This update removes the 'headpin provider status' from the CLI.+An attempt to query the repository sync status via "headpin provider status" resulted in an undefined method error. This update removes "provider status" from the headpin CLI because it is a redundant command.
Comment 9 errata-xmlrpc 2012-06-20 11:20:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1021.html

Note You need to log in before you can comment on or make changes to this bug.