Bug 772875 - RFE: update pymongo package
Summary: RFE: update pymongo package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: pymongo
Version: rawhide
Hardware: All
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Silas Sewell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-01-10 08:19 UTC by Cristian Ciupitu
Modified: 2012-04-26 03:31 UTC (History)
2 users (show)

Fixed In Version: pymongo-2.1.1-1.fc16
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-04-26 03:31:54 UTC
Type: ---


Attachments (Terms of Use)

Description Cristian Ciupitu 2012-01-10 08:19:39 UTC
Description of problem:
Please update the pymongo package. The current version is outdated and it also does not support closing connections properly. The latest version is 2.1.1.

Version-Release number of selected component (if applicable):
pymongo-1.11-1.fc16.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. Run the following Python program

import pymongo
c = pymongo.Connection('localhost')
c.close()
  
Actual results:
Traceback (most recent call last):
  File "<stdin>", line 1, in <module>
  File "/usr/lib64/python2.7/site-packages/pymongo/database.py", line 622, in __call__
    "failing because no such method exists." % self.__name)
TypeError: 'Database' object is not callable. If you meant to call the 'close' method on a 'Connection' object it is failing because no such method exists.

Expected results:
No errors

Additional info:
The latest version (2.1.1) works fine.

Comment 1 Fedora Update System 2012-04-10 22:45:19 UTC
pymongo-2.1.1-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/pymongo-2.1.1-1.fc16

Comment 2 Pierre-YvesChibon 2012-04-11 05:07:42 UTC
Does it make sense to update on EL6 as well?

Comment 3 Pierre-YvesChibon 2012-04-11 05:08:24 UTC
Sorry I just saw the update is pending for EPEL6, all good for me :)

Comment 4 Fedora Update System 2012-04-12 11:29:49 UTC
Package pymongo-2.1.1-1.fc16:
* should fix your issue,
* was pushed to the Fedora 16 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing pymongo-2.1.1-1.fc16'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-5744/pymongo-2.1.1-1.fc16
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2012-04-26 03:31:54 UTC
pymongo-2.1.1-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.